Solved

Server ActiveSync Event Errors. Active Sync not working

Posted on 2010-11-19
11
797 Views
Last Modified: 2012-05-10
Greetings,

Exchange 2003 stopped allowing our iphones to sync via active sync. I am getting Event ID 3005  in the event vwr. When attempting to access the mailbox from the iphone , it is triggering the alert. Iphone reads "cannot get mail. The connection to the server failed.
Event Type:      Error
Event Source:      Server ActiveSync
Event Category:      None
Event ID:      3005
Date:            11/19/2010
Time:            2:31:07 PM
User:            Domain\User
Computer:      computer
Description:
Unexpected Exchange mailbox Server error: Server: [server.domain.com] User: [user@domain.com] HTTP status code: [501]. Verify that the Exchange mailbox Server is working correctly.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

The only successful post I have seen about this error is removing the headers from the default website in IIS. That did not resolve.
Any help on this would be great.

thank you !!
M.Magbee
0
Comment
Question by:gpaaw1
  • 4
  • 3
  • 2
  • +2
11 Comments
 
LVL 15

Expert Comment

by:getzjd
ID: 34176452
What are the results of this tool?  https://www.testexchangeconnectivity.com/
0
 

Author Comment

by:gpaaw1
ID: 34176564
ExRCA is testing Exchange ActiveSync.  
  The Exchange ActiveSync test failed.
   Test Steps
   Attempting to resolve the host name mail.soulsvillefoundation.org in DNS.
  The host name resolved successfully.
   Additional Details
  IP addresses returned: 64.132.114.250
 
 Testing TCP port 443 on host mail.soulsvillefoundation.org to ensure it's listening and open.
  The port was opened successfully.
 Testing the SSL certificate to make sure it's valid.
  The SSL certificate failed one or more certificate validation checks.
   Test Steps
   Validating the certificate name.
 
 
 
 
I do not have SSL , and have not for this server . But it was working without it for almost a year now.
0
 
LVL 16

Expert Comment

by:Viral Rathod
ID: 34176607
Please check the Active Sync Test without checking SSL.

Please review the newly revised following article from Alan to make sure you are not missing anything.
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34176730
Monitoring - I will also cleanup your IP Addresses . domain names once the question is concluded (or sooner if you wish).

Alan
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34176747
What is the reason for not using SSL  You can buy an SSL cert for $50 and that would secure your communications considerably.
0
Integrate social media with email signatures

Is your company active on social media? Do you also use email signatures? Including social media icons in your email signature is a great way to get fans for free. Let all your email users know you’re on social media quickly and easily, in a single click.

 

Author Comment

by:gpaaw1
ID: 34176768
Alan: SSL has been proposed; but working without it .

viralrathod: I have walked through the guide, other than the SSL options my config is spot on.
0
 
LVL 16

Expert Comment

by:Viral Rathod
ID: 34177762
do you have FE-BE topology or just back end server ?
0
 

Accepted Solution

by:
gpaaw1 earned 0 total points
ID: 34192041
Went over level one technician notes and saw that he added a registry key during initial troubleshooting.  This key should have only been added when creating a second virtual directory in IIS.  I pulled another 2003 exchange server and noted that the below key did not exist:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters\ExchangeVDir

The only time you should create this key is when you are creating a secondary virtual directory.

I removed this key, restarted the IIS admin service, and active sync is now working.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34192063
The only reason for creating the 2nd virtual Directory on an Exchange Server is if Forms Based Authentication is enabled and this forces SSL onto the Exchange Virtual directory, requiring exchange-oma virtual directory to be created which has SSL disabled.

This is all covered in KB817379 from Microsoft.
0
 

Author Closing Comment

by:gpaaw1
ID: 34221293
Issue is resolved.
0
 

Expert Comment

by:Mike-IT-Guy
ID: 35013527
that is all the results
0

Featured Post

Promote certifications in your email signature

Has your company recently won an award or achieved a certification? They'll no doubt want to show it off. Email signature images used to promote certifications & awards can instantly establish credibility with a recipient and provide you with numerous benefits.

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now