Solved

How Do I Get Past "Run Migration Prep Tool" Errors During an SBS 2003 to SBS 2008 Migration?

Posted on 2010-11-20
6
929 Views
Last Modified: 2012-06-27
Greetings Experts:

--Longtime reader, first time poster.  Need help with an SBS 2K3 Std to 2K8 Std migration because I get the error, "Run the Migration Preparation Tool on the Source Server".  I've researched many of the possible fixes without success. It's important for the migration to succeed since rebuilding the domain would be problematic for my client.

--I should also point out that the source server runs virtually on a Sun xVM box. We're migrating back to the original server hardware after an array failure. I've used this approach successfully in the past with other SBS 2K3-2K8 migrations.

--Below are the steps I've taken; a snippet of the migration setup log follows. I will post the full log if necessary. The process appears to fail at SourceChkRequirement after passing the AD, Exchange and service pack requirements.

--I'll be grateful for any and all replies.  Thanks in advance for your time and expertise.

All the best

Patrick

::TROUBLESHOOTING STEPS::

-Can successfully ping between source and destination servers via host name and IP.

-Applied all missing updates to the source server.

-Ran the SBS Best Practices Wizard on the source server (no issues other than older NIC card drivers, etc.).

-Successfully ran the Migration Prep tool (v. 6.0.5601.8495); it too showed no issues.

-Manually verified the correct SP levels for server and Exchange.

-Manually verified the forest, domain levels as well as the Exchange level.

-Compared the DCOM config against two known good servers.

-Verified group memberships on account used for migration.

-No relevant errors in Event Viewer logs on source server.

-Confirmed migration readiness registry entry on source server.

-No firewall or AV on either machine.

-Ran ADDIAG, DCDIAG, NETDIAG on source server - all clean.

::LOG SNIPPET::

2080] 101119.164104.9209: Setup: Setting source OS to Other
[2080] 101119.164104.9209: Setup: Running requirement check: SchemaLevelRequirement
[2080] 101119.164104.9521: Setup: Path=LDAP://Franciscan.local/CN=ActiveDirectoryUpdate,CN=ForestUpdates,CN=Configuration,DC=Franciscan,DC=local
[2080] 101119.164104.9521: Setup: Revision 2, Expected=2
[2080] 101119.164104.9521: Setup: Path=LDAP://Franciscan.local/CN=ActiveDirectoryUpdate,CN=DomainUpdates,CN=System,DC=Franciscan,DC=local
[2080] 101119.164104.9521: Setup: Revision 3, Expected=3
[2080] 101119.164125.2946: Setup: Source Schema Version:    44
[2080] 101119.164125.2946: Setup: Required Schema Version:    44
[2080] 101119.164125.2946: Setup:     Requirement passed.
[2080] 101119.164125.2946: Setup: Running requirement check: FunctionalLevelCheck
[2080] 101119.164126.1214: Setup:     Domain level: Windows2003Domain
[2080] 101119.164126.1214: Setup:     Forest level: Windows2003Forest
[2080] 101119.164126.1214: Setup:     Requirement passed.
[2080] 101119.164126.1214: Setup: Running requirement check: ExchangeSp2Check
[2080] 101119.164127.9466: Setup: Found exchange server version: 7638.  Path=LDAP://SBSSRV/CN=SBSSRV,CN=Servers,CN=first administrative group,CN=Administrative Groups,CN=FRANCISCAN,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Franciscan,DC=local
[2080] 101119.164127.9466: Setup:     Requirement passed.
[2080] 101119.164127.9466: Setup: Running requirement check: SourceWMICheck
[2080] 101119.164127.9622: Setup:     Requirement passed.
[2080] 101119.164127.9622: Setup: Running requirement check: SbsSp1Check
[2080] 101119.164127.9622: Setup:     Requirement passed.
[2080] 101119.164127.9622: Setup: Running requirement check: SourceChkRequirement
[2080] 101119.164128.3054: Setup: Caught exception: System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
0
Comment
Question by:lnetworks
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 34181386
Is your sever 2008 running OK with updated drivers before running the SBS set5up?
Olaf
0
 

Author Comment

by:lnetworks
ID: 34181531
Hi Olaf:
--Thanks for the reply. Yes, it should have the latest drivers. It's an HP ML 350 G5. I installed SBS 2K8 with SmartStart CD v 8.5 x64. Additionally, I updated the firmware as well.
Patrick
0
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 34182309
Please post IPconfig/all of both servers?

Also on server 2008 please run these one by one  in an elevated prompt:

netsh int ip set global taskoffload=disabled
netsh int tcp set global congestion=none
netsh int tcp set global autotuning=disabled
netsh int tcp set global rss=disabled
 and try to run the migration  text file again,

Olaf
0
How our DevOps Teams Maximize Uptime

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us. Read the use case whitepaper.

 

Author Comment

by:lnetworks
ID: 34187843
Hi Olaf:

--Thanks for the info. I will try those suggestions and post the results.

--I think I've identified the source of the problem as something to do with DCOM. It looks like the destination server cannot determine the OS of the source server. Hence, it fails at "Running requirement check: SourceChkRequirement". A close look at C:\Program Files\Windows Small Business Server\Data\info.xml on the destination server shows large gaps when compared to the same file on  known good. Among them missing sections are Source OS. My research says this is tied into DCOM permissions, etc. I've already checked those, but will take another look. Regardless, I'll let you know how it goes. Thanks again.

Patrick
0
 

Accepted Solution

by:
lnetworks earned 0 total points
ID: 34191607
Hi Olaf:

--I think the problem may be solved.  Below is the post I received from Microsoft Partner Support Forums. Migration seemed to work after this. I hope others may benefit. Note that in my case, Method 2 did the trick. My DCOM settings matched those in Method 1; there was no ISA server. Thanks again for the assist.

Patrick

Analysis
=======
From the LOG SNIPPET of the first post, seems the installation passed Schema Version, domain/forest level requirements, but it fails at the following point:
 

[2080] 101119.164128.3054: Setup: Caught exception: System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

This issue can occur if SBS2008 setup fails to make WMI query to the source server to get the OS version. To try to fix the issue, I suggest you do the following:

Action Plan
=========
 
Method 1: Make sure DCOM and 'Impersonate a client after authentication' have been configured correctly.

Make sure DCOM is enabled and is working correctly, I understand that you have tried this before, but please double check to ensure it is correct.


1.) Launch Component Services (DCOMCNFG)

2.) Expand Component Services -> Computers -> My Computer

3.) Bring up the Properties dialog box for My Computer

4.) Click on Default Properties tab

5.) Check the box 'Enable Distributed COM on this computer'

6.) Make sure Default Authentication Level is set to 'Connect' and Default Impersonation Level to 'Impersonate'

7.) Click Apply, click Ok.

8.) Close the Component Services window.

Make sure the group policy 'Impersonate a client after authentication' has SERVICE account added to the list.

1.) Launch Local Computer Policy (GPEDIT.msc)

2.) Expand Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> User Rights Assignment

3.) Make sure the Group Policy 'Impersonate a client after authentication' has Administrators group and SERVICE account added to the list.

4.) Reboot the Source server

Method 2: If the above steps does not fix the issue for you, as a workaround, you can change the Log On type for RPC to Local System. To do this, follow these steps on the source server.

1.) Open Services console

2.) Open the Properties dialog box for Remote Procedure Call (RPC) service.

3.) Go to Log On tab

4.) Select the radio button for 'Local System Account'

5.) Check the box 'Allow service to interact with desktop'

6.) Click Apply, click OK.

7.) Reboot the Source server

Method 3: If you have ISA 2004 installed on the Source server, you need to configure RPC filtering. By disabling strict RPC compliance, DCOM traffic and other RPC protocols are allowed.
0
 

Author Closing Comment

by:lnetworks
ID: 34221281
--Solution provided by Kevin Su of Microsoft Online Partner Community.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Because virtualization becomes more and more common, and, with Microsoft Hyper-V included in Windows Server at no additional costs, and, most server hardware nowadays is more than capable of running a physical Small Business Server (SBS) 2008 or 201…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question