Solved

Having Munin/Apache (on CentOS) setup problems - Directory index forbidden by Options directive: /var/www/munin/

Posted on 2010-11-20
3
2,979 Views
Last Modified: 2012-05-10
Am running these RPM packages on a CentOS 5.5 VM:

munin-1.4.5-4.el5
munin-common-1.4.5-4.el5
munin-node-1.4.5-4.el5


what's generated in error_log

Directory index forbidden by Options directive: /var/www/munin/

Open in new window


I haven't changed anything in munin.conf; right now I'm only trying to monitor the localhost.

I can telnet to 4949 on the localhost, but then I can't list any plugins

here's munin-node.conf

log_level 4
log_file /var/log/munin/munin-node.log
pid_file /var/run/munin/munin-node.pid

background 1
setsid 1

user root
group root

# Regexps for files to ignore

ignore_file ~$
#ignore_file [#~]$  # FIX doesn't work. '#' starts a comment
ignore_file DEADJOE$
ignore_file \.bak$
ignore_file %$
ignore_file \.dpkg-(tmp|new|old|dist)$
ignore_file \.rpm(save|new)$
ignore_file \.pod$
allow ^127\.0\.0\.1$
host *
port 4949

Open in new window


got this in the httpd access_log:

"GET /icons/image2.gif HTTP/1.1" 304 - "http://10.0.1.10/munin/"

Open in new window


I go to http://10.0.1.10/munin/

I am prompted for login, I provide the munin user and pwd. I authenticate correctly, but then I get this:

You don't have permission to access /munin/ on this server.

Here is my relevant Alias setup in httpd.conf

Alias /munin /var/www/munin/

<directory /var/www/munin/>
        AllowOverride None
 	Options ExecCGI FollowSymlinks
        AddHandler cgi-script .cgi
        DirectoryIndex index.cgi
        AuthUserFile /etc/munin/munin.passwd
        AuthType basic
        AuthName "Munin stats"
        require valid-user
</directory>

Open in new window


other permissions:

l
s -la /var/lib/munin/
total 32
drwxr-xr-x  3 munin munin 4096 Nov 21 00:15 .
drwxr-xr-x 26 root  root  4096 Nov 18 00:37 ..
-rw-r--r--  1 munin munin   14 Nov 21 00:15 datafile
-rw-r--r--  1 munin munin   14 Nov 21 00:15 limits
-rw-r--r--  1 munin munin   14 Nov 21 00:15 munin-graph.stats
-rw-r--r--  1 munin munin   36 Nov 21 00:15 munin-update.stats
drwxr-xr-x  2 munin munin 4096 Jul 18 22:36 plugin-state

Open in new window


ls -la /var/log/munin
total 60
drwxr-xr-x  2 munin munin  4096 Nov 18 01:07 .
drwxr-xr-x 16 root  root   4096 Nov 18 00:37 ..
-rw-r--r--  1 munin munin  3354 Nov 21 00:15 munin-graph.log
-rw-r--r--  1 munin munin 10981 Nov 21 00:15 munin-html.log
-rw-r--r--  1 munin munin  4992 Nov 21 00:15 munin-limits.log
-rw-r--r--  1 munin munin  5293 Nov 21 00:15 munin-node.log
-rw-r--r--  1 munin munin 12556 Nov 21 00:15 munin-update.log

Open in new window


ls -la /var/www/html/munin
total 96
drwxrwxr-x 4 munin munin 4096 Nov 18 00:40 .
drwxr-xr-x 3 root  root  4096 Nov 20 23:38 ..
drwxrwxr-x 2 munin munin 4096 Nov 18 00:37 cgi
-rwxrwxr-x 1 munin munin 2555 Nov 18 00:40 definitions.html
-rwxrwxr-x 1 munin munin 2046 Nov 18 00:40 favicon.ico
-rwxrwxr-x 1 munin munin  864 Jul 18 22:36 .htaccess
-rwxrwxr-x 1 munin munin 1794 Nov 18 00:40 logo-h.png
-rwxrwxr-x 1 munin munin  473 Nov 18 00:40 logo.png
-rwxrwxr-x 1 munin munin 1700 Nov 10  2009 munin-comparison-day.tmpl
-rwxrwxr-x 1 munin munin 1705 Nov 10  2009 munin-comparison-month.tmpl
-rwxrwxr-x 1 munin munin 1702 Nov 10  2009 munin-comparison-week.tmpl
-rwxrwxr-x 1 munin munin 1702 Nov 10  2009 munin-comparison-year.tmpl
-rwxrwxr-x 1 munin munin 3461 Nov 10  2009 munin-domainview.tmpl
-rwxrwxr-x 1 munin munin  849 Apr 29  2009 munin-htaccess.in
-rwxrwxr-x 1 munin munin 2368 Nov 11  2009 munin-nodeview.tmpl
-rwxrwxr-x 1 munin munin 6401 Nov 19  2009 munin-overview.tmpl
-rwxrwxr-x 1 munin munin 5912 Nov 11  2009 munin-serviceview.tmpl
drwxrwxr-x 2 munin munin 4096 Nov 18 00:37 partial
-rwxrwxr-x 1 munin munin 3619 Oct 30  2009 style-1.2.css
-rwxrwxr-x 1 munin munin 5351 Nov 18 00:40 style.css

Open in new window


I know its permissions, but I'm very, very junior in apache. thanks in advance


0
Comment
Question by:kapshure
  • 2
3 Comments
 

Author Comment

by:kapshure
ID: 34181984
oh, and i also ran this:

htpasswd -c /etc/munin/munin.passwd munin

Open in new window

0
 
LVL 13

Accepted Solution

by:
dsmile earned 250 total points
ID: 34182630
In httpd.conf, try to use this instead

Two lines added:
        Allow from all
        Order allow,deny
Alias /munin /var/www/munin/

<directory /var/www/munin/>
        AllowOverride None
        Options ExecCGI FollowSymlinks
        Allow from all
        Order allow,deny
        AddHandler cgi-script .cgi
        DirectoryIndex index.cgi
        AuthUserFile /etc/munin/munin.passwd
        AuthType basic
        AuthName "Munin stats"
        require valid-user
</directory>

Open in new window

0
 

Author Comment

by:kapshure
ID: 34235180
@dsmile.

i haven't had a chance to try this yet. will be trying this tonight. thanks for the feedback. im sure it was something simple.. just gotta get my apache skills honed better.
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If your site has a few sections that need to be secure when data is transmitted between the server and local computer, such as a /order/ section for ordering or /customer/ which contains customer data, etc it would of course be recommended to secure…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

680 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question