Solved

Acer Aspire 8935G screen problems

Posted on 2010-11-21
8
1,909 Views
Last Modified: 2016-09-14
I left my 18 month old Acer Aspire 8935G switched on yesterday and on returning about 30 minutes later there was nothing displayed on the screen. My first thought was it had gone in to some sort of power saving mode as I couldn't even hear the hard drive spinning. After 5 minutes trying to revive it with no success I pressed and held the power button to turn it off.

I then powered it on and was presented with the Boot Manager screen and chose Normal Mode. Windows started but after displaying the logo the screen went blank. I heard the windows theme play just after this happened and the notepad was still on and working.

I tried powering off and back on a few times, but got the same result. I tried booting into Safe Mode and this worked i.e. the screen didn't blank out.

My notepad has two o/s's installed:
- The original pre-installed Windows Vista 32 bit, which is virtually unused.
- Windows 7 Ultimate 64 bit, which I use all the time. This is installed on the 2nd hard drive, with Vista on the 1st.

I was using Windows 7 when it originally failed.

I tried booting into Vista, but get exactly the same problem, although the windows desktop is briefly displayed before the screen blanks out.

I can get into safe mode in both o/s's and the screen displays okay, it's only when I try to run either full o/s that I get the problem.

I can attach an external monitor and this works i.e. I can use the notepad through the external monitor, but nothing is displayed on the notepad monitor once the o/s's are running.

Any idea what could be causing this problem?
0
Comment
Question by:Milleniumaire
8 Comments
 
LVL 1

Expert Comment

by:okassis
ID: 34182850
Yes it sounds as thought windows might have installed a updated driver for the video card that has taken the resolution to a level that the monitor cant handle, thus when loading into safe mode the std res is lower and thus you seen thing as per norm.

there are a few ways to fix this, the easiest is to do a system restore to date when it worked.

if you want to get tricky:

Try windows VGA only mode from the boot option screen. if this work then the best advise is to do a system restore or to go to ad remove programs and uninstall display driver, then go onto the acer site and download and install the stable drivers

If it doesnt work in vga only mode:
then it a 3rd party app loading on boot, go to start > run > type msconfig enter > then go to startup tab and untick all the items and ok and restart. this will remove 3rd party apps and then go through to figure out which on is causing the fault.
0
 
LVL 23

Expert Comment

by:Dr. Klahn
ID: 34182860
It is possible that the Windows display driver is the problem.  This fits with the system displaying the BIOS screen and the logo being displayed until the OS actually starts up.  However, I can't think of why it should affect two different operating systems.

It may be more profitable to investigate display settings.  Hit F8 when the system is starting, and select VGA mode from the boot menu.  Once Windows is running, set the display resolution to the lowest available (probably 640x480, 256 colors).  Reboot and see if Windows comes up with a display.  If so, investigate higher resolutions and greater color depth.  There may be one or more specific settings that no longer work.  If this is the case, it would point at a hardware problem in the display chipset.
0
 
LVL 16

Author Comment

by:Milleniumaire
ID: 34183309
Thanks for your suggestions.

As DrKlahn says, I can't see how this could be a driver issue given that two different operating systems are having the same problems.

However, as I can still use the notepad by connecting it to a monitor I tried reducing the resolution to minimum settings and re-booted, but this had no affect.

I'm not sure what you mean by VGA mode as this isn't listed on the boot menu.  There is a "Enable  low-resolution video (640x480)" option listed, so I tried this and got the same problem.

I then booted into safe mode and uninstalled the two listed display adapters:
- ATI Mobility Radeon HD4670
- Mobile Intel (R) 4 Series Express Chipset Family

After rebooting, Windows 7 started up normally, but the resolution was poor.  Windows was showing the same two adapters, but both were showing a yellow exclamation against them.  I then uninstalled them (again), but windows then found them again (still showing exclamation marks).  It wanted to reboot so I let it.

This time it booted up and the screen looked okay (back to normal?), however, the ATI Mobility Radeon HD 4670 could not be started, but the Mobile Intel (R) 4 Series Express Chipset Family is okay, so I guess the notepad is now using this driver.

I also had some errors from the ATI Catalyst Control Centre as it appears the ATI Mobility RAdeon HD 4670 driver has now reverted to an older version that isn't supported by the Catalyst software.

It has taken over half a day of messing about to get to this stage, but it seems that whenever I get the ATI driver to work, no screen is displayed when Windows starts.

I've noticed the Windows Experience Index for the Graphics component has reduced from 6.7 when using the ATI driver, to 4.1 using the Intel driver, so this is not ideal and will clearly affect performance.  Gaming graphics is down to 3.4.  I don't know what the original figure was, but it was definitely higher than 5.6 as this was the lowest subscore before and relates to the hard drive performance.

I've no idea what kicked this problem off in the first place, but it does appear to be an ATI issue.  Is it possible something has failed on the graphics card that is only used by the ATI driver?

If I boot into Windows Vista, this is still having problems, so it looks like I will need to "disable" the ATI the driver in this O/S as well, if I can be bothered.

I now have a working laptop, running Windows 7, but I still think the notepad is poorly and the current Intel drivers are obviously not as good as native ATI ones.

Just to summarise  The problem arises when the notepad is using ATI drivers.  The driver versions used by  Windows Vista and Windows 7 are different, also one is 32 bit and the other is 64 bit, so this can't be solely a driver issue otherwise only one of the O/S's would be affected.

My guess is that this is a "hardware" issue that is only triggered when attempting to use the more "advanced" features of the video card provided by the native ATI drivers.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 16

Author Comment

by:Milleniumaire
ID: 34197651
Having contacted Acer through their support web page, here's the email I got back today:

The analysis has been completed and here is our feedback:
The unit is showing as out of warranty. You will need to contact the out of warranty line on 0870 853 1110 and book a chargable repair. Chargable repair process emailed to customer.

Well thanks a bunch Acer, I was hoping to at least enter a dialogue to try to determine what the problem might be - hardware or software, but clearly once the warranty has expired they aren't interested.

I had a Dell laptop for many years and even 5 years after the warranty expired I was still able to get assistance from Dell support.

I can't tell you how incredibly frustrated I'm feeling about Acer at the moment.
0
 
LVL 16

Accepted Solution

by:
Milleniumaire earned 0 total points
ID: 34391484
Took my notepad to my local PC repair shop who believed it was an issue with the ATI card and spent time "re-seating" it.  They also "played around" with the drivers.

After 2 weeks they returned it to me stating it was repaired, but within 5 minutes I identified that it wasn't and they had simply disabled the ATI card so that it was using the onboard graphics card.  They tried again and another week later it is still not repaired and I'm now £145 out of pocket, which I have every intention of getting back!

I now have no choice but to send it off to Acer and get ripped off by them, but hopefully they will know what they are doing.

Based on my experience, my advice to anyone considering buying an Acer is to stay clear.  While very competitively priced and packed with technology, it is clear to me that they lack quality and their support is non-existent once the warranty expires; they just don't want to know.

You get what you pay for!
0
 
LVL 16

Author Closing Comment

by:Milleniumaire
ID: 34424385
Unfortunately, there is still no solution to this problem, but I'm 99% sure it is a hardware issue relating to the ATI Radeon graphics card.
0
 

Expert Comment

by:Jari Peltola
ID: 41798413
I've had this issue for years, and I've detected the reason is faulty design. When I run a CPU thermometer program, It gives 80+ celcius results even I have disabled the ATI Radeon card. The motherboard simply overheats in use and this causes the graphics card units to shut down. Not a driver issue, that's for sure.

Lately I have had new issues with startup, it may be that that the motherboard/fan unit is starting to kick the bucket.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Introduction: When experiencing some peculiar problem with the functioning of your PC, how many times has it happened that you look for a solution and even google can’t help? It could be that you are one of the only few people on earth who ma…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now