Exchange 2010 with SP1 error: Couldn't perform the operation because objects of type 'Microsoft.Exchange.Data.Directory.SystemConfiguration.ResourceBookingConfig' couldn't be found on 'servername'

Hello,

I am attemting to install Exchange 2010 with SP1 on the newly deployed Server 2008 R2

When I run setup it failes (at the time when it runs setup /preparschema) with following error:

Couldn't perform the operation because objects of type 'Microsoft.Exchange.Data.Directory.SystemConfiguration.ResourceBookingConfig' couldn't be found on 'servername.domainname'

I have found following article: http://support.microsoft.com/kb/949526/en-us

but can't find CN-Global Settings when running ADSIEDIT.

any ideas?
LVL 1
pyotrekAsked:
Who is Participating?
 
pyotrekConnect With a Mentor Author Commented:
davorin:
I just figured out how to get to the CN=Global Settings object in ADSIEDIT and after following the article's (http://support.microsoft.com/kb/949526/en-us) suggestion it all works fine.

I would point out only to somone else trying to follow the KB949526 is - the location of the CN=Global Settings is as follows:

CN=Configuration, DC=<Domain>, DC=<suffix>
CN=Services
CN=Microsoft Exchange
CN=<Organization Name>

of course the articler shows the "Distinguished Name" which in simple terms is a backward path to the object.
0
 
BigBadWolf_000Commented:
the Resource Schema object under Global Settings in Active Directory directory service is missing.
Check this...should apply to 2010 also
http://support.microsoft.com/kb/949526

Also, The exchange server needs to be in the same site as the schema master DC

0
 
pyotrekAuthor Commented:
BigBadWolf:
Thank you but I already mentioned that article in my description of the problem.

My problem is that I cannot follow the suggestions from the article above as I do not see CN=Global Settings in adsiedit?!?!

and yes - may exchange server is in the same site as Schema master DC.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
davorinCommented:
Maybe this one could help:
http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/272750df-6880-430b-b11f-da574bb24ccc/
Do you have older versions of exchange in your organization?
0
 
pyotrekAuthor Commented:
davorin:
Thank you but the article that you are suggesting is just a pointer to the originally mentioned article in my original description.
0
 
davorinCommented:
Yes, I know. But it also has link to http://technet.microsoft.com/en-us/library/bb125224.aspx.
Is it Exchange 2010 you are installing the first and the only exchange server in your organization or you already have Exchange 2003? If that is the case you will have to prepare legacy permissions also.
0
 
davorinCommented:
I'm glad you have solved the problem.
0
 
pyotrekAuthor Commented:
Solutions from BigBadWolf and davorin - altough accurate were already mentioned by author in original descripton of the problem.
Final answer was provided by the author of the question
0
 
P HurdleCommented:
This issue is not resolved. I have not had time to address it. I will be back on shortly.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.