needing direct XP driver download link for onboard USB ports of a VIA, KM4M,MS-6734, Ver.1 Motherboard

Hi Everyone;

            From a previously closed post, I was able to use feedback given from various advisers of EE to successfully install the drivers for the onboard audio and video drivers for my VIA, KM4M, MS-6734, Ver.1 motherboard.  As far as the onboard USB ports go, there was a special note to upgrade from SP2 to SP3 of XP which was suppose to load the USB drivers.  Tonight, I upgraded from SP2 to SP3 successfully, however, I still do not have any entry within Device Manager for the USB ports.  As to be expected with missing USB drivers, the external USB devices I hook up like the USB flash drivers do not work when connected to these ports either.  

             Seeing the tricky nature of this problem, I am needing any suggestions which come to mind for successfully loading the USB drivers for this motherboard.  All other hardware device drivers associated with this motherboard is loaded.  At this point, I am only the needing the USB drivers.  And, as mentioned, the Service Pack of XP installed on the system is SP3 if that helps.  

              In closing, any help given to this problem will be appreciated.  If anyone has any questions, please feel free to let me know.  I currently have the problem pc powered up with everything working except the USB ports.  

              Thank you.

              George
GMartinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dbruntonCommented:
Check USB is enabled in BIOS.

And does Device Manager show any missing devices such as USB?  Which is why I asked the above question.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
faizbaigCommented:

    How to check USB enable in BIOS :

-> Entering Bios setting by  pressing or tapping  "Del" key
     Look for Menu " Integrated Devices" and than go to " Via Onchip Pci Device" and you will find " Onchip USB  controller"...etc..please enable all the USB options.


or

-> you can simply go to " Load Optimized default " and  " Save & Exit setup", this should enable USB (in case Disable).

Hope you are trying back end USB ports because some time front end USB port and not physically connected on motherboard.
0
jodix2002Commented:
Sorry, I don't really understand why you have a problem installing USB drivers, since this board already have support for USB, am I right? Shouldn't it installed right away? Is it a problem with the driver or what? What do you see in device manager? Any unknown hardware present?
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

☠ MASQ ☠Commented:
Now WinXP SP3 is installed try reinstalling the chipset drivers for the board - in this case it will be the Via Universal 4-in-1 package
http://www.msi.com/index.php?func=downloaddetail&type=driver&maincat_no=1&prod_no=572

Then point IE at the Windows Update site and you should get hardware updates under "Optional" to support USB.  Download, install and reboot.

If after rebooting you are still getting a problem check Device Manager for the USB entries - do they show as USB 2.0? Are there any errors shown?
If you have a PCI USB expansion board add this to see if Windows recognises the separate hub.  If the card USB ports work then you've a hardware problem with the onboard ports.
0
Gary CaseRetiredCommented:
George,

If you've installed the chipset drivers, then you should not be having this issue IF the ports are (a) working okay; and (b) are enabled in the BIOS.      Be sure they aren't simply disabled in the BIOS ... that would be the "simple fix" here :-)

If they are not disabled in the BIOS, you may very well have defective USB ports.     The easiest way to confirm this is to simply install an add-in PCI card with USB ports ... this is a good one:  http://www.newegg.com/Product/Product.aspx?Item=N82E16815104216&cm_re=koutech_usb_pci-_-15-104-216-_-Product

There should NOT be any drivers required for this -- just plug it in and you should "see" the ports.       If that's the case, your onboard ports are simply defective.      But as I noted, first be sure they aren't simply disabled.    There's a good chance that's all the issue is;  as I'd expect defective ports to have an entry in Device Manager with an exclamation point noting they weren't working properly.

0
nobusCommented:
you can also confirm if the usb is working, by booting froma live Knoppix cd, and test the usb :
ftp://ftp.kernel.org/pub/dist/knoppix/KNOPPIX_V5.0.1CD-2006-06-01-EN.iso      
0
GMartinAuthor Commented:
Hi Everyone;

            Thanks so much for the followup advice and suggestions.  Last night, I was able to fix this issue by enabling USB within the BIOS as recommended by dbrunton.  Upon closer inspection within Device Manager in addition to a direct ethernet connection of the hardware, I also noticed the onboard NIC was not responding.  Using the tip given regarding enabling the onboard USB, I went ahead and enabled the onboard NIC as well.  After carrying out these procedures within the BIOS, I saved the settings by pressing F10 and restarted the pc.  Once restarted, I pleasantly and excitedly noticed XP found new hardware and began loading its native drives for the onboard USB and onboard NIC accordingly.   To make a long story short, drivers were not needed as I originally thought.  Apparently, XP will load its native drivers for onboard USB and onboard NIC just as long as they are enabled within the BIOS and of course, as Gary indicated, working properly.  

        In closing, thank you so much for this BIOS tip.  I am sure it will come in very handy in the future as well.  

         Great job as always!!!

         George

             
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.