Solved

unable to bind to destination server in dns

Posted on 2010-11-22
29
798 Views
Last Modified: 2012-05-10
I am having problems sending and receiving emails. On the message queue is the following message.

unable to bind to destination server in dns

I can ping the dns servers and I am using a smart host relay.

Does anyone have any suggestions?

I was cleaning up some WMI issues previously and I am not sure if this was the cause.
0
Comment
Question by:mail2clk
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 14
  • 14
29 Comments
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 34186859
This suggests that the server in question or rather the domain for the email that is stuck, is not working properly, or the domain does not exist.

If you bring up a command prompt and type the following:

nslookup {press enter}
set type=mx {press enter}
problemdomain.com {press enter} (change problem domain with the domain name you are having issues with)

What response do you get?
0
 

Author Comment

by:mail2clk
ID: 34186893
after entering MX

a message comes up. server.company.local. cannot find mx.  domain is non-existent.

0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34186897
Then that is the answer - the domain does not exist.

Is the domain correctly spelled?  Did someone internally send to it?  Who is the sender of the message (internal user or Administrator / Postmaster)?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:mail2clk
ID: 34186910
i can send an email from administrator to administrator internally.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34186940
Is the domain a domain external to your mail server or an internal domain that you are hosting?
0
 

Author Comment

by:mail2clk
ID: 34186955
Domain company.co.uk is external.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34186975
Okay - please post the full domain name (which I will obscure to protect their identity) so I can check to see what is up.

Thanks

Alan
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 34187017
Okay - I see that they use Messagelabs to filter their email.

Testing a connection to them from my IP I can easily connect to both MX records - which might suggest that either you cannot resolve their name in DNS which means your DNS settings ar enot correct, or you might be blacklisted by them.

Can you check your IP Address on www.mxtoolbox.com/blacklists.aspx and make sure you don't pop up on any blacklists please.
0
 

Author Comment

by:mail2clk
ID: 34187039
Claranet confirmed we are not blacklisted.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34187044
Okay - but please visit the link and check your fixed IP Address - just for my peace of mind!
0
 

Author Comment

by:mail2clk
ID: 34187057
Looks ok blacklist:79.123.xxx.xxx. Please delete address
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 34187077
Yep - looking good.

Okay - so that leaves DNS issues!

On your server - what is the Server's LAN DNS IP Address set to?  It should be itself and nothing else.

Have you got DNS forwarders setup on the Forwarders TAB of the DNS server?  Start> Programs> Administrative Tools> DNS> Right-Click Server Name and choose Properties> Forwarders Tab.

You should have your ISP's DNS Server IP Addresses configured here.  If not - please add them, click Apply, then click on the Monitoring Tab and check both Test Types (Simple / Recursive) and click Test Now.  If you see PASS PASS in the Test Result window all is well.  Uncheck both Test Types and click OK.

Then return to the command prompt and type:

ipconfig /flushdns

then

nslookup {enter}
set type=mx {enter}
theirdomain.co.uk {enter}

Any better?
0
 

Author Comment

by:mail2clk
ID: 34187091
Dns address is set to itself the server ip address. passed the test, flushed dns but cannot find mx non-existent domain.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34187099
Are you using DNS forwarders and are they correct?
0
 

Author Comment

by:mail2clk
ID: 34187103
yes dns is correct
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 34187115
Can you add 158.43.240.4 to the DNS forwarders and then make sure it is at the top of the list, then In DNS Admin Tool, right-click the Servername and choose Clear Cache and then Right-Click and Choose Scavenge Stale Resource Records.

Re-run the command prompt check.

Any better?
0
 

Author Comment

by:mail2clk
ID: 34187116
Could it be a server issue ? Why would the domain be non-existent?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34187127
It is only non-existent to your server because it can't find it in DNS!

You may also have an entry in the hosts file on your server for some daft reason. Please check c:\windows\system32\drivers\etc hosts and lmhosts.sam (both should open with notepad.exe easily.

Any entries in there for this domain?  If so - delete the lines please.
0
 

Author Comment

by:mail2clk
ID: 34187164
Nothing in either file.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34187169
Okay - did you see my earlier comment?
0
 

Author Comment

by:mail2clk
ID: 34187187
i checked another server with a different company same setup and the message cannot find domain comes up but emails work fine
0
 

Author Comment

by:mail2clk
ID: 34187225
I added the ip address in the forwarders and cleared cache and scavenge stale records. Dean the command and the same message.non-existent domain.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34187318
Okay - please talk to your ISP as you are using their forwarders - they may be able to throw some light on this.

Alan
0
 

Author Comment

by:mail2clk
ID: 34187607
Alan

I got it to work. Thanks for your help

I followed these steps.

To work around this issue, remove the external DNS server references in Exchange System Manager, and then restart Microsoft Internet Information Services (IIS).

To remove the external DNS server references, follow these steps:
Start Exchange System Manager.
If administrative groups are enabled, expand Administrative Groups, and then expand First Administrative Group.

If administrative groups are not enabled, go directly to step 3.
Expand the Servers container, and then expand the Your_Server_Name container.
Expand the Protocols container, and then expand the SMTP container.
Right-click Default SMTP Server, and then click Properties.
Click the Delivery tab, and then click Advanced.
Click Configure, and then click the first entry in the External DNS list.
Click Remove.
Remove each remaining entry from the External DNS list.
Click OK three times.
Quit Exchange System Manager.
To restart IIS, follow these steps:
Open the Services snap-in.
Right-click the IIS Admin Service, and then click Restart.
In the Restart Other Services dialog box, click Yes to restart the dependency services.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34188811
Brilliant - thanks for the update.

A bit heavy-handed - but if it worked - I won't knock it.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34214062
So nothing I said helped you in any small way to resolve the problem?
0
 

Author Comment

by:mail2clk
ID: 34214101
I need to allocate some points.
0
 

Author Closing Comment

by:mail2clk
ID: 34214110
I provided my own solution.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question