Solved

any free ftp text editor that works on linux (centos 5)?

Posted on 2010-11-22
27
612 Views
Last Modified: 2012-05-10
Hi

I want to know any free ftp text editor that works on linux (centos 5)?

Thank you!
Francis SZE
0
Comment
Question by:fsze88
  • 12
  • 11
  • 3
  • +1
27 Comments
 
LVL 14

Accepted Solution

by:
John-Charles-Herzberg earned 100 total points
ID: 34186952
This might work for you.

Kate - Supports any protocol that is supported by KDE. (FTP, SSH...)
http://en.wikipedia.org/wiki/Kate_%28text_editor%29

KDevelop - Supports any protocol that is supported by KDE. (FTP, SSH...)
http://en.wikipedia.org/wiki/KDevelop

Quanta Plus - Supports any protocol that is supported by KDE. (FTP, SSH...)
http://en.wikipedia.org/wiki/Quanta_Plus
0
 
LVL 35

Expert Comment

by:torimar
ID: 34187019
Gedit:
http://thecodecentral.com/2010/04/02/use-gedit-as-remote-file-editor-via-ftp-and-ssh-ubuntu

Vim (with the Netrw plugin script):
http://www.vim.org/scripts/script.php?script_id=1075


Generally, I'd rather like to advise against the use of remote editing as a default means for manipulating files on remote servers. It is insecure, especially when using FTP. It is better used as an exception and quick fix.
As such, the inherent editing functions as provided by FileZilla and other FTP clients is just sufficient for my personal use. All bigger modifications are made locally and re-uploaded.

0
 
LVL 15

Author Comment

by:fsze88
ID: 34187186
any tool(s) could be installed by yum?
Thank you!
Francis
0
Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

 
LVL 14

Expert Comment

by:Deepak Kosaraju
ID: 34187923
Yes KDevelop, Kate, anjutha, gedit, vim all can be installed by yum. But all those are gui based text editors. I am not sure what do you mean by ftp text editor?
0
 
LVL 35

Expert Comment

by:torimar
ID: 34188043
Gedit is installed by default on a Gnome driven system (as CentOS is).

Vi/Vim should also be installed by default - depends on the distro though.
Kate and KDevelop are KDE software; they should run on Gnome too, but were not developed for it and may not have all the functionality available.
0
 
LVL 15

Author Comment

by:fsze88
ID: 34193667
up to now I interested in gedit.
What is  command to install gedit?
Thank you!
0
 
LVL 15

Author Comment

by:fsze88
ID: 34193668
yum command
0
 
LVL 35

Expert Comment

by:torimar
ID: 34193752
yum install gedit
0
 
LVL 15

Author Comment

by:fsze88
ID: 34194202
Hi,
I tried gedit, it is unable to do ftp function
Please guide me how to install Quanta_Plus or kate3 please thank you!

Francis SZE
0
 
LVL 35

Expert Comment

by:torimar
ID: 34194738
Did you actually follow the guide for Gedit I posted above?
( http://thecodecentral.com/2010/04/02/use-gedit-as-remote-file-editor-via-ftp-and-ssh-ubuntu )
It would have made you realize that you need to connect to a remote server first, then use Gedit and open files on the remote server via the Gedit bookmark feature. Gedit itself does not open a connection to a FTP server, but if you are connected already, then Gedit is able to edit remote files.

Kate3 is for KDE what Gedit is for Gnome. If Gedit doesn't work for you, and you don't run KDE (Gnome is the default desktop on CentOS), then there is no point in trying Kate.

Quanta Plus is a complete full-featured HTML editor (almost comparable to Dreamweaver), it is not a simple text editor.
You may try installing via:

yum install kdewebdev

0
 
LVL 14

Expert Comment

by:Deepak Kosaraju
ID: 34196469
You might be interested to look at this URL
http://forums.whirlpool.net.au/archive/1057483
0
 
LVL 15

Author Comment

by:fsze88
ID: 34210409
>>
It would have made you realize that you need to connect to a remote server first, then use Gedit and open files on the remote server via the Gedit bookmark feature. Gedit itself does not open a connection to a FTP server, but if you are connected already, then Gedit is able to edit remote files.

Bookmark feature? where is it?
Screenshot.png
0
 
LVL 14

Assisted Solution

by:Deepak Kosaraju
Deepak Kosaraju earned 100 total points
ID: 34210475
Why don't u try with bluefish by openoffice.
http://bluefish.openoffice.nl/movies/working_with_remote_files.html
Installation should be easy
http://bfwiki.tellefsen.net/index.php/Installing_Bluefish
You can try either yum search bluefish to check if its in base repository.
0
 
LVL 35

Expert Comment

by:torimar
ID: 34210527
Bookmark feature? where is it?

You still did not read that link, did you?
Ok then, I'll repost the relevant passages here:

Once you are successfully connected to a server, fire up gedit.
Go to view and check "Side Panel" or press F9.
At bottom of side panel, click "File Browser" tab.
On top of the side panel drop down menu, select "Bookmarks".
Expand the server you are connecting to.
You now can edit remote files as they are local files.

And here's an explanatory screenshot, taken from that link as well:
0
 
LVL 35

Expert Comment

by:torimar
ID: 34210544
Image didn't attach; so here it is:

 gedit.png
0
 
LVL 15

Author Comment

by:fsze88
ID: 34211562
that gedit is Ubuntu version
I am using centos version
they may be different
Screenshot-1.png
0
 
LVL 35

Assisted Solution

by:torimar
torimar earned 300 total points
ID: 34211769
There is only one Gedit, no different versions for CentOS and Ubuntu. But some of the default settings may be different. CentOS usually is very spartanic when it comes to that and leaves all the configuring to the user.

Here are new steps that I tested myself:

1. Connecting to a remote server

-- Click the 'Computer' icon on the desktop to open the file manager
-- File > Connect to server...
-- Choose 'FTP with login', insert the server data, choose a name for the connection (which will serve as 'bookmark')
-- Click 'Connect'
-- The connection name should now appear under "Places" in the side pane (If you don't see a side pane, enable it under "View" or press F9)
-- Click the name and you will be asked for your login credentials, then the FTP files should appear in the file window

2. Edit FTP files with Gedit

-- Easiest solution: simply right-click a file and select 'Edit with text editor'; it will be opened in Gedit.

-- Longer solution (following the original link I posted):
---- Open Gedit (Applications > Accessories > Text Editor)
---- Edit > Preferences > Plugins: tick 'Enable file browser pane'
---- At the bottom of the pane a new tab will appear
---- Select it and then choose "Bookmarks" in the file pane dropdown menu
---- Double-click your connection name and files should be listed ready for editing
0
 
LVL 35

Expert Comment

by:torimar
ID: 34211826
Sorry, forgot one step there:

The "connection name" is not yet a persistent bookmark.
For easy re-connections by just one double-click, add the following step to section #1 above:

-- Once the FTP folder is opened in the file manager, select Bookmark > Add bookmark.
The FTP server will now be added as a permanent location to the side pane.
0
 
LVL 15

Author Comment

by:fsze88
ID: 34212273
torimar,
Thanks for your help
I busy , I will make reply asap as I can, may be 2~3 days.
please don't angry
0
 
LVL 15

Author Comment

by:fsze88
ID: 34216346
torimar,
you right, I can open ftp file. but it said [Read Only]
How Could I solve this issue?
Thank you!
Francis SZE
0
 
LVL 35

Expert Comment

by:torimar
ID: 34216437
In order to be able to edit a file via FTP it needs to either be owned by the ftpuser (this is usually the case for files that were uploaded via FTP as well), or the file permissions need to be set (chmod) to 777.

0
 
LVL 15

Author Comment

by:fsze88
ID: 34217459
I can edit file via windows ftp text editor(pspad) www.pspad.com, but not works on gedit......
I don't understand.......
0
 
LVL 35

Assisted Solution

by:torimar
torimar earned 300 total points
ID: 34218688
This is very strange, but you are right : I could reproduce this phenomenon on two machines here, CentOS and Ubuntu.
I suppose this could be a setting in Nautilus (the Gnome file manager), although I found several other pages on the internet that recommend this method of editing remote files; they don't seem to get stuck with read-only files. Or it could have to do with the /tmp folder where the local copies for editing are created ...

I'm not sure if I'll find the time to look into this now.
For the time being I suggest you simply don't make the connection via Nautilus (the file manager), but via a regular FTP client. Then the permissions are set correctly. Just install gFTP via Applications > Add/Remove Software or via the terminal by typing:
yum install gftp

Then open the client (Applications > Internet > gFTP), go to FTP > Options in the menu (or press CTRL + O) , under General > Edit Program type: gedit, then connect to your FTP server, right-click the file and select 'Edit'. It will open Gedit with a writable copy of the file.

ps:
When opening the file in Gedit it will bear another name; nevermind that. This is the name of the temporary local copy of that file which was created by gFTP and sent to Gedit; when saving gFTP will write the changes to the original file.
0
 
LVL 15

Author Comment

by:fsze88
ID: 34235648
saving gFTP will write the changes to the original file?
how?
0
 
LVL 35

Expert Comment

by:torimar
ID: 34235976
My sentence must be read like this:

"When saving the edited file, gFTP will write the changes back to the original file on the FTP server."
0
 
LVL 15

Author Comment

by:fsze88
ID: 34256657
"When saving the edited file, gFTP will write the changes back to the original file on the FTP server."
it doesn't seem works, sorry.....
[press control -s] on gedit...

Thank you!
Francis SZE
0
 
LVL 35

Assisted Solution

by:torimar
torimar earned 300 total points
ID: 34258195
Well, then saving and exiting Gedit.
The file is edited locally, so as long as you still keep Gedit open, chances are that modifications will continue, so gFTP may not consider it necessary to write the edited local file back to the server.

As I said in my first post: this is not and should not be the normal way of editing a web page. I use it only for small immediate changes to robots.txt and .htaccess, not for lomng editing sessions of a whole page, so I am not familiar with how this method will work under different circumstances. You need to do your trial and error yourself.
0

Featured Post

Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Linux hostname change 2 71
AWS - HAProxy- KeepAlived 5 43
fedora linux on laptop - setup sendmail - or some kind of email 5 44
number in printf 13 27
Daily system administration tasks often require administrators to connect remote systems. But allowing these remote systems to accept passwords makes these systems vulnerable to the risk of brute-force password guessing attacks. Furthermore there ar…
This is the error message I got (CODE) Error caused by incompatible libmp3lame 3.98-2 with ffmpeg I've googled this error message and found out sometimes it attaches this note "can be treated with downgrade libmp3lame to version 3.97 or 3.98" …
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question