RDP timeout settings

Is there a way to extend the timeout settings for  either the host or remote machine ?
ethernet69Asked:
Who is Participating?
 
scrathcyboyConnect With a Mentor Commented:
This procedure should set it to NEVER time out --

   1. Go to the Start Menu and click Run (or press the shortcut combination Windows+R).
   2. In the prompt, type gpedit.msc and click OK.
   3. In the left panel, navigate the hierarchical menu: Computer Configuration > Administrative Templates > Windows Components > Terminal Services > Sessions
   4. Double click the “Sets a time limit for active but idle Terminal Services sessions” property to open up the properties window.
   5. In the popup window, make sure the Enabled selection is chosen and the Idle Session Limit dropdown list is set to Never.
   6. Click Ok and close all windows and applications
   7. Reset the computer for the changes to take effect.
0
 
scrathcyboyCommented:
There should be settings in all the various RD software to adjust the timeout.  In the one I use, it is right on the main page.  You will need to adjust both, of course.  Since you didn't say which RD software you are using, I can't be more specific.

http://technet.microsoft.com/en-us/library/cc754272.aspx
technet.microsoft.com/en-us/library/cc758177(WS.10).aspx
0
 
ethernet69Author Commented:
sorry, I thought that was clear. We are using Remote Desktop (RDP) built into Windows XP.

Brian
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
scrathcyboyCommented:
then the two MS articles I cited should help.  Check em out.
0
 
ethernet69Author Commented:
Those articles both pertain to Server OSs. Can you provide a link to modify RDP settings like this in XP Pro?
0
 
scrathcyboyCommented:
www.victorchen.info/remote-desktop-idle-timeout/
http://support.microsoft.com/kb/969084

Here is the procedural way --
http://www.tek-tips.com/viewthread.cfm?qid=1259649&page=1

But you can do it in the registry as a fairly simple change --
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

Also see here for an arduous full review --
http://www.geek.com/articles/mobile/your-desktop-on-the-go-remote-desktop-20020826/
0
 
ethernet69Author Commented:
Ok, thanks for the registry key. All values in in the hive/key are pointing to "MaxConnectionTime" or "MaxDisconnectionTime" being set at a value of "0" - what should I do/change to allow my client who is remoting from one XP box to another XP Pro box to keep her from being disconnected/timed out after about 5-10 minutes while she leaves the session open? Should we just install VNC instead both machines? Or can RDP keep the connection alive for longer?
0
 
scrathcyboyCommented:
However, I have always used Tight VNC and have never had a time out issue.  I would recommend using Tight VNC, I found its operation basically flawless.  The only peculiar thing is their terminology seems back to front.  What they call the client is actually the "server" and vice versa.  Once you get used to the back to front logic in all VNC software, it is great.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.