?
Solved

windows 2003 domain reporting wrong functional level

Posted on 2010-11-22
12
Medium Priority
?
1,092 Views
Last Modified: 2012-05-10
I am currently trying to install exchange 2010

i have several 2003 servers, a couple 2008 r2 servers
and no 2000 or prior servers

The domain was in mixed mode, but in order to install exchange 2010 I raised the functional level to 2003.  This was done 2 days ago.  When i try to run

setup /prepareAD
the server reports that the domain forest is still in mixed mode

0
Comment
Question by:koffea
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
  • +1
12 Comments
 
LVL 26

Assisted Solution

by:Tony J
Tony J earned 400 total points
ID: 34189902
Try the commands in this order:


Setup.com /PrepareLegacyExchangePermissions
Setup.com /PrepareSchema
Setup.com /PrepareAD

Of course, it would be a good test to ensure your domain is ready with no replication issues etc.

Get hold of a copy of the Exchange Best Practices Analyser and run the readiness check.
0
 
LVL 26

Expert Comment

by:Tony J
ID: 34189916
Oh and just another thought - Windows 2003 SP1 or above? That's a pre-requisite.
0
 
LVL 9

Expert Comment

by:losip
ID: 34189925
Worth checking that AD Domains and Trusts MMC shows the domain and forest functional level correctly.
0
Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34190641
As losip said, check your forest functional level too
0
 

Author Comment

by:koffea
ID: 34191470
yes i am running SP2
Setup.com /PrepareLegacyExchangePermissions and the other commands fail on the Organization checks.  It reports that the domain is not at a functional level of 2003 or higher.

AD Domains and Trusts MMC reports that the current level is:
windows server 2003

how do i specifically find the forest level?
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 1600 total points
ID: 34191873
Domain Functional level is done through ADUC

Forest Functional level is done through Active Directory Domains and Trusts:
Right click in the top left hand side pane on where it says "Active Directory Domains and Trusts" and you see a "raise forest functional level" option

The other thing to consider is what level your exchange org is. You need to raise it to native for Exchange 2010 as it doesn't support Exchange 5.5 or Exchange 2000.
0
 

Author Comment

by:koffea
ID: 34192421
this is the first exchange server in our organization.  

I have verified that  "Active Directory Domains and Trusts" and you see a "raise forest functional level" option says that it is at "Windows Server 2003"

could this issue be that i do not have any windows 2008 r2 domain controllers?  only member servers.
is there any way to run:
Setup.com /PrepareSchema
Setup.com /PrepareAD
 on a windows 2003 server (ie not 64 bit)?
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 1600 total points
ID: 34194549
Did you check the exchange org level and confirm it was native too?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34194565
Exchange 2007 has a 32bit version you can prepare AD and the schema with, but I would rather not as you are going direct to Exchange 2010.

How many Domain Controllers do you have? Log into all of them and verify the domain and forest functional level.
0
 

Accepted Solution

by:
koffea earned 0 total points
ID: 34202800
ok - i got this sorted - kind of

i transfered the schema master role to the pdc with the intent of then transfering the role to another server that i was going to install on thursday.  however, when i transfered the role to the pdc  "Active Directory Domains and Trusts" reported that the domain was in mixed mode.  So i raised it to "windows server 2003" and it all worked out fine.  

so there must have been some issue with the server that had the schema role.  no matter, i am taking it off line this week.

thanks for the help
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34203299
Interesting. Thanks for the points and your solution.
0
 

Author Closing Comment

by:koffea
ID: 34224760
tells what i did but not really why it worked
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…
Suggested Courses
Course of the Month11 days, 5 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question