Solved

How do i access network share documents through OWA

Posted on 2010-11-22
31
1,051 Views
Last Modified: 2012-05-10
How do i access network share documents through OWA (outlook web access) ?
0
Comment
Question by:resolver1
  • 15
  • 14
  • +1
31 Comments
 
LVL 1

Expert Comment

by:GandalphWizard
Comment Utility
OWA is not designed to access network resources. For that you should either use RDP or VPN or both.
0
 
LVL 9

Expert Comment

by:dmessman
Comment Utility
Gandalph is correct.  OWA is an interface for email only.  I'm not sure what version of SBS you're on, but you can use the remote web workplace to connect to LAN computers to access documents remotely.

For SBS 2003, it's https://sub.domain.com/remote

For SBS 2008, the default is https://remote.domainname.com

Log in and choose connect to a computer and log in again.  There's really no option for accessing files via OWA.
0
 
LVL 31

Expert Comment

by:MegaNuk3
Comment Utility
Exchange 2007 and above allow accessing of files through OWA
0
 
LVL 31

Accepted Solution

by:
MegaNuk3 earned 500 total points
Comment Utility
0
 
LVL 31

Expert Comment

by:MegaNuk3
Comment Utility
So if you are using SBS 2008 you should be fine.
0
 

Author Comment

by:resolver1
Comment Utility
yeap we are using sbs 2008.  Ill take a look at the article tomorrow.  Thanks.
0
 

Author Comment

by:resolver1
Comment Utility
ive read the instructions and setup exchange. however, the article " http://www.msexchange.org/tutorials/Drilldown-OWA-Direct-File-Access-Exchange-Server-2007-Part2.html " says that i need the Premium client in order for the feature to work.  Which client is the writer referring to? I have sbs 2008 standard.  Do i get this feature?

0
 
LVL 31

Expert Comment

by:MegaNuk3
Comment Utility
When you open OWA you should see the option to select if you are using a public or private computer and if you want to use OWA light or the Premium version. Do you see those options?
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 500 total points
Comment Utility
Just don't tick the "use OWA light" box and you should get the documents option after you have logged in
0
 

Author Comment

by:resolver1
Comment Utility
I selected private and no tick in OWA light, then logged in.  No option for documents.  Any ideas?
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 500 total points
Comment Utility
0
 

Author Comment

by:resolver1
Comment Utility
Direct file access feature is enabled.  I've left the default options for allow and block extentions.  I've also added the server with the shares (the only sbs server).

I've also restarted the exchange and iis services: see below.

net stop msexchangeadtopology
net stop msftesql-exchange
net stop msexchangeis
net stop msexchangesa
net stop iisadmin
net start msexchangeadtopology
net start msftesql-exchange
net start msexchangeis
net start msexchangesa
net start iisadmin
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 500 total points
Comment Utility
Log into owa--> options-->about
Is the "OWA experience" = Premium?
0
 

Author Comment

by:resolver1
Comment Utility
no it says "Outlook Web Access experience: Basic ".  how do i login with a premium?

Mailbox owner: user name [user.name@companyname.co.uk]
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; MS-RTC LM 8; .NET4.0E)
Outlook Web Access experience: Basic
User language: English (United Kingdom)
User time zone: (GMT) Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London
Exchange mailbox address: /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=user.name
Outlook Web Access host address: https://remote.companyname.co.uk/owa
Outlook Web Access version: 8.3.106.1
Outlook Web Access host name: remote.companyname.co.uk
Client Access server name: servername.tbh.local
Exchange Client Access server .NET Framework version: 2.0.50727.4206
Client Access server operating system version: Microsoft Windows NT 6.0.6002 Service Pack 2
Client Access server operating system language: en-US
Microsoft Exchange Client Access server version: 8.3.83.0
Client Access server language: en-US
Client Access server time zone: GMT Standard Time
Microsoft Exchange Client Access server platform: 64bit
Mailbox server name: servername.tbh.local
Mailbox server Microsoft Exchange version: 8.3.83.0
Other Microsoft Exchange server roles currently installed on the Client Access server: Mailbox, Hub Transport
Authentication type associated with this Outlook Web Access session: Basic
Public logon: No
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 500 total points
Comment Utility
OK, just tried it on my SBS2008 and I can see the Documents folder through OWA straight away.
Do have a look at this
EMC-->Server config-->Client Access-->Outlook Web Access-->Properties on OWA(SBS)-->Segmentation tab--> Is ' Premium Client' Enabled?

If not, Enable it and you should see the 'Documents' button the next time you log into OWA.
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 

Author Comment

by:resolver1
Comment Utility
it says enabled. any more ideas. i can feel we're getting close.  thanks for your help so far.
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 500 total points
Comment Utility
Try
Get-casmailbox "yourmailbox" | fl displayname, owapremiumclientenabled

Does it say FALSE or is it empty? Try setting it to true
0
 

Author Comment

by:resolver1
Comment Utility
Thanks.

[PS] C:\Windows\system32>Get-casmailbox "user.name" | fl displayname, owapremiu
mclientenabled


DisplayName             : user name
OWAPremiumClientEnabled :

No option there.  I've looked in the mailbox properties cant see any option for enabling premium version.  
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 500 total points
Comment Utility
Set it to true
Set-casmailbox "your mailbox" -owapremiumclientenabled $true
0
 

Author Comment

by:resolver1
Comment Utility
ran the PS command and now get the following:

DisplayName             : user name
OWAPremiumClientEnabled : True

However, i still cant see the documents on the left hand side.  IVe attached a screen shot and checked the setting again : Outlook Web Access experience: Basic .  I made sure i was not ticking the basic on the logon screen.  I am using internet explorer to view the OWA. Any more ideas?

 OWA screen shot without document
0
 

Author Comment

by:resolver1
Comment Utility
thanks for your help so far. its appreciated.
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 500 total points
Comment Utility
Log into OWA and then do Options -->Accessibility
Is the "use the blind and low vision experience" option ticked?
Untick it if so, then click "Save" and then "Log Off" and then log back in and the Documents button should be visible.
0
 

Author Comment

by:resolver1
Comment Utility
Thanks for your patience.  We're getting closer.  We now have the premium !

Outlook Web Access experience: Premium

However, no documents.  Any more ideas?

 OWA screen shot premium without documents
Mailbox owner: user name [user.name@name.co.uk]
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; MS-RTC LM 8; .NET4.0E)
Outlook Web Access experience: Premium
User language: English (United Kingdom)
User time zone: (GMT) Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London
Exchange mailbox address: /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=user.name
Outlook Web Access host address: https://remote.name.co.uk/owa
Outlook Web Access version: 8.3.106.1
Outlook Web Access host name: remote.name.co.uk
Client Access server name: TBHSERVER.tbh.local
Exchange Client Access server .NET Framework version: 2.0.50727.4206
Client Access server operating system version: Microsoft Windows NT 6.0.6002 Service Pack 2
Client Access server operating system language: en-US
Microsoft Exchange Client Access server version: 8.3.83.0
Client Access server language: en-US
Client Access server time zone: GMT Standard Time
Microsoft Exchange Client Access server platform: 64bit
Mailbox server name: TBHSERVER.tbh.local
Mailbox server Microsoft Exchange version: 8.3.83.0
Other Microsoft Exchange server roles currently installed on the Client Access server: Mailbox, Hub Transport
Authentication type associated with this Outlook Web Access session: Basic
Public logon: No
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 500 total points
Comment Utility
Hmmm, the problem here is the annoying fact that as soon as you set one OWA option to True (like we did with OwaPremiumClientEnabled) it sets all the others from <not set> to false. So it turns off all the other Outlook options, like Calendar etc. You can set them 1 by 1 to True or use set-qaduser to change the all to true or <not set> in one go
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 500 total points
Comment Utility
The easiest way to reset it is to find the mailbox with ADSIEDIT and clear the msExchMailboxFolderSet attribute

Then login with OWA and the Documents option should be visible
0
 

Author Comment

by:resolver1
Comment Utility
That works a treat.  Although i used the advanced attribute editor to clear the param.  Thanks alot for all your time/effort MegaNuk.  I would have never found the answer to this question!
0
 

Author Closing Comment

by:resolver1
Comment Utility
Thanks again MeageNuke.
0
 
LVL 31

Expert Comment

by:MegaNuk3
Comment Utility
No problem, I learnt quite a bit too with this one.
0
 

Author Comment

by:resolver1
Comment Utility
strange thats in this state in the first place.  your would have thought each of the paremeters would be correct
0
 
LVL 31

Expert Comment

by:MegaNuk3
Comment Utility
Have you checked other mailboxes to see if the "low vision experience" is ticked?
0
 

Author Comment

by:resolver1
Comment Utility
No, not yet.  I'm not at that part of the project yet. ill check it out and post back.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now