I get a 403 error when trying to install cacti with apache

I am trying to install cacti on a opensuse box. This is a fresh install of mysql, apache and cacti. I am currently getting a 403 error when trying to access the cacti web page.
motewalkerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Maciej SsysadminCommented:
Post your apache config file and appropriate part from your error_log.
0
motewalkerAuthor Commented:
Rebuilt the server last night and just installed the updates and apache. Still get the 403 error. with that said.

default-server.conf
DocumentRoot "/srv/www/htdocs"
<Directory "/srv/www/htdocs">
        Options None
        AllowOverride None
        Order allow,deny
        Allow from all
</Directory>
Alias /icons/ "/usr/share/apache2/icons/"
<Directory "/usr/share/apache2/icons">
        Options Indexes MultiViews
        AllowOverride None
        Order allow,deny
        Allow from all
</Directory>
ScriptAlias /cgi-bin/ "/srv/www/cgi-bin/"
<Directory "/srv/www/cgi-bin">
        AllowOverride None
        Options +ExecCGI -Includes
        Order allow,deny
        Allow from all
</Directory>
<IfModule mod_userdir.c>
        UserDir public_html
        Include /etc/apache2/mod_userdir.conf    
</IfModule>
Include /etc/apache2/conf.d/*.conf
Include /etc/apache2/conf.d/apache2-manual?conf
                                                         
I have no virtual hosts configured at this time.

error log

[Mon Nov 22 14:55:43 2010] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Nov 22 14:55:43 2010] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
[Mon Nov 22 14:55:43 2010] [notice] Apache/2.2.15 (Linux/SUSE) mod_ssl/2.2.15 OpenSSL/1.0.0 configured -- resuming normal operations
[Mon Nov 22 14:55:43 2010] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
[Mon Nov 22 14:55:43 2010] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
[Mon Nov 22 14:55:43 2010] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
[Mon Nov 22 14:55:43 2010] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
[Mon Nov 22 14:55:52 2010] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
[Mon Nov 22 14:55:52 2010] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
[Mon Nov 22 14:55:52 2010] [client ::1] File does not exist: /srv/www/htdocs/favicon.ico
[Mon Nov 22 14:55:52 2010] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
[Mon Nov 22 14:55:52 2010] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
[Mon Nov 22 14:55:55 2010] [client ::1] File does not exist: /srv/www/htdocs/favicon.ico
[Mon Nov 22 14:55:55 2010] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'

0
Maciej SsysadminCommented:
Is /srv/www/htdocs your cacti installation directory? If no - please attach proper /etc/apache2/conf.d/*.conf file.
How is your DirectoryIndex option set? (should be in main config file). It should contain index.php.

PS Another thing is your AppArmor (but I doubt, that it is causing your cacti/apache problems) - you have to configure it properly or just turn it off, but I can't help with this application, as I don't use suse.
0
motewalkerAuthor Commented:
switched over to ubuntu and now I have apache working, but I don't know the file paths for the cacti config file for mysql/php and apache. Does anyone know where I should start?
0
Maciej SsysadminCommented:
dpkg -L cacti
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.