Solved

SWF file doesn't play on web page

Posted on 2010-11-22
6
374 Views
Last Modified: 2012-05-10
I have a SWF file that's based off a XML file. It's basically a banner slide show. I uploaded all the SWF, Content.xml, and images to the root location. When I just click on the main SWF, the movie plays as it should. It's when I embed the file into the web page that I get stuck. It basically just shows the background color scene in the FLA file. It's like it doesn't know where the files are located and if that's the case, I'm not sure where edit it to make the change.

Sorry if I got some of the terminology wrong as I'm pretty new at this.
0
Comment
Question by:DxtrLws
  • 3
  • 2
6 Comments
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 34191189
>> It's like it doesn't know where the files are located and if that's the case, I'm not sure where edit it to make the
>> change.

Can you post a link for us to look at?
0
 

Author Comment

by:DxtrLws
ID: 34191438
It's an internal site, so I can't really post up a link for you to see. But here's a copy of th ecode that's on the main page as well as a screen shot. I can also attach the flash and xml files if needed.

<%@LANGUAGE="VBSCRIPT"%>
<!--#include virtual="/Connections/wwwReader.asp" -->
<%
Dim release
Dim release_cmd
Dim release_numRows

Set release_cmd = Server.CreateObject ("ADODB.Command")
release_cmd.ActiveConnection = MM_wwwReader_STRING
release_cmd.CommandText = "SELECT ItemID, HeadLine FROM dbo.PressReleases ORDER BY ReleaseDateTime DESC" 
release_cmd.Prepared = true

Set release = release_cmd.Execute
release_numRows = 0
%>
<%
Dim FrontPageImage
Dim FrontPageImage_cmd
Dim FrontPageImage_numRows

Set FrontPageImage_cmd = Server.CreateObject ("ADODB.Command")
FrontPageImage_cmd.ActiveConnection = MM_wwwReader_STRING
FrontPageImage_cmd.CommandText = "SELECT * FROM dbo.FrontPageLinks" 
FrontPageImage_cmd.Prepared = true

Set FrontPageImage = FrontPageImage_cmd.Execute
FrontPageImage_numRows = 0

dim a(100), b(100), c(100)
while (not FrontPageImage.eof)
num = num + 1
a(num) = FrontPageImage.Fields.Item("image").Value
b(num) = FrontPageImage.Fields.Item("link").Value
c(num) = FrontPageImage.Fields.Item("name").Value
FrontPageImage.MoveNext()
wend
%>

<% Dim RanID
Randomize
RanID = Int((num * Rnd) + 1)
RanImage = a(RanID)
RanLink = b(RanID)
RanName = c(RanID)
%>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>Orbital Sciences Corporation</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<LINK href="/includes/styles.css" type=text/css rel=stylesheet>
</head>
<body>
<script type="text/javascript" src="/nav/menu_scr.js">
</script>
<!--#include virtual="/includes/table_top.inc" -->
<table width="934" border="0" align="center" cellpadding="0" cellspacing="0" id="main">
<!--#include virtual="/includes/nav.inc" -->
	<tr>
		<td colspan="4" valign="top">
		<table  width="100%" border="0" cellpadding="0" cellspacing="0">
	<tr>
		<td colspan="4">
			<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="934" height="254">
			  <param name="movie" value="FlashBanner/deploy/main.swf" />
			  <param name="quality" value="high" />
			  <param name="wmode" value="opaque" />
			  <embed src="FlashBanner/deploy/main.swf" quality="high" wmode="opaque" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="934" height="254"></embed>
			  </object></td>
	</tr>
	<tr>
		<td rowspan="2"><a href="#"><img  src="/images/Graphics/Sub_feature/sub47_feature.jpg" alt="" width="207" height="190" border="0" usemap="#Map" /></a></td>
		<td rowspan="2"><a href="http://www.orbital.com/NewsInfo/MissionUpdates/MinotaurIV_STPS26/"><img  src="images/Graphics/Sub_feature/Feature_Sub1_MinIV STP-S26settolaunch.jpg" alt="Read the Latest Edition of the Orbital Quartely" width="208" height="190" border="0" /></a></td>
		<td>
			<img  src="/images/news/news_header.gif" width="52" height="25" alt="" /></td>
		<td>
			<img  src="/includes/images/spacer.gif" width="467" height="1" alt="" /></td>
	</tr>
	<tr>
         
		<td height="165" colspan="2" background="/images/news/news_body.gif"><table width="100%" border="0" cellpadding="4" cellspacing="0">
		  <% dim returns
									   returns = 0
									   while not release.eof and returns < 3  %>
          
          
          <tr>
            <td width="20" height="30" align="right" valign="top" class="TDfooter"><img src="images/graphics/Misc/blue_arrow.gif" width="7" height="11" /></td>
            <td valign="top" ><a href="/NewsInfo/release.asp?prid=<%=(release.Fields.Item("ItemID").Value)%>" class="TDnav"><%=(release.Fields.Item("HeadLine").Value)%></a></td>
          </tr>
          <% returns = returns + 1
											 release.MoveNext()
											 wend
										  %>
          <tr>
            <td align="right" valign="top" ><span class="TDfooter"><img src="images/graphics/Misc/blue_arrow.gif" width="7" height="11" /></span></td>
            <td class="sidebar"><a href="/NewsInfo/PressReleaseList.asp" class="TDnav">MORE NEWS...</a></td>
          </tr>
        </table></td>
	</tr>
	<tr>
		<td colspan="4">
			<img  src="/includes/images/spacer.gif" width="934" height="9" alt="" /></td>
	</tr>
</table>
		</td>
		</tr>
	<tr>
     <!--#include virtual="/includes/footer.inc" -->
  </table>
<!--#include virtual="/includes/table_bottom.inc" -->

<map name="Map" id="Map">
  <area shape="rect" coords="3,4,204,87" href="TaurusII/" alt="Taurus II Microsite" />
  <area shape="rect" coords="3,90,203,189" href="CargoResupplyServices/" alt="Cyngus Microsite" />
</map>
</body>
</html>
<%
FrontPageImage.Close()
Set FrontPageImage = Nothing
%>

Open in new window

Homepage.jpg
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 34192044
>> But here's a copy of th ecode that's on the main page as well as a screen shot. I can also attach the flash and
>> xml files if needed.

Probably not worth doing.  Can you run Firefox with Firebug and look at the page with Firebug active and the Net panel enabled?  That might return a 404 error for the XML and give us more of clue as to why it is failing...
0
DevOps Toolchain Recommendations

Read this Gartner Research Note and discover how your IT organization can automate and optimize DevOps processes using a toolchain architecture.

 

Author Comment

by:DxtrLws
ID: 34192912
I will give that a shot when I go back into the office tomorrow.
0
 
LVL 3

Accepted Solution

by:
prafullamjn earned 500 total points
ID: 34420848
In the page, just you need to call the swf file with the correct path. You can check by using Code and give the correct Path. When you insert by design it will come whole path, like D:/Flash/answer.swf and so on. you no need to give all the path just answer.swf.
Please insert and let me know..
It will help you .

thanks
0
 

Author Closing Comment

by:DxtrLws
ID: 34544782
Sorry for the late reply, but thanks!! That helped a lot. Looks like I had some of the files located in the wrong place. Sometimes it's just the small things that get overlooked.
0

Featured Post

DevOps Toolchain Recommendations

Read this Gartner Research Note and discover how your IT organization can automate and optimize DevOps processes using a toolchain architecture.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Which XML parser should I used for my requirement 11 65
Change to event 1 100
XSLT Help 12 28
XML Data Missing in PHP SimpleXML 8 44
I have been doing hardcore actionscripting for some time; and needless to say I have faced a lot of problems in just understanding others' code rather than understanding what the code executes. A programmer's life can become hell when there are a lo…
The last time I worked with Flash and Socket connections was in AS1. A recent project required flash connecting to a Socket, and sending receiving information - we figured it would be easy enough - we all know about the socket policy documents and c…
The goal of the tutorial is to teach the user how to live broadcast using Flash Media Live Encoder and connecting it to YouTube to broadcast. Log into your Youtube account, choose live stream settings, start live stream from Flash Media Live Enc…
The goal of the tutorial is to teach the user what frame rate is, how to control it and what effect it has on the video.

914 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now