• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4665
  • Last Modified:

"Specified Network Name No Longer Available" Error on Seagate NAS

Hi Everyone,

My client has a Seagate BlackArmor 440 NAS.    They can open up the file share on the NAS (via name or IP), but they are unable to open any of the files or copy any of the files off of the NAS.

When you try to copy a file off, it gives the error: "The specified network name is no longer available"

I've tried rebooting it.   Doesn't work.
I've tried resetting the IP configuration.   Doesn't work.
I've tried updating the firmware.    It won't allow me to update the firmware.  It gives me the error, "Failed to upload new firmware image to system"

I really need to access this data.   My client is dead in the water without it.    Any ideas?
0
Justin Goo
Asked:
Justin Goo
  • 14
  • 7
  • 2
  • +3
1 Solution
 
Justin GooPresidentAuthor Commented:
BTW, Seagate technical support was no help whatsoever.   I was on the phone with them for an hour, and the best they could say was "you may need to replace the unit".   But that wouldn't get me all of the data off of it either.
0
 
VirtaliciousCommented:
Please take a look at this utility.
Its Legit and I have used it.  It usually ids the issues and can fix most of them
I have recovered 80TB SAN with this.

http://www.cgsecurity.org/wiki/TestDisk

Let us Know!
-Virt
0
 
theras2000Commented:
That's really strange indeed.  I'd suggest 2 troueblshooting steps.
1. Can you copy files from your PC to the NAS?  Can you copy files from the NAS to the NAS?
2. Can you isolate form the network and just use a single crossover LAN cable from the NAS to a lappy and see if the problems remain.
3. If you don't end up getting a solution, perhaps there's same way you can use the web interface to copy files ... in that case you could copy to an external USB ... just as a last resort thing.
0
What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

 
Justin GooPresidentAuthor Commented:
I'm not really sure how that TestDisk software would help me to recover the data since it's not a lost partition on a local drive, it's access to a NAS file share that I can't to work.


0
 
Justin GooPresidentAuthor Commented:
I cannot copy from PC to NAS  OR from NAS to PC.   Both give me the error "The specified network name is no longer available."

I can't seem to find anything in the web interace for the NAS to allow me to copy or manipulate the files directly.  The best option it seems to have is to run a backup to a USB drive.   But I have tried running backups in the past and they've always failed.

I don't currently have physical access to the NAS, only remote access.   When I can get onsite, I will try with a direct connection to a PC via crossover cable (this unit doesn't seem to have a USB connection to a PC).
0
 
theras2000Commented:
Yeah I just can't think of any suggestions other than (a) it's stuffed and needs wiping or (b) it doesn't like something on your network and a direct connection would be the place to start.

I don't suppose you have Symantec?  This page http://support.microsoft.com/kb/961293 lists prooblems like yours, but it's on a fileserver running Symantec.  I know this is not your direct problem, but it's the kind of example that makes me think you have weird networky problems (including any firewalls in between you and the NAS).

Here's some more networky examples http://support.microsoft.com/kb/325487
http://forums.cnet.com/7723-7589_102-19682.html
0
 
Justin GooPresidentAuthor Commented:
Okay.  I tried it direct to PC.  Still no luck.

I tried changing the link speed down to 10mbps.  Still no luck.

I can't run the backup either.  It just gets stuck.

Any ideas?
0
 
Justin GooPresidentAuthor Commented:
Okay.  I tried it direct to PC.  Still no luck.

I tried changing the link speed down to 10mbps.  Still no luck.

I can't run the backup either.  It just gets stuck.

Any ideas?
0
 
Justin GooPresidentAuthor Commented:
And no... no Symantec..
0
 
theras2000Commented:
I assume you've tried from a few PCs too, so that we can rule out your PC?  If not, then dang it really looks like a fault on the NAS hardware/firmware.  In fact, wiping disks probably wouldn't solve anything.  :<
0
 
Justin GooPresidentAuthor Commented:
Well, I only tried directly connecting from one PC.   But the "specified network name is no longer available" error is showing up from every PC in the office.   So it really can't be just the one.
0
 
theras2000Commented:
Yeah I'd agree.
0
 
Justin GooPresidentAuthor Commented:
Well, Seagate is sending me a replacement NAS.    They think that the firmware is just corrupted and if I am unable to update the firmware, then the thing is just a brick.   But this doesn't do anything for me to recover the data.

Is there any way to FORCE a firmware update with that NAS?

Is it possible to remove the drives from the old NAS and just put them into the new NAS so that I can retain the data?

0
 
theras2000Commented:
No idea about the firmware.  Certainly there'd be a way to pull the drives out, but it just depends on warranty and such.  You should have asked Seagate about it.
Actually here, it looks dead easy on page 55 http://www.seagate.com/staticfiles/blackarmor/userguides/BlackArmorNAS440UserGuide.pdf
0
 
Justin GooPresidentAuthor Commented:
Okay... you won't believe this, but I got the brand new NAS.   I took the old HDDs out of the old NAS, and shoved them into the new NAS, and the new NAS booted up exactly the same as the original.   Meaning it had the exact same firmware version, it had the exact same IP Address, and it had the exact same problems!!!   Apparently, the Seagate firmware is not kept on flash memory of any kind, it's just written directly into the disk array.   So I'm stuck with the faulty firmware and the data on the same drives.    
0
 
theras2000Commented:
Whaaaaaat!  Have Seagate support got any bright ideas?  I'd suggest pulling the drives out and just putting a spare blank one in to see if you get the same problems on that.
BTW how many drives did you have and what RAID config were you using?
0
 
Justin GooPresidentAuthor Commented:
Well.... Seagate said I'm doomed.  There is no way to force the firmware update, so the only option I've got left is to go with their PAID Data Recovery services.   So they're sending me a quote in a couple of hours.   Dang it.

Unofficially, the tech told me that I could also try pulling out the drives, and hooking them up to a PC.   He said that I could then search for a Linux File Viewer, and theoretically that should be able to read the drives.   However, the NAS has 4 drives in a RAID 5 configuration.   I don't have any PC that has more than 4 SATA connections.   I would need 1 for the boot O/S at least, and since it's RAID 5, I should only need 3 out of 4 drives to read the array, so it should theoretically work.   Do you know if the Linux File Viewer from Disk Internals will read a RAID array?

0
 
theras2000Commented:
Sorry I've no exp with Linux at all.  I wasn't even aware that RAID arrays could be read on other machines by other software etc. so I'd love to hear how it goes.  Make sure you label your drives as the disk order is probably important.
0
 
BudDurlandCommented:
Have you tried changing the IP address of the NAS?  The symptom you describe can occur if two devices on the network have the same IP address.
0
 
Justin GooPresidentAuthor Commented:
Yes, I tried changing it.
0
 
BudDurlandCommented:
Is there a server on this network, or only the NAS?  Do all the devices agree about the workgroup name?  If there's a Windows server involved, does it have a WINS entry for the NAS?  If you do a PING -t <nasname>, and let it run for several minutes, does it drop packets?
0
 
Justin GooPresidentAuthor Commented:
No server on the network.
Everyone in the same workgroup.
Ping -t does not drop any packets.

0
 
rindiCommented:
Check out the "RAID Reconstructor". It makes an image of each HD, then it can put those images back into one to simulate the RAID array you had (of course you will need enough disk-space for this).  You can then try booting a Linux LiveCD like PartedMagic, mount that "rebuilt" array image and copy the files off.

http://runtime.org

http://partedmagic.com/

The RAID reconstructor isn't free though, and I personally haven't had to use it yet, so when it comes to details I won't be of much help. In my opinion the better option is to use the recovery of seagate. After all, it isn't your money, and if your customer kept all his data in one place without a backup, that is his own fault. Using a RAID 5 in a NAS doesn't exempt anyone from having a backup if he wants his data safe.

A further thing you could try is to clone the old HD's to the new ones, then check if you can work with the new ones. The PartedMagic LiveCD has cloning tools included.
0
 
Justin GooPresidentAuthor Commented:
Well... I took the drives out of the NAS and hooked them up to my PC.   I tried using all of Disk Internals' tools, as suggested by Seagate.   I was able to see that the drives were there.   I was able to see a partition on the drives, with a "storage file" on them.   But I wasn't able to see anything else.

But what's worse, is I put the drives back into the NAS, and now the NAS won't even boot!!    

So I think I'm just really screwed now.
0
 
Justin GooPresidentAuthor Commented:
Well, it looks like we're going to have to send the drives back to Seagate, and hope that their data recovery services don't cost us an arm and a leg.    Thanks for all your suggestions.
0
 
ee_autoCommented:
Question PAQ'd and stored in the solution database.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 14
  • 7
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now