XenApp 6 error= Remote Desktop Services is currently busy

Hi, users are having random issues when connecting to our Windows 2008 R2 XenApp 6 servers.  I think it might be when they try to reconnect to a session.  I see in some forums this was caused by firewalls or anti-virus on the servers.  My servers have no FW but they do Symantec Endpoint which I will test after uninstalling.  The message is:

"The task you are trying to do can't be completed because Remote Desktop Services is currently busy.  Please try again in a few minutes.  Other users should still be able to log on."

Thanks in advance for the help.
LVL 1
JohnLeo9Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
JohnLeo9Connect With a Mentor Author Commented:
We opened a case with Citrix but they quickly pointed the blame at Microsoft.  So we opened a case with Microsoft and they suggested 3 hotfixes which update the following files:

Win32k.sys - http://support.microsoft.com/kb/2383928
Ntoskrnl.exe - http://support.microsoft.com/kb/2398906
3 other files: http://support.microsoft.com/kb/2265716

We know the descriptions don’t match, but these hotfixes offer the latest and greatest for the files in question.

They also suggested the KB979530 to update regapi.dll and KB981872 which updates rdbss.sys. the combination of those two plus the above 3 hotfixes got rid of the issue for the other client.

None of that helped though.  Still working on it.
0
 
stratlover4lifeConnect With a Mentor Commented:
Hi there,

I am getting the same issue. I have spoken to Microsoft and they are working on a fix which should be released to the public in the next 2 weeks. I am anxiously waiting as it is a pain when this happens. I have 2 Xenapp 6 servers and it happens randomly a couple times a week. I have a little success by writing a script to restart the Xenapp servers every night and it reduced the occurrences a little bit.
0
 
stratlover4lifeCommented:
The things I have noticed will help you suppress this issue is going to the web interface and remove the server name that is having these issues and new connections will be sent to the server. The only other options is to bource (restart the server) manually and that will clear it up. Take a look at your system event log you will see several errors Event ID 7011 under Crup Service something another. Good Luck!
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
stratlover4lifeCommented:
I meant to type Crypt Service Error Event ID 7010
0
 
JohnLeo9Author Commented:
I do not remember seeing that error, but I will check again.  I will see if I can also call Microsoft as well.  Please post back here when you get the fix, thanks.
0
 
stratlover4lifeCommented:
Got it keep me posted I really would like to get this resolved.
0
 
JohnLeo9Author Commented:
Still no luck.
0
 
JohnLeo9Author Commented:
I actually just heard from the client.  It seems all the Microsoft hot fixes may have worked after all.  They also changed the disconnect time from 1 day to 8 hours, but I think they changed it back and still did not get the error again.
0
 
stratlover4lifeCommented:
So are you saying you have a fix by using the hotfix steps you mentioned above?
0
 
JohnLeo9Author Commented:
Stratlover4life suggested a Microsoft fix was needed so I called Microsoft to find out which fixes.
0
 
HSWENTCommented:
I am having the same problem  with a single user. On my machine I can login to citrix as myself and run the application. but when I try to login as this user (from the same workstation and connect to same citrix server) I get the  error.
"The task you are trying to do can't be completed because Remote Desktop Services is currently busy.  Please try again in a few minutes.  Other users should still be able to log on."
All other users seem to work fine.  Seems to be tied to the application somehow because the same user can run other applications from the same citrix box. I have deleted the citrix profile from the box and I still get the same message. It seems that it might be something in AD not being cleared out.
0
 
T-ckoCommented:
Did you tried SP1? In most cases it helps.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.