Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

IPSwitch iMail emails missing information in an account

Posted on 2010-11-22
12
Medium Priority
?
1,076 Views
Last Modified: 2012-05-10
I've run into a strange problem at the school I support.  The email service is IPSwitch Imail, version 11.02.  One user's account has nearly all their emails "missing."  The emails are listed with timestamps when they log in, but the subject, body, to address, and from address are all missing from each.  I tried removing the .guid, .uid, .xml files of main (main being the inbox) so they could be regenerated on login, but it didn't help.  The .mbx file contains the emails themselves (I couldn't remove that without removing the emails).  The user accesses their email with the iMail web interface.  Any suggestions?

Thanks!
0
Comment
Question by:ruralsolutions
  • 5
  • 5
10 Comments
 

Author Comment

by:ruralsolutions
ID: 34193494
I tried accessing the account with Thunderbird. All the blank messages showed timestamps of the same time, the time when I first pulled the mail down in t-bird.  A couple of the messages showed something like this: ------_=_NextPart_001_01CAED25.70788580--
0
 
LVL 21

Assisted Solution

by:snusgubben
snusgubben earned 2000 total points
ID: 34214542
0
 

Author Comment

by:ruralsolutions
ID: 34234685
Yeah, I can open it and read it.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 21

Assisted Solution

by:snusgubben
snusgubben earned 2000 total points
ID: 34235004
Is the formatting correct (refered to the link above)?

If you create a test user and copy the problem mailbox file to this user folder. Can you view the e-mails from the web interface logged in as "test user"?
0
 

Author Comment

by:ruralsolutions
ID: 34243009
I created the test user and the same emails were missing.  I'm able to read the mbx file and the formatting is correct accept for the missing emails.  Here's what the missing emails look like (addresses removed for privacy, one actually missing):

From <person@address> Fri Nov 12 12:21:01 2010

X-UIDL: 591150466



From <person@address> Tue Nov 16 08:31:31 2010

X-UIDL: 591150467



From <person@address> Tue Nov 16 10:43:31 2010

X-UIDL: 591150468



From <> Tue Nov 16 14:07:09 2010

X-UIDL: 591150469



From <person@address> Tue Nov 16 15:34:34 2010

X-UIDL: 591150470



From <person@address> Tue Nov 16 18:07:34 2010

X-UIDL: 591150471



From <person@address> Wed Nov 17 09:39:38 2010

X-UIDL: 591150472



From <person@address> Thu Nov 18 09:55:35 2010

X-UIDL: 591150473



From <person@address> Thu Nov 18 10:09:46 2010

X-UIDL: 591150474



From <person@address> Fri Nov 19 06:58:58 2010

X-UIDL: 591150475



From <person@address> Fri Nov 19 07:54:57 2010

X-UIDL: 591150476
0
 
LVL 21

Accepted Solution

by:
snusgubben earned 2000 total points
ID: 34243535
You are obviously missing the header and body. If those are not in the mbx-file, you can't read them.

You could look in the SMPT log from November 16 -19 to see if there was anything fishy with the D and Q file, but I don't to think that you'll be able to recreate those messages.

I would create a new user for the unlucky one with a new mailbox. Copy the mbx-file over to this new account, and remove "empty mails" from the file.

I would also run a "chkdsk" on the disc where the mailbox was located to be sure you don't have any bad sectors.

0
 
LVL 21

Expert Comment

by:snusgubben
ID: 34243541
* SMTP log (not SMPT)
0
 
LVL 21

Assisted Solution

by:snusgubben
snusgubben earned 2000 total points
ID: 34243583
It's been a while since I last saw a IMail server, but if I remember correct you could check the "IMail\..\..\SPOOL" folder for any orphan D-files (created nov 16-19).

A D-file is paired with a Q-file. ie.

D12jklj232j121213
Q12jklj232j121213

Both those two files are required to have a successful mail delivery.
0
 

Author Comment

by:ruralsolutions
ID: 34243638
Thanks for the excellent suggestions, I'll look into them!  Yep, iMail is at times the bane of my IT support existence.  It's also running in Server 2003 on a computer which should be a desktop computer, not a server.  P4, 80 GB hard drive and 1 GB of RAM until I came along and upgraded it to two gigs (still same HDD and CPU though).  But it's a small public school so not surprising.
0
 

Author Comment

by:ruralsolutions
ID: 34243779
No D or Q files currently in the spool folder.  Just log and txt files.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes clients can lose connectivity with the Lotus Notes Domino Server, but there's not always an obvious answer as to why it happens.   Read this article to follow one of the first experiences I had with Lotus Notes on a client's machine, my…
Among the most obnoxious of Exchange errors is error 1216 – Attached Database Mismatch error of the Jet Database Engine. When faced with this error, users may have to suffer from mailbox inaccessibility and in worst situations, permanent data loss.
This Micro Tutorial will demonstrate the easy use of Gmail embedding images in your email so the recipient of your email can view them in context.
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question