PWA Access denied

Hello Experts,

I created new user (AD account)  in Project server 2007 using server setting -> Manager user. I have selected windows authetication option & added to administrator group. When i try to login to windows box using that new user account and access the PWA from IE i get following error message "Error: Access Denied "

Please help.
err2.jpg
LVL 1
sudhirgoogleAsked:
Who is Participating?
 
sudhirgoogleAuthor Commented:
I followed below steps to clear the queue. Now the queue is empty but still facing same problem. Please help.

1. Launch Services.msc
2. Stop the Project Queue Service
3. Stop the SharePoint Timer Service
4. Start the SharePoint Timer Service
5. Start the Project Queue Service
0
 
KimmyelCommented:
Verify that the user exists in AD and is enabled
0
 
sudhirgoogleAuthor Commented:
yes the user exist in ad and i am able to login to windows using that id.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
BembiCEOCommented:
Can you login on the same machine with a different account?
If you cannot logon in general, it may be just a browser (authentication) setting. Dependend from your settings in MSPS, you may try to disable "Integrated windows authentification" (what means Kerberos) in IE.

If you cannot login only with your new account, but can login with an older account, make sure, the user is at least team member and the windows user name in Resource center is set correctly (i.e. MyDomain\MyUser) and that the account setting there is correct.

That you can logon into windows does not mean, that the account is set correctly in project server.

See if you have errors in the queue, especially if you create such a user.
0
 
sudhirgoogleAuthor Commented:
Yes I am able to login on the same machine with different account.

I am not able to login only with new account and i am able to login with older account.
Yes the user has at least team member and the windows user name set correctly in resource center.
0
 
Greg BessoIT Solutions EngineerCommented:
Which groups did you add the user to? In Project Server 2007 there are more than one type of admin. There are the built-in WSS/MOSS security groups, and then there are the Project Server 2007 roles.

Log back in as the other user and verify where this user has access. Do this in both Server Settings, and Site Actions > Site Settings.
0
 
sudhirgoogleAuthor Commented:
I have add him to "Project Managers" group and i can see that "My organization" category is linked.
0
 
BembiCEOCommented:
Can you sign in with an account, which belongs to the same user group?

a.) There is a global permission under "General" --> "Log on", which is necessary to logon in general, set by default for all groups.  

b.) There is a global permission under "General" --> "Log on to Project Server from Project Professional", which is set by default for Project Managers group.

These settings should not denied in any other group, the user is member in.

c.) Within the user properties on Project Server Web-Access, there is an additional checkbox "Ressource can logon to project server"

Categories has nothing to do with logon permissions, and users should not be directly associated with a category. The categories are associated to user groups.
0
 
sudhirgoogleAuthor Commented:
Sorry for delay in response. The answer is yes to all your above questions.
I believe the problem is due to failed tasks in the queue. Please take a look at attached snapshot.

How do i clear this queue. I have around 142 tasks in the queue. I tried restarting the queue service and restarting the EPM server several times but it didn't work. Most of the task were in "Failed and Blocking correlation" state.

Please help.
queue.JPG
0
 
BembiCEOCommented:
The point is not to clear the queue, the question is, why the queue fails in a blocking state, which stops all subsequent actions.

At the end of the line of the queue, there is a link to an error description. This is a little bit cryptic, but gives hints to the reason. Usually one of the last actions has something to do with this.

A common mistake is the fact, that (not only) user names are used within SQL queries. This means in fact, that all kinds of special characters (including commas etc.)  in object names (like resource names, field names etc. are a source of failure. All these names shoudl only contain regular characters.  If such special characters get part of a sql query, the query text may get invalid and results into a blocking situation, what means, that all subsequent query jobs are stopped.
0
 
sudhirgoogleAuthor Commented:
Hello Bembi,

Thank you very much for your solution. It helped me to understand different causes for the issue.
Answer is here..
After clearing all the tasks in queue that were in blocked state resolved my problem.

Thanks for your support experts.
0
 
sudhirgoogleAuthor Commented:
I followed below steps to clear the queue. Now the queue is empty but still facing same problem. Please help.

1. Launch Services.msc
2. Stop the Project Queue Service
3. Stop the SharePoint Timer Service
4. Start the SharePoint Timer Service
5. Start the Project Queue Service
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.