• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1001
  • Last Modified:

Windows 7 not displaying icons for JPG, PNG etc.

Win7 Home Premium has stopped displaying icons in folders.

Have tried creating new DWORD in Registry and set value to 8192.  Also deleted Icon Cache file.

Cannot locate gpedit.msc (apparently not in this version of Windows 7).

This seems a basic issue and am a little surprised that it is has even occured.  Would appreciate any help in rectifying please.

Martin Dean
0
martindean001
Asked:
martindean001
  • 5
  • 3
1 Solution
 
KimmyelCommented:
Are the extension .jpg .png associated with any program?
Can you please verify this by going into 'Folder Options' > 'File Types'
If not, add the program you want it to start with and reboot.
If yes, which one?

Regards
0
 
rsoly777Commented:
Right click on the file and select "open with" Select a program and tell it to always open with this application. See screen shot "Open With" Screen capture
0
 
rsoly777Commented:
Once the program is associated the icons will display
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
martindean001Author Commented:
Thank you both for your quick responses.

.JPG is associated with Windows Photo Viewer and I have changed this to another programme - no change in the folder when I look at the files' icons.  Likewise, .PNGs are associated with Windows Photo Viewer and this was swapped (back) to Adobe Fireworks.  

The files display an icon but not a preview thumbnail.  Also, if I activate the 'PREVIEW' panel in Explorer, only the generic icon appears.  So, I cannot preview any pictures (including PSD) unless I open the file in its associated application.

Have attached a few screenshots.

M
Screen-grab---jpg.JPG
Screen-grab2---jpg.JPG
Screen-grab3---jpg.JPG
0
 
rsoly777Commented:
Still looks as if your associations are messed up somewhere, Take a look in the control panel> Programs> Default Programs> Set Associations and make sure they are set to the desired associations for the files you want. If that doesn't make a difference see if there is a repair option in the program you want them associated to. When did this start happening? Was it right after installing the application you are trying to associate these with?
0
 
martindean001Author Commented:
My file associations are not specific.  For example, I have chosen various different applications to open .JPG and .PNG.  None of these result in the expected behaviour in the folder - where I would normally see a thumbnail appearing.

I cannot exactly remember when this started happening, although I believe it was some time ago.

Would still appreciate any thoughts you may have.

Martin
0
 
martindean001Author Commented:
I have also checked for the file 'thumbs.db' which does not seem to exist anywhere on my system.  Isn't this the file which saves and displays the the thumbnails?

If this should exist (in every folder with grpahics or photos), could this be the reason I cannot see any thumbnails?
0
 
martindean001Author Commented:
OK - It looks like I have found my own solution.

The setting 'Always show icon never thumbnail' was checked in Folder Settings and therefore no thumbnails were displaying.

Thanks for trying
0
 
martindean001Author Commented:
I am closing tue question because I managed to find my own solution.  The score of B is to reflect the prompt responses and attempts to solve my problem.  Unfortunately none of the responses were correct.

The answer was a very simple fix and perhaps the experts were looking for too complex a solution??
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now