Adding Static Route

Posted on 2010-11-23
Last Modified: 2012-05-10
I have a SiteProtector console which is running windows 2003 server. It has one NIC. I am putting this device in our DMZ and setting the default gateway to but want any traffic for or to go to gateway.
Device Network info is:
Static IP:
Default Gateway:

I have tried:
route add mask
route add mask
"The route addition failed: Either the interface index is wrong or the gateway does not lie on the same network as the interface. Check IP Address Table for the machine."
Question by:m_travis
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2

Expert Comment

ID: 34196575

Try to specify the interface index, using the 'IF' command line parameter.
I understand there is only one physical NIC but ...

LVL 95

Expert Comment

by:Lee W, MVP
ID: 34196643
Add an IP Address to the NIC so that it has an address on both the 10.x.x.x network and the 170.230.x.x network

Author Comment

ID: 34196682
when I type route print the only interface besides is 10003, so I put
route add mask IF 10003
I got the same error

This device is in the DMZ and the only IPs allowed in that network range is addresses
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

LVL 95

Expert Comment

by:Lee W, MVP
ID: 34197347
I'll repeat:
Add an IP Address to the NIC so that it has an address on both the 10.x.x.x network and the 170.230.x.x network

You can't add a route when the machine has no logical way of getting there!

Author Comment

ID: 34197561
maybe I didnt make myself clear. So here is an image to help clarify things, hopefully. I need all of the and to go to and all other traffic go to

leew: the server is pointed  to 24.1 as default, so it can get to the internet just fine, I need it to get to the internal network. 170.230 address is not allowed to exist in the DMZ the 10.100.24 range. Diagram

Accepted Solution

m_travis earned 0 total points
ID: 34240277
The appliance had to be plugged into the network, even if the it is plugged into the wrong network range. I never tried this assuming that it wouldnt help since it had a static of and was being plugged into a network.

Author Closing Comment

ID: 34276729
No one suggested even checking the NIC card on the device. I got the idea from a MSS engineer.

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
I had an issue with InstallShield not being able to use Computer Browser service on Windows Server 2012. Here is the solution I found.
After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question