MS outlook and Outlook Express not sending FQDN

Posted on 2010-11-23
Last Modified: 2013-11-10
Our mail server requires the PC's sending the emails to have FQDN. I set mine in "My Computer>System Properties>Computer Name tab>Change>More>Primary Suffix for this computer"
also in "LAN Properties>TCP/IP>Properties>advanced>DNS tab>DNS suffix for this connection"

After restarting, the Computer Name tab in the System properties does show a FQDN but when I send mail using outlook express I still get the error:

The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address XXXXXX. Subject 'test 3', Account: XXXXXX', Server: XXXXXXXX, Protocol: SMTP, Server Response: '504 5.5.2 <RTVMKTGD1>: Helo command rejected: need fully-qualified hostname', Port: 25, Secure(SSL): No, Server Error: 504, Error Number: 0x800CCC79

also when I issue the command "hostname" in DOS prompt. I get the name without the suffix (but maybe that's normal, I don't know).


Question by:uridimitri
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34196585
When you say "our mail server" - what type of server is this and is it a company server or a hosted mail server or your ISP's mail server?

Outlook / Outlook Express usually only needs to login with a valid username and password to send mail - it does not need a FQDN to be able to send mail.

Author Comment

ID: 34196657
It is a company server running postfix
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34196776
Do you have to provide a username and password to access the server or does it accepted mail from anyone as long as your FQDN is configured properly?
Is Your DevOps Pipeline Leaking?

Is your CI/CD pipeline a hodge-podge of randomly connected tools? You’ve likely got a tool to fix one problem & then a different tool to fix another, resulting in a cluster of tools with overlapping functionality. Learn how to optimize your pipeline with Gartner's recommendations


Author Comment

ID: 34197299
I have to give user name and password (actually password only since the outlook express email account is already setup, but I did not select "remember password"). The funny thing is When I send mail using Mozilla Thunderbird on the same computer (create same user account), it sends without problem.

I won't send/receive without this authentication..
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34197437
It sounds like an Outlook / Outlook Express setting issue.  Can you setup a new Profile and a new account within that profile and test?

Does that account work happily?

Author Comment

ID: 34197582
OK, just created a new account on OE. I'm receiving the same result.. My last option is to tell all my users to migrate to thunderbird. But only if I can't find a solution to this..
LVL 23

Accepted Solution

Maciej S earned 500 total points
ID: 34213924

Featured Post

RoboForm Secure Password Management System

RoboForm Everywhere - Superb Browser Support
Windows / Apple / IOS / Android / Linux / Chrome OS
Use different complex passwords everywhere
Best Secure Password Management by far
Synchronize all of your devices instantly
Safe, Secure & Highly Recommended!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
When you have clients or friends from around the world, it becomes a challenge to arrange a meeting or effectively manage your time. This is where Outlook's capability to show 2 time zones in one calendar comes in handy.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question