• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 441
  • Last Modified:

SBS 2008 / Exchange Server Problems

  It has been running fine for two years. Two days ago messages started getting stuck in the queue, I am on FIOS so I am using smtp.frontier.com as a smarthost. I look at the queues and the messages are stuck in the smtp.frontier.com queue with the last error on the queue being "451 4.4.0 DNS Querey Failed".

   I am going to say nothing has changed on the server but obviously something has. I have no idea where to start on this. I found an article that said to download and install Rolluo 3 for ES 2007 to correct the problem but that patch won't even install.

Help!!!!!!
0
jimbecher
Asked:
jimbecher
  • 4
  • 2
1 Solution
 
Alan HardistyCo-OwnerCommented:
The usual issue with DNS on SBS 2008 is either a lack of DNS forwarders on the Forwarders Tab of DNS Server Properties or that the DNS servers have changed.

Please check yours - check with your ISP for their current DNS server IP Addresses and make sure your forwarders are either correct or if none, add the current ISP's forwarders.

That should hopefully sort you out.
0
 
jimbecherAuthor Commented:
  Thanks Alan. I came across that too. The forwarders were not changed. Thinking Frontier might have their DNS servers messed up (they have been on a path of death and destruction lately) I added a couple more Verizon DNSs (4.2.2.1 and 4.2.2.2), moved them to the top of the list and the problem persists.
0
 
Alan HardistyCo-OwnerCommented:
Okay - what are the DNS settings on the SBS server?

It should be set to look to itself to resolve DNS (i.e., the Server IP Address as the Primary DNS server).

Can you resolve smtp.frontier.com in DNS from your server in a command prompt?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
Alan HardistyCo-OwnerCommented:
Alternatively - if DNS is not working - for now change the FQDN for the SmartHost from smtp.frontier.com to the IP Address of 66.133.129.50 and then you don't have to resolve the name!
0
 
jimbecherAuthor Commented:
The NIC DNS is pointing at itself. I can resolve smtp.frontier.com from the server. Very funny. I changed the smarthost to 66.133.129.50 and that seemed to do the trick. I am going to run with it and see what happens. Thanks!
0
 
Alan HardistyCo-OwnerCommented:
No problems - at least it gets you out of hot water for now.

Thanks for the points.

Alan
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now