How do I maximize a window on second monitor in Windows 7?

There's an application I'd like to run on a second monitor, maximized, whenever it is opened. I've been able to do this in XP but for some reason I'm unable to get 7 to behave. So far I've been able to get the application to open smaller in the correct monitor but I can't get it to remember the size of the window, most of the time I can't even resize the program any. Any attempts to maximize the program bring it to the primary monitor, is there any program out there that will force a program to be maximized on a second monitor or am I just spinning my wheels?
hobbin_computingAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
hobbin_computingConnect With a Mentor Author Commented:
Thank you both for posting, unfortunately I just got word back from the vendor that this is a known bug with the software and they're hoping to have it fixed in future releases, what a bummer :(
0
 
Mez4343Commented:
It might be a default setting of the program in question to open in a smaller size.Is your screen resolution on XP and Win7 the same? Some programs are written to restrict size based on how the developer has coded the User Interface.

You can try to run the program from MS-DOS.
1) Start-cmd
2) START /max yourprogram.exe

/max[imized] Run the new program maximized (in the foreground).


0
 
music2myear1Commented:
I'm not at my Win7 box right now, but the setting should be in the same place.

If you don't see File, View, Tools, Help etc, menus in a My Computer window, press the ALT key to show them and then open Tools -> Folder Options.

In the View tab, look for Remember each folder's view settings and make sure it is checked.

This should set the option you're looking for.

If that doesn't work it doesn't mean Win7 doesn't support this function. I've run multi-monitor setups on Win7 since I got it and I don't recall a time when it did not restore each application to it's previous window and view state upon reopening. So if it isn't this setting, there's another one out there somewhere that'll do the trick.
0
 
hobbin_computingAuthor Commented:
Vendor acknowledged this was a known issue to be fixed in future releases
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.