Solved

Problems with DC Demotion in Citrix environment

Posted on 2010-11-23
7
551 Views
Last Modified: 2012-08-14
Hi Everyone, here is a problem one of our customers IT departments is experiencing, anyone have any insight?


When I started at CompanyX, the network had one older server (called Phoenix) that provided the following roles:
1.      Primary domain controller
2.      Citrix license server
3.      Primary file server
4.      Print server.

Soon after I replaced this with a brand high-end HP server ( Jupiter) that became the primary DC, and file server.  During the process I demoted Phoenix and over time I started moving the other roles, like the Citrix licensing and print server, onto other servers. A couple of months ago I decided it was time to turn Phoenix off and see what happens.

The first thing was that some citrix sessions lost their desktops.  There was also program errors seen in our ERP application.  An print-job routing application that runs  on another server stopped working.
I started investigating first by using process monitor then by testing affected user accounts.  One thing that I did find was that were places, MSOffice application default file location for example, that instead of using a UNC (we map folders to W: & U: drives) I was seeing instances of \\phoenix\; the server name was being hard coded. I also found that the “MyDocuments” folder was redirected to \\phoenix\userhomefolder.

I logged onto one of the citrix servers that seem to be causing the problem with a user account that was experiencing the issue.  I searched the HKCU hive of the registry and found multiple references to \\phoenix\ but when I logged onto that server as an administrator I found few  in any of the hives.  I then tried manually changing the HKCU registry entries (I don’t remember if I changed them to \\jupiter\ or used a UNC path) for affected users only to see them revert back the next time they logged on.

I  searched every group policy I could think of/find on the chance that there was some folder redirection going on, but to no avail.  I’ve considered the possibility that this is still the issue and that I am looking in the wrong place so this might be a good place to start.

I’ve also looked for a 3rd party AD interface but there is no indication that any exists.

I’m not sure what to try next.

Any Ideas?


0
Comment
Question by:SpyderG
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 
LVL 31

Expert Comment

by:Justin Owens
ID: 34199794
RSoP is your friend. Resultant Set of Policies, run on your Citrix server, will tell you which policies are being applied to it and what the results of those policies are.

Overview of RSoP:
http://technet.microsoft.com/en-us/library/cc758010%28WS.10%29.aspx

How to use it:
http://support.microsoft.com/kb/323276

Search the results for your \\phoenix\ server.

DrU
0
 

Author Comment

by:SpyderG
ID: 34201310
We will give it a shot and ill report the findings, thank you Dr!
0
 
LVL 31

Expert Comment

by:Justin Owens
ID: 34205837
No problem.   Let me know what you find...
0
Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

 

Author Comment

by:SpyderG
ID: 34213404
I ran the utility for one user I know was having the problem and I couldn’t find anything pointing to \\phoenix.

I'm still racking my brain looking for anything I'm missing, sure it's probably a fairly simple fix
0
 
LVL 51

Accepted Solution

by:
Netman66 earned 500 total points
ID: 34254291
If these users have roaming profiles, then the HKCU key is basically the NTUSER.DAT file.  If the changes never made it to that file on the roaming profile share, then the next logon would overwrite your changes.

As a temporary measure, you could always create a Host (A) record for Phoenix and give it the IP of Jupiter.  This would then resolve to the right location as long as the shares were named the same.

Let us know.
0
 

Author Comment

by:SpyderG
ID: 34320287
Busy with other issues this past week, will try this out before next week.

Cheers!
0
 

Author Closing Comment

by:SpyderG
ID: 34468047
This seemed to provide a temp solution for the customer as they havent responded back to us since providing this info. I look forward to them responding with their final solution, if they provide one i will add it to this case.

Thanks so the help everyone!
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question