?
Solved

Remote Desktop Connection setup on Windows 2008 Web Server and firewall ports

Posted on 2010-11-23
8
Medium Priority
?
846 Views
Last Modified: 2012-05-10
I want to setup  my remote desktop connection to allow someone to call into my windows 2008 web server and look at my IIS7 and event logs and make sure everything is setup properly, etc.

I need to setup my firewall to allow them in:
1) how can I setup my firewall to allow them to specifically log into THIS machine and not the machine that is assigned to the firewall? I'm using Netgear Prosafe.
2) what ports should I setup for the services and what type?

The last time I did this, the user could only log into the IP address that was assigned to the firewall. Is there a way it can be setup so that they can log into the actual box needed?

3) How do I setup the Windows 2008 Web server to turn this feature on?

I need step by step instructions.

thanks!
0
Comment
Question by:Starr Duskk
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 10

Expert Comment

by:moon_blue69
ID: 34201250
TCP port 3389

0
 
LVL 4

Accepted Solution

by:
DigitalTyrant earned 1000 total points
ID: 34201261
Microsoft Remote Desktop uses port 3389.  You would want to forward the port to you server using the Prosafe.  If you already have 3389 mapped to a different computer you can forward any port, preferable above 5000 to port 3389 of the server.  If you have chosen to use a port other than 3389 you can simply specify the port when connecting, ie. server:port.  
To enable Remote Desktop on your server, click the start menu, right-click on computer and click the Remote Settings link in the left pane.
0
 
LVL 10

Assisted Solution

by:moon_blue69
moon_blue69 earned 1000 total points
ID: 34201267
Right click -> my computer -> romote tab under remote deskto select allow and add the user whom you want to let connect to the server. On your router forward TCP port 3389 - you might find it as RDP. to the ip of your web server . I think thats it
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 11

Expert Comment

by:louisreeves
ID: 34201415
2008 SBS has a great feature called remote web workplace. If you do not have SBS then TS WEB access is great. You can hit your machine with a Web browser over port 443. The less port you have to forwad, the better. Truthfully, you  can use TSWEB with any port you wuish:
http://technet.microsoft.com/en-us/library/cc771908(WS.10).aspx

By the way I love these Guys:
http://www.virtualizationadmin.com/articles-tutorials/terminal-services/general/windows-server-2008-terminal-services-web-access-part1.html

Isnt this the way to access your server now?  I love RWW better bu this is great for standard 2008


0
 
LVL 2

Author Comment

by:Starr Duskk
ID: 34201532
When I setup the services, it offers TCP and UDP, but not RDP. I setup both TCP and UDP to a port over 5000 that isn't being used.

Then on my firewall, I have an inbound service to always allow both the tcp and udp Remote Desktop services I just setup, to the remote IP destination, and the LAN address for this box.

I get an error that the computer can't connect.
I'm using the remote IP and the port like so:
computer: xx.xx.xx.xx:xxxx
User Name: xxxx
I setup an administrative user and am putting in their user name.

Then pressing "Connect"
I  have tried this on two computers. One says it is one of 3 problems:
1) remote access is not enabled
2) remote computer is turned off
3) remote computer is not available on the network.

The other computer errors saying:
The computer can't connect to the remote computer.

I know it's turned on.
I enabled it via the methods you told me. Both in the netgear firewall setup and in the windows firewall.
I'm logging in with the custom port. The windows firewall and netgear firewall use the custom port.
The user is created as an administrator. I'm giving that user name.

Any ideas?

thanks.
0
 
LVL 2

Author Comment

by:Starr Duskk
ID: 34201546
Okay, I get now what you were saying about RDP, the build-in service. I'll try that without the custom port.
0
 
LVL 2

Author Comment

by:Starr Duskk
ID: 34201577
woo hoo! got it! thanks! I guess I'll just forego the custom port and disable it when I dont' need it. thanks!
0
 
LVL 2

Author Closing Comment

by:Starr Duskk
ID: 34201589
Thanks!
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question