Solved

Server 2008 Ent R2, RDC from Snow Leopard

Posted on 2010-11-23
4
1,105 Views
Last Modified: 2012-05-10
ok, fresh, brand new Server 2008 Enterprise R2...Macbook Pro with Snow Leopard...I'm using RDC 2.1 and trying to RDP to the server to work on it.  I'm getting the "you were disconnected from the windows-based computer because of problems during the licensing protocol" error.

I can connect from Windows PC's both from inside and outside the network so it's something with me Mac.

Is there a solution for this?

Thanks

Cliff
0
Comment
Question by:crp0499
  • 2
4 Comments
 
LVL 6

Expert Comment

by:thiagotietze
ID: 34202416
Are you able to see the licenses and verify if there is some available for your Mac?
Maybe you have ran out of licenses and all of them are delivered to your other desktops (in case of per machine license)

Take a look at this workaround:
"As a workaround (do not tell Microsoft I told you that), on the Mac, go to /Users/Shared/Microsoft/RDC Crucial information folder and DELETE the file that is in there. It should be called "RDC GLOBAL DATA". This should do the trick until you get the licenses you need."

It was registered on a old answer in E-E:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2000_Server/Q_23057372.html
0
 

Author Comment

by:crp0499
ID: 34202438
well, it's a new server, just installed (Remote Desktop Services) terminal server a couple of days ago so I'm using temp licenses just now.
0
 
LVL 15

Expert Comment

by:roylong
ID: 34204031
You should not need to worry about the licenses if this is administrative RDP access - you only need to worry about that if you are using the terminal services service for this server.  I access my windows servers all the time from snow leopard using MS RDP client.

My current version is 2.0.1 (090714)

I am just going to look at my settings.  Presumably you have put in the credentials for connecting using a domain account?  i.e. username; password; domain are correct...
0
 
LVL 15

Accepted Solution

by:
roylong earned 500 total points
ID: 34204048
Right, I have my credentials saved for each connection so that it does not prompt for them each time.

Display is set to Full Screen; Millions of Colors; Main Display (two monitors); desktop background is off; font smoothing is on; show contents (off); show menu (off); show themes (on); bitmap caching (on); don't show mac menu (off).

Keyboard is default and Sound is set to Mac only.

Drives is set to mount Home folder from Mac.

Printers set to my main mac printer.

Nothing set on Applications.

Security set to Warn me if authentication fails.

Another thing::
Is your username in the remote desktops user group on that server?  We have all our domain admins on ours so automatically added for all our Windows servers.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article we discuss how to recover the missing Outlook 2011 for Mac data like Emails and Contacts manually.
Let’s list some of the technologies that enable smooth teleworking. 
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question