[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 975
  • Last Modified:

Jboss Time Out

Hi Expert

When I start my jboss-4.0.2 in my local machine it start's up
JBoss (MX MicroKernel) [4.0.2 (build: CVSTag=JBoss_4_0_2 date=200505022023)] Started in 17s:113ms

but then when I look at the end of the screen  in Eclipse it says  "Starting JBoss v4.2 at localhost" then times out and give me this Error

Server JBoss v4.2 at localhost was unable to start within 350 seconds. If the server requires more time, try increasing the timeout in the server editor.
0
abooysen2
Asked:
abooysen2
  • 8
  • 5
  • 3
1 Solution
 
ManishLeadCommented:
In server editor, try to increase time.
0
 
abooysen2Author Commented:
Are you talking about double clikcing the on the server and it opens up the Timeouts Section?
0
 
ManishLeadCommented:
Yes,
Increase time there.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
abooysen2Author Commented:
Will try it

increased
Start (in seconds) - 350
Stop (in seconds) - 350

But it will stop in 350 seconds ? I need to to run until I stop my jboss instance
0
 
abooysen2Author Commented:
it timed out again

Server JBoss v4.2 at localhost was unable to start within 350 seconds. If the server requires more time, try increasing the timeout in the server editor.
0
 
ManishLeadCommented:
change 350 to 1000 or 2000
0
 
a_bCommented:
Can you check what port is jboss in eclipse configured for? And what port id jboss actually working on?

350 seconds is too high. Jboss should easily start within that.
0
 
a_bCommented:
Also, what version of eclipse are you running? You might have to make the change into the plugin rather than the UI
0
 
a_bCommented:
Also, read this thread - http://community.jboss.org/message/301958?tstart=2 since you guys are running the same version of jboss.
0
 
abooysen2Author Commented:
Hi Sage

I am running Eclipse Java EE IDE for Web Developers.Version: Helios Service Release 1
0
 
a_bCommented:
Did increasing the timeout to 2000 help?
0
 
abooysen2Author Commented:
Hi Sage

No it time out again. I looked at http://community.jboss.org/message/301958?tstart=2
 found Window/Preferences/Server
 but not Set "Server Timeout Delay" to "Longer" value in server

the value in kspace/.metadata/.plugins/org.eclipse.core.runtime/.settings\org.eclipse.wst.server.core.prefs is set to 3000
0
 
a_bCommented:
What about the ports as per my comment #34203355?
0
 
abooysen2Author Commented:
Is this what you looking for?
Initializing Coyote HTTP/1.1 on http-0.0.0.0-18080
0
 
abooysen2Author Commented:
I will not worry to much about it because setting it to 2000 it fine and I can do what I need to do
0
 
abooysen2Author Commented:
I will not worry to much about it because setting it to 2000 it fine and I can do what I need to do
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 8
  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now