Solved

How to Setup Linksys AM300 to provide Internet cisco router

Posted on 2010-11-24
13
899 Views
Last Modified: 2012-08-14
Hello All Friend's,
 
We have Cisco 1861 router, but i am unable to browse Internet from Cisco 1861, we have DSL line with Dynamic IP & our ISP is OPTUS  In Melbourne.

We have Physical connection as per below :

Internet provider (OPTUS)<---> Linksys Modem(AM300 & IP :192.168.1.1/24) <---> Cisco 1861 (LAN IP, 192.168.8.1) <---> Workstation (192.168.8.2 to 192.168.8.254),
 
But We can't access Internet from Cisco Device,  we need to configure Linksys Modem in proper mode but I'm not sure about Linksys modem. Can anyone suggest me what configuration need to be done on Linksys for getting Internet from Cisco Device..

interface FastEthernet0/0
 description outside
 no ip address
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1


 
 
Regards

Vikrant
0
Comment
Question by:kavinagpur
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
13 Comments
 
LVL 3

Expert Comment

by:khuphuc
ID: 34205653
you lynksis has a internal ip 192.168.1.1/24,

you have to config something like
interface FastEthernet0/0
 description outside
 ip address 192.168.1.xxx (not 1) 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1

then you have to add a
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
0
 
LVL 3

Expert Comment

by:khuphuc
ID: 34205688
but i thing that the config would be on the cisco router, instead you linksys does the pppoe connection and has the internal ip correctly assigned (192.168.1.1), if you increase the security, change the subnet to 255.255.255.252 or 32, then will be a lan like this

Lan 192.168.1.0
first useful ip: 192.168.1.1
second useful ip: 192.168.1.2
broadcast: 192.168.1.3

that's all
0
 

Author Comment

by:kavinagpur
ID: 34210504
If we will use pppoe on Linksys they why use below under WAN port of 1861,  
pppoe enable group global
 pppoe-client dial-pool-number 1

anyway i tried your suggestion  but still having same issue

0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 
LVL 3

Expert Comment

by:khuphuc
ID: 34211267
ok, i miss understood ,

let's me try to explain what i understand now

you want to connect to internet with a cisco router 1861, but it's router don't have a adsl port then you can connect directly to your isp telephonic port. then you want to use a Linksys AM300 modem,

if the situation it's correct you have to config all in this way.
if i remeber correctly, the linksys has a web config home page, can you upload the screen shot of wan an lan configuration, to suggest the correct parameter, for the pppoe connection?

then once configured the linksys you can config you cisco router no more as a pppoe connecting but a router with a static ip, the pppoe connection it's duty of the linksys

then you obtain this logical config

ISP <--- Linksys (pppoe on the DSL/WAN Port)  & [Static IP (10.10.10.1/255.255.255.252) on the Ethernet0] <--- Cisco Router [Fa0/0 Static IP (10.10.10.2/255.255.255.252) &  (LAN IP, 192.168.8.1/24)]+ ip route 0.0.0.0 0.0.0.0 10.10.10.1 <-- workstation  


is it clear?
0
 

Author Comment

by:kavinagpur
ID: 34216072
Hello khuphuc,

Thanks for your help, I have attached my Present running configuration also Screen Shot of modem,
Can you please look on this, & I request to you please let me know if I'm wrong anywhere ?

Regards
Vikrant
Lan-Port.jpg
ADSL-port.jpg
Static-Route.jpg
6th.txt
0
 
LVL 3

Expert Comment

by:khuphuc
ID: 34216369
HI first of all, if you have single patch trough adsl router(ethernet port) to the ciscor 1861 router (fe0/0), then you have to remove the  

ip route 192.168.8.0 255.255.255.0 FastEthernet0/0
it's make a loop

then you have a trunk to a switch on the fe0/1/8, in this switch are you a your pc?, maybe on the lan 192.168.8.0/24???

i don't understood the reason of the bridging that you try to do. could you please (i'm sorry again for these request) try to design a logical lan, i don't understood the nat trrought a loopback and the fe0/0

and i can't understood the vlan that you want to create.


:)
0
 

Author Comment

by:kavinagpur
ID: 34216572
Thanks for quick reply,

I removed as per your suggestion Please look on my Netowk diagram
As it doesn’t have wifi on 1861, so I bought a aironet wifi thing for it, I have done setup for  Voice & Data,Vlan 1 is for Data & Vlan100 is for voice . I did Setup DHCP LAN-POOL is for All computer, Laptop, Printer &  did setup Pool phone is for Voice Traffic , so Wi fi phone will connect from Airone, also Wifi Lap-top will connect from Aironet, I configured two SSID on Aironet.. ssid Coinop will work for Data (VLAN1) & dot11 ssid Voice-Coinop will work for VOICE (VLAN100)..

That's why i did use as per below
192.168.8.0/24------ for Data LapTop, Printer etc
10.10.10.0/24-------- for Voice traffic means Cisco IP Phone

I hope you understand My scenirio
Topology-Melbourne.jpg
0
 

Author Comment

by:kavinagpur
ID: 34216587
I have attached wifi configuration pls look & let me know if I'm wrong or pls give me a good suggestion what should i do,

 
Test-Aironet.txt
0
 
LVL 3

Accepted Solution

by:
khuphuc earned 500 total points
ID: 34216653
ok,

first flag to win :) we have to obtain a correctly configuration on the 1861, then you have to do this

on the router 1861 that we want to use as a gateway,

interface bvi2
no ip address

interface Vlan1
ip address 192.168.8.1 255.255.255.0
no bridge-group 2
no bridge-group 2 spanning-disabled

let's try to going to internet, mayba a ping to www.google.com from your pc1,2,3,4

what's append?

if i understood nothing working yet?, this it's a setup enviroment, you don't create interruption of some service?, is it true?



0
 

Author Comment

by:kavinagpur
ID: 34216729
Shall we need to enter ip nat inside under valn1 ?
0
 
LVL 3

Expert Comment

by:khuphuc
ID: 34216753
yes you can

interface Vlan1
ip nat inside
0
 
LVL 3

Expert Comment

by:khuphuc
ID: 34216868
someting new?

skype: idem nick
0
 

Author Comment

by:kavinagpur
ID: 34236655
Hello ,

Still Having same issue

Melbourne1861#ping ip 58.108.208.65 source fastEthernet 0/0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to Google.com, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.2
.....
Success rate is 0 percent (0/5)
0

Featured Post

Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question