?
Solved

Out of Office cannot be displayed because server is currently unavailable

Posted on 2010-11-24
19
Medium Priority
?
2,959 Views
Last Modified: 2012-05-10

I've been looking through past Solutions and none seem to have worked for me so far, and they all seem to revert to the same solution.  I am probably doing something incorrectly.

Server 2008 with Exchange 2010
Windows 7 with Office 2010
Go to File, Info, Automatic Replies and after about ten seconds I get the "Your automatic reply settings cannot be displayed because the server is currently unavailable.  Try again later." message which seems so popular.

I have:
Created (A) record:  autodiscover.internal.mydomain.com --> 192.168.1.5 [exchange server]
Created CNAME:  autodiscover.internal.mydomain.com --> exchange.internal.mydomain.com [i know this is redundant; was just trying]
In Management Shell I have:
Set-OutlookProvider –id exch –server: exchange01 [the server name]
Test-OutlookWebServices
 -I received an interesting result:  
 
Id         : 1013
Type       : Error
Message    : When contacting https://mydomain.com/autodiscover/autodiscover.xml received the error The remote name could not be resolved: 'mydomain.com'

Open in new window


From this message it seems that my DNS settings are incorrect, or *something*!  By the way, I *can* ping "autodiscover" or "autodiscover.internal.mydomain.com" from any local client and it returns my Exchange servers' IP address just fine.

Either way it is frustrating and none of our users can set their Automatic Replies through Outlook.  They must use OWA.

Help?
0
Comment
Question by:devoleb
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 7
  • 3
19 Comments
 
LVL 6

Expert Comment

by:fluk3d
ID: 34205363
If you ping autodiscover.domain.com from the machine your having problems with does it resolve to the internal ip of your exchange server?
0
 
LVL 6

Expert Comment

by:fluk3d
ID: 34205372
Sorry disregard just read the last bit..
0
 
LVL 6

Expert Comment

by:fluk3d
ID: 34205379
How many NIC's does your exchange server have?
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 

Author Comment

by:devoleb
ID: 34205445

One NIC card; static IP.

Sending/Receiving email has no known issues.  This is a production server.
0
 
LVL 14

Expert Comment

by:Schnell Solutions
ID: 34205460

Hello,

In case that you use a proxy server with your clients. You need to excluede the domain name or server name used for autodiscover. If not the autodiscover connection will try to route throw the Internet and Outlook won't accept it.
0
 

Author Comment

by:devoleb
ID: 34205500
Hi,

No, we do not use any type of proxy.  The clients are all on the LAN (192.168.1.x) and the server is also.

0
 

Author Comment

by:devoleb
ID: 34205534
On the 3rd line of the code section, where it reads:
"https://mydomain.com/autodiscover/autodiscover.xml"

Shouldn't that be https://EXCHANGE.INTERNAL.mydomain.com/autodiscover/autodiscover.xml ?

Could this be the source of the problem?  Or is this a normal output?
0
 
LVL 14

Expert Comment

by:Schnell Solutions
ID: 34206070

The name used there came from the name configured in the CAS parameters, in some way it can be configured with any name

Please, send us the information returned from an Outlook Connection Test, make it like this:

Right click the Outlook client with the CTRL key pressed and select "Test eMail Auto Configuration". In the "Test eMail Auto Configuration" window write a user email address, password and clear the check boxes: Use Guessmart and Secure Guessmart Authentication. Make a click on Test and check all the names used and the answers returned

0
 

Author Comment

by:devoleb
ID: 34206167
Before when I tried this, it returned something like "Could not locate autodiscover..."
But ever since I've been messing with the above-mentioned troubleshooting steps, I now get:

 test connection
0
 
LVL 14

Expert Comment

by:Schnell Solutions
ID: 34206300

Ok, let's validate the web address and the certificate name/validation

Try with the web browser from a failed computer and access this website

https://XXXXXX.com/ews/exchange.asmx

Introduce your credentials and validate that the XML information is accesible. Once been loaded the website, view the certificate properties of the website (Click the certificate icon in the browser, usually a locker symbol). Check if there is not any kind of error with the Certificate, that the name is included in the certificate, that it is not expired and that the certification path is with "Ok" status

0
 

Author Comment

by:devoleb
ID: 34206350
Hmmm..

https://mydomain.com/ews/exchange.asmx  returns a "Page cannot be found" error.

But if I do:  https://exchange01/ews/exchange.asmx   I have to hit "Continue" for the cert, but then I get thrown at https://advorlexch01/ews/Services.wsdl and see a page full of XML.


PS.  i forgot to mention earlier, I found another post on these forums that mentioned to make sure that "Ignore client cert" was checked under the Autodiscover directory of the Default Website (IIS).  Mine is checked (ignore).
0
 
LVL 14

Expert Comment

by:Schnell Solutions
ID: 34206542

It looks that we will need to change the OOF URL address of your Exchange configuration

Just confirming...

In the image that you sent. The part where is the blue line. The marked part in OOF. Does it point to https://domainname... or https://exchangeservername...

0
 

Author Comment

by:devoleb
ID: 34206615
In the Test Connection results,

OOF URL:  https://domainname.com/ews/exchange.asmx

*not* https://servername.com/ews/exchange.asmx *not*
0
 
LVL 14

Accepted Solution

by:
Schnell Solutions earned 2000 total points
ID: 34206897


There are many things that we can do, but in order to avoid using names not included in your digital certificate and been able to continue your DNS resolution, it will be better to configure the OOF with the name https://webmail.YOURDOMAIN.com/ews/exchange.asmx

You can accomplish this with the CMDLet:

Get-WebServiceVirtualDirectory -server YOUREXCHCASSERVER | Set-WebServiceVirtualDirectory -InternalURL "https://webmail.YOURDOMAIN.com/ews/exchange.asmx" -InternalNLBBypassUrl "https://webmail.YOURDOMAIN.com/ews/exchange.asmx"


Them, force an AD repplication (in case that you have more than one DC). After replication is complete, restart outlook from a failed computer and make the test again to check if it is using the new configured OOF

0
 

Author Comment

by:devoleb
ID: 34207139
Thanks, I will try this in a bit and reply back.

But before I do, is there a way to backup the current config just in case this somehow backfires on me?

Backup-WebServiceVirtualDirectory, perhaps?  :-)
0
 
LVL 14

Expert Comment

by:Schnell Solutions
ID: 34207626

This is AD data, so... in order to back it up we shall make an AD backup. System State of a DC. But it is easier just have a reference of the previous configuration

We are just going to change two entry names, you can safe the information inside the configuration for reference

Get-WebServiceVirtualDirectory | Format-List > CASFileConf.txt



0
 

Author Comment

by:devoleb
ID: 34207826
Alright...
This is what I've done so far:

Get-WebServicesVirtualDirectory | Format-List > CASFileConf.txt

Get-WebServicesVirtualDirectory -server exchange | Set-WebServicesVirtualDirectory -InternalURL "https://webmail.MYDOMAIN.com/ews/exchange.asmx" -InternalNLBBypassUrl "https://webmail.MYDOMAIN.com/ews/exchange.asmx"

Before I entered the second command, the CAS txt file *did* say that the OOF Internal was the "https://MYDOMAIN.com/......." URL.  *After* the second command, it now says the correct "https://webmail.MYDOMAIN.com/....." --- so I think that is good.

I tried flushing DNS on a client computer and restarted Outlook, then test, still no luck.  I think this may be due to the replication issue.  I'm sorry but I'm not really a Systems guy --- how do you force a replication?  We have a couple DC's...

Thanks for your help so far!
0
 

Author Closing Comment

by:devoleb
ID: 34208092
This did it!

I didn't know how to force replication, so waiting it out was the key.

After about 20 minutes I did another connection test and everything appeared.  I then opened OOF and everything appears to be working!

Thanks again!

Read commends for exact command I used.
0
 
LVL 14

Expert Comment

by:Schnell Solutions
ID: 34208349

One way to do it is going to the "Active Directory Sites and Services" console in administrative tools, expand the AD site, expand your DC server and inside the NTFS component there are the repplication objects in the right side, you can right click them and select Synchronize, you can make it like this in each one of your DCs inside the same console

There is another way to make it with the "repadmin" command, but it is ok if you make it by the GUI

0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In-place Upgrading Dirsync to Azure AD Connect
There are times when we need to generate a report on the inbox rules, where users have set up forwarding externally in their mailbox. In this article, I will be sharing a script I wrote to generate the report in CSV format.
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
Suggested Courses
Course of the Month11 days, 3 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question