SonicWall Configuration for VPN Access

We are attempting to force traffic over a (second) VPN from an outside agency. We re running a SonicWall NSA 240 and the agency is running a Cisco device.  The connection between us has been successfully established but, for example, FTP traffic never reaches the intended server. Here are the particulars:

a.      the VPN is established.
b.      The agency NATs all of their outbound traffic over a single IP
c.      The FTP server works over our own VPN or, if I turn it on, over the WAN interface. Accordingly, it also works for the agency (no surprise there) if that access rule is activated.
d.      An access rule (network) has been created to support the NAT-ed address over the VPN
e.      A firewall access rule has been created for:  VPN > LAN and VPN > WAN to the host for the agency network as well as VPN <-> WAN (X1 Subnet, both ways) to support the agency VPN connection.
f.      The appropriate protocols have been activated on the host and have been tested.

The agency performed a TRACERT and it would seem that they can get to our system, but I’m not seeing it on the firewall logs. They are reporting “connection refused”.

It would seem that we’re missing something simple.  I compared the settings with our existing VPN, and all is accounted for.  The biggest difference is that they are NAT-ing to a single address. Further, I’m not sure that will work when we bring on clients to access our applications.

Thanking you in advance for your insight.  Greatly appreciated.

Happy Thanksgiving!
MSConsultingAsked:
Who is Participating?
 
digitapConnect With a Mentor Commented:
ok...getting a clearer picture.  NAT'ing as in WAN > LAN has nothing to do with VPN > LAN.  they SHOULD be using the private IP address of the server as it is on your LAN and NOT the public IP address.  doing so will not send the traffic over the VPN.

the address object representing the Destination Network should be the single IP address that they are NAT'ing their LAN to.
0
 
digitapCommented:
hello - NAT'ing to a single IP should be fine.  i have several clients doing this over a VPN.  are you running any security services on the VPN zone?  IPS can block FTP traffic if configured to do so.
0
 
MSConsultingAuthor Commented:
Thanks for the quick response. No, I'm not running any security on the firewall/VPN zone(s).  Perhaps you could outline the steps necessary to set up the NSA so that I can support access to my servers over the VPN. Like I said, I set it up for our private network and it works fine.  It's a spoke-hub configuration, where the applications servers are at the hub and we're just adding another "spoke".

Cheers,
Marc
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
digitapCommented:
OK...read through your particulars.  when setting up a VPN, you typically don't have to configure any firewall access rules.  default allows all of the hosts specified in the address object (group) of the VPN SA and any services.  i've gone back and tweaked the access rules to lock down services, but i don't do this often.

i need some clarification on the NAT part.  are they NAT'ing such that their network (Destination Networks) appears as a single IP address or your network (Local Networks) appears as a single IP address?

Are you performing any NAT work on your sonicwall?
0
 
MSConsultingAuthor Commented:
Thanks again. I would have thought as much about VPNs (re: firewall access rules).  I will relook to see if I've compromised anyting in my setup.

They are NAT'ing so that their network looks like a single IP.  
Yes, we are performing some NAT'ing on our network. Specifically, the target server is NAT'ed to translate the public address to the private one. It might be helpful to know that they are using the server's public address when trying to engage its services.

Cheers,
M.
0
 
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.