Solved

Cisco policy Map Qos

Posted on 2010-11-24
10
1,002 Views
Last Modified: 2012-05-10
I am having some issues with a VOIP telephony systems, calls being dropped etc.  I have a few sites connected via vpn and via fiber.  i was thinking maybe if i put qos on the router to prioritize traffic for voice it might help.  below is what i came up with...does this look like it will work?  going to be on 2821 and 871 ciscos

Thanks

class-map match-any VoIP
 match  dscp ef
 match  precedence 5
 match ip rtp 5004 5004
 match ip rtp 2427 2427
 match ip rtp 5440 5446
!
!
policy-map VOICE
 class VoIP
  set dscp cs5
 class class-default
  fair-queue
!
0
Comment
Question by:jasonmichel
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
10 Comments
 
LVL 1

Author Comment

by:jasonmichel
ID: 34208643
anyone?
0
 
LVL 28

Expert Comment

by:bgoering
ID: 34213001
Take a look at this previous EE thread for an example: http://www.experts-exchange.com/Hardware/Networking_Hardware/Routers/Q_22681478.html
0
 
LVL 1

Author Comment

by:jasonmichel
ID: 34213418
yeah i looked at that, but my VOIP is shoretel not Cisco, thats why i just wanted confirmation that what i had would work, thanks for the response!!
0
Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

 
LVL 28

Expert Comment

by:bgoering
ID: 34213477
Sorry - my experience doesn't extend to shoretel - good luck
0
 
LVL 4

Accepted Solution

by:
askincakir earned 250 total points
ID: 34221529
hi,
well this may be work, but depends on your voip phones status. You are matching some criteris which are coming from your ip phones and if they are not the same then your policy may not match packets. I suggest you to use ACL to match trafic from your ip phones. then set priority to them. Another case is that you need to apply this priority to interface in inbound direction.
example:
ACL
R1(config)#access-list 1 permit 192.168.0.0 0.0.0.255
R1(config)#access-list 1 deny any
---
class-map match-all IPPhones
 match access-group 1
!
!
policy-map Voice
 class IPPhones
  set dscp af43
 class class-default
!

----
interface Ethernet1/0
 service-policy input Voice

#########
this config is when your packets are coming to your router. if you want to give dedicated bandwith to your voice then your need to do class based config which you will apply to outgoing interface.

hope this will help you.





0
 
LVL 17

Expert Comment

by:pergr
ID: 34221779
None of the above will work.

As the previous poster saud, if you do have a separate IP subnet for the IP phones then it is useful for your Marking, and you could do something like this:


access-list 1 permit 192.168.0.0 0.0.0.255
!
class-map match-all IPPhones
 match access-group 1
!
!
policy-map Voice
 class IPPhones
  priority percent 25
 class class-default
!
interface Ethernet1/0
 service-policy output Voice

Note, the main changes are to use 'priority' in the policy-map, and to use the service policy as 'output' - assuming the interface is towards your WAN.

However, your probably do not have a full 10Mbps 'Ethernet' interface towards your WAN. If that interface is a Serial interface, then there is no problem. However, if it is an Ethernet interface that does not offer the line rate in the WAN, then you will also need some nested 'policy-map' that does 'shaping' down to your WAN speed.
0
 
LVL 1

Author Comment

by:jasonmichel
ID: 34222476
i do not have a separate subnet..they are all on the same subnet, we are only talking about 50 devices total. and yes i confirmed with vendor on the port numbers needed, thats why i used those specific ports.  It's a shoretel VOIP
0
 
LVL 17

Assisted Solution

by:pergr
pergr earned 250 total points
ID: 34223146
Yes, it is fine to use your own 'class-map' instead of the one I suggested.

Once you get the voip packets into the class, the important thing is the 'priority'.

I also found the attached file, which gives more extensive background information.


Your main issue will be the traffic on the VPN links, and if that traffic shares Internet ports with other (browsing) traffic. Your ISP will not have any QOS configured, and will mix your VPN traffic with browsing traffic without any priority - unless you can get them to implement something.
best-practices-wan.pdf
0

Featured Post

Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
For many of us, the  holiday season kindles the natural urge to give back to our friends, family members and communities. While it's easy for friends to notice the impact of such deeds, understanding the contributions of businesses and enterprises i…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question