Solved

Unable to connect remotely to my mysql server on a linux system

Posted on 2010-11-24
5
493 Views
Last Modified: 2012-05-10
From my linux system, it shows mysql is up and running from the output of the following command:

[root@localhost ~]# netstat -npl | grep tcp
tcp        0      0 0.0.0.0:3306                0.0.0.0:*                   LISTEN      31579/mysqld        
tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      3294/portmap        
tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN      2884/cupsd          
tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN      3534/sendmail: acce
tcp        0      0 0.0.0.0:953                 0.0.0.0:*                   LISTEN      3315/rpc.statd      
tcp        0      0 :::80                       :::*                        LISTEN      3580/httpd          
tcp        0      0 :::22                       :::*                        LISTEN      3513/sshd          
tcp        0      0 :::443                      :::*                        LISTEN      3580/httpd          
[root@localhost ~]#


I can't seem to connect to  it remotely from a window system using MySQL Workbench application. What else can I try to do to get a connection?
0
Comment
Question by:areyouready344
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 4

Expert Comment

by:max-hb
ID: 34207452
Make sure your MySQl server is listening for incoming connections:

Follow instructions at http://www.cyberciti.biz/tips/how-do-i-enable-remote-access-to-mysql-database-server.html especially step 3!
0
 

Author Comment

by:areyouready344
ID: 34209779
Thanks max-hb, how can i get the mysqld process to listen on the ip address of 192.168.1.137

cp        0      0 0.0.0.0:3306                0.0.0.0:*                   LISTEN      31579/mysqld  


0
 
LVL 15

Expert Comment

by:DonConsolio
ID: 34209861
Your mysqld is already listening on ALL interfaces (0.0.0.0), but on the quite unusual port 31579

to get a listening server for  192.168.1.137 on dthe default port of 3306 use:

[mysqld]
...
port            = 3306
bind-address    = 192.168.1.137
...

and restart your mysql server. You may also want to verify you have no firewall active.
0
 

Accepted Solution

by:
areyouready344 earned 0 total points
ID: 34210086
Working, thanks to this document located at:

http://benrobb.com/2007/01/15/howto-remote-root-access-to-mysql/
0
 

Author Closing Comment

by:areyouready344
ID: 34424475
worked great
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Popularity Can Be Measured Sometimes we deal with questions of popularity, and we need a way to collect opinions from our clients.  This article shows a simple teaching example of how we might elect a favorite color by letting our clients vote for …
In this blog post, we’ll look at how ClickHouse performs in a general analytical workload using the star schema benchmark test.
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question