Solved

Sound over RDP

Posted on 2010-11-24
5
804 Views
Last Modified: 2012-05-10
Hello,

We have a completely virtual environment setup...Windows Server 2008 SBS R2 (virtual) and 10 Windows 7 Pro 64bit (virtual).
The users connect to their virtual workstations using the remote workplace web page.
The problem we are facing is that when connecting from some computers or laptops to the remote desktops, the sound comes through, but from others Windows says that "no audio device is installed".
I have tried copying the sound driver files to the virtual computer thinking that windows looks for those files to make the audio go accross, but no luck.
The laptop that always works is a lenovo Y410 running Windows 7 Ultimate 64bit.
I have also went to the TS Service Manager and unchecked the audio mapping under RDP-TCP.

Any suggestions or comments are welcome.

Thank you.
0
Comment
Question by:alchetec
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 7

Expert Comment

by:YarnoSG
ID: 34207807
The "secret sauce" is in how the remote instance is invoked - for example, if you were using the RDP client built into Windows, you control whether or not you get sound as a launch condition of the RDP session.  Check your "remote workplace" web page and make sure the options are set consistently.

You can test this theory by attempting to connect using remote desktop and clicking to the options and then going to the "local resources" tab.  The Remote Audio settings are controlled there.  If you want to codify that, you can put the settings into an RDP file that is then invoked with MTSC.exe.
0
 
LVL 1

Author Comment

by:alchetec
ID: 34207902
Even when I try connecting directly through RDP without using the remote workplace, I get the same result "no audio device installed".
If I connect directly through RDP, skipping the Remote Workplace, even from the Lenovo Y410 I get the same result as above, although the Y410 works if I go through Remote Workplace.
0
 
LVL 7

Expert Comment

by:bradgcoza
ID: 34609159
Ensure you log off the previous session so when you login it wont keep the previous sessions settings.

connect to your server by running the below command ensuring that the sound on your machine is enabled.

mstsc -v:servrename
0
 
LVL 1

Accepted Solution

by:
alchetec earned 0 total points
ID: 34614497
The problem has been solved. In Windows server 2008 SBS edition, the remote workplace web page has an aspx file that defines all the remote settings. This file tsweb.aspx has the settings for the audio and by default it is set to not do remote audio. After changing the setting to remote audio, everything started to work.

Thank you for your assistance.
0
 
LVL 1

Author Closing Comment

by:alchetec
ID: 34869405
I found the file where the rdp settings are kept when using remote work place in sbs
0

Featured Post

Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are many software programs on offer that will claim to magically speed up your computer. The best advice I can give you is to avoid them like the plague, because they will often cause far more problems than they solve. Try some of these "do it…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question