Solved

Ubuntu 10.04 TLS wireless issues

Posted on 2010-11-24
5
744 Views
Last Modified: 2013-11-15

Hardware: Dell D830 Latitude

I am a Linux newbie. I installed Ubuntu 10.04 using wubi installer in my Windows 7 laptop.

When I installled and ran it for the first time it asked me for the wep key I provided it , connected and was able to browsed Internet just fine. I installed Chromum browser. I shut it down and today I cannot access wireless and the "Enable wireless" option is greyed out.

On the Windows 7 install the wireless is just fine

Any ideas how to solve it?
0
Comment
Question by:JohnRamz
  • 3
5 Comments
 
LVL 18

Expert Comment

by:TobiasHolm
ID: 34210822
Try:

$ sudo ifconfig wlan0 up
0
 
LVL 18

Accepted Solution

by:
TobiasHolm earned 500 total points
ID: 34210831
Also try this:

"1. I switched wireless OFF with the hardware wireless switch and restarted the box.
2. After logging in (and checking that "enable wireless" check box was grayed out - this time for a good reason) I changed the hardware switch to the ON state and now the "enable wireless" check box was not grayed out and switched ON; everything was working again."
0
 
LVL 18

Expert Comment

by:TobiasHolm
ID: 34210836
0
 
LVL 35

Expert Comment

by:torimar
ID: 34210901
Run the following command in the terminal:

sudo rfkill list

Open in new window


Do you get any "Hard blocked: yes" or "Soft blocked: yes" entries?
Then this may indeed be a case where Ubuntu does not correctly interpret the WLAN killswitches, so play around with the keyboard 'Fn + Enable/Disable Wlan' key, and check the laptop manual for a hardware switch that you may click. (It does not matter that WLAN works under Windows; Windows uses specific drivers as supplied by hardware manufacturers, Linux has to learn to support all hardware features by itself, so an occasional 'misunderstanding' of a brand specific button can occur.)

You may also want to try:

sudo rfkill unblock all

Open in new window


Yet another method that is reported to have worked for some Dell laptops is this command:

sudo rmmod -f dell-laptop

Open in new window

0
 

Author Closing Comment

by:JohnRamz
ID: 34217681
Thanka Tobias. Turning the switch off and rebooting did the trick.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Creating a Samba server for a small office. Ubuntu Linux and Samba can breathe new life into a retired PC and save an office money on new hardware/software. Our example server will have two hard disks, one exclusively for storing shared data. …
The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
This Micro Tutorial will give you a basic overview how to record your screen with Microsoft Expression Encoder. This program is still free and open for the public to download. This will be demonstrated using Microsoft Expression Encoder 4.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now