Solved

Microsoft VPN will not connect through ASA 5505

Posted on 2010-11-24
4
666 Views
Last Modified: 2012-05-10
I implemented an ASA that is not allowing Microsoft VPN clients to connect outside of the network. The Cisco VPN connections work fine, but for some reason the L2TP traffic utilized by MVPN is not passing. Any help is greatly appreciated.

:
ASA Version 8.2(1)
!
hostname asa5505
domain-name bdk.local
enable password FHh7Yl18tRxWouNz encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.10.10.254 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 10.10.10.254
 domain-name bdk.local
access-list BDK_Hurlock_splitTunnelAcl standard permit 10.10.10.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 10.10.10.0 255.255.255.0 10.
10.20.0 255.255.255.0
access-list outside_access_in extended permit tcp any any eq pptp
access-list outside_access_in extended permit tcp any any eq 1701
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool AnyConnect_Pool 10.10.20.100-10.10.20.130 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 65.210.50.177 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
aaa authentication http console LOCAL
aaa authentication telnet console LOCAL
http server enable 8080
http 10.10.10.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
http redirect outside 80
http redirect inside 80
snmp-server location none
snmp-server contact none
snmp-server community *****
snmp-server enable traps snmp authentication linkup linkdown coldstart
snmp-server enable traps syslog
snmp-server enable traps ipsec start stop
snmp-server enable traps entity config-change fru-insert fru-remove
snmp-server enable traps remote-access session-threshold-exceeded
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128
-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256
-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ca certificate map DefaultCertificateMap 10
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 10
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 10
console timeout 0
dhcpd dns 8.8.8.8
dhcpd domain bdkasa.local
dhcpd auto_config outside
!
dhcpd address 10.10.10.100-10.10.10.130 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 averag
e-rate 200
ntp server 207.46.197.32 source outside prefer
webvpn
 enable outside
 svc image disk0:/anyconnect-win-2.3.0254-k9.pkg 1 regex "Windows NT"
 svc enable
 tunnel-group-list enable
 certificate-group-map DefaultCertificateMap 10 DefaultWEBVPNGroup
group-policy DfltGrpPolicy attributes
 webvpn
  url-list value EasyVPN
group-policy EasyVPN internal
group-policy EasyVPN attributes
 vpn-tunnel-protocol webvpn
 webvpn
  url-list value EasyVPN
group-policy BDK_Hurlock internal
group-policy BDK_Hurlock attributes
group-policy BDK_Hurlock internal
group-policy BDK_Hurlock attributes
 dns-server value 10.10.10.254 8.8.8.8
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value BDK_Hurlock_splitTunnelAcl
group-policy AnyConnect internal
group-policy AnyConnect attributes
 vpn-tunnel-protocol svc
username bruce password v8VyfSJT.x/9XrpU encrypted privilege 15
username edwina password O09CoHTJAWVTqPkb encrypted
username john password q1MS15zXwwHbA5g4 encrypted
username bdkguest password /bjcu6tfz9oB57fS encrypted
username ernie password cRO3fpVj9RKv2YDY encrypted
username jason password rGNiBeFeApTlgkP0 encrypted privilege 15
tunnel-group DefaultRAGroup webvpn-attributes
 group-alias EasyVPN enable
 group-url https://10.10.10.254/EasyVPN enable
tunnel-group EasyVPN type remote-access
tunnel-group EasyVPN general-attributes
 default-group-policy EasyVPN
tunnel-group EasyVPN webvpn-attributes
 group-url https://xxx.xxx.xxx.xxx/EasyVPN enable
tunnel-group AnyConnect type remote-access
tunnel-group AnyConnect general-attributes
 address-pool AnyConnect_Pool
 default-group-policy AnyConnect
tunnel-group AnyConnect webvpn-attributes
 group-alias anyconnect enable
 group-url https://xxx.xxx.xxx.xxx/anyconnect enable
tunnel-group BDK_Hurlock type remote-access
tunnel-group BDK_Hurlock general-attributes
 address-pool AnyConnect_Pool
 default-group-policy BDK_Hurlock
tunnel-group BDK_Hurlock ipsec-attributes
 pre-shared-key *
 isakmp ikev1-user-authentication none
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:f5d3d0ff5f47
0
Comment
Question by:nwhitaker2
  • 2
4 Comments
 
LVL 27

Accepted Solution

by:
davorin earned 125 total points
Comment Utility
0
 
LVL 33

Expert Comment

by:MikeKane
Comment Utility
Do you mean Clients on the outside trying to connect to you?   Or do you mean your employees on the inside trying to connect outbound to other endpoints?
0
 
LVL 1

Assisted Solution

by:nwhitaker2
nwhitaker2 earned 0 total points
Comment Utility
MikeKane.....the clients internal to the LAN are trying to reach remote networks using MVPN. I was able to resolve the problem by adding a statement to the policy map to inspect pptp. Thank you everyone for your help and have a great Thanksgiving!
0
 
LVL 1

Author Closing Comment

by:nwhitaker2
Comment Utility
The issue was resolved after implementing a policy map inspection for pptp.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Have you experienced traffic destined through a Cisco ASA firewall disappears and you do not know if the traffic stops in the firewall or somewhere else? The solution is the capture feature. This feature was released in 6.2(1) and works in all firew…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now