Solved

Unable to access Apache Tomcat Port 8080 on Red Hat 5.4 server from Windows system on network

Posted on 2010-11-24
11
1,361 Views
Last Modified: 2012-08-13
We have recently deployed a Red Hat 5.4 server on our network and have deployed Apache Tomcat to serve VXML and JSP pages.

The issue is that we are unable to access port 8080 on the Red Hat Server to access any of the pages.  We are able to pull up that Administrative page if on the local machine, but from the remote machine we get a 404 error and are unable to display the page.

We have disabled the firewall on the Red Hat machine to rule it out.  Also, there are no firewalls betweent the two systems on the network.

Here is some information that I pulled from the Red Hat system related to port 8080.  Any assistance would be greatly appreciated.

 Port-8080-Info.txt
0
Comment
Question by:davidpaez
  • 5
  • 3
  • 2
  • +1
11 Comments
 
LVL 16

Expert Comment

by:Blaz
Comment Utility
What is your apache configuration?
0
 

Author Comment

by:davidpaez
Comment Utility
Hi Blaz,

I have attached the httpd.conf file.  I believe that this is what you are asking for.  Please let me know if there is any additional information that I should provide.

Just open it with WordPad or some other text editor to preserve formatting for viewing.

Thanks!
 httpd.conf.txt
0
 
LVL 16

Expert Comment

by:Blaz
Comment Utility
Actually you should also include the virtual hosts configuration. This configuration file does not tell anything about server on 8080 port.
0
 

Author Comment

by:davidpaez
Comment Utility
Thanks Blaz.  Are you saying that I possibly need to add a Virtual Host to this configuration file?  I believe that there is a section for Virtual Hosts in httpd.conf.  Currently, there are no entries in this section.

Or is there another file that I should be looking for?
0
 
LVL 15

Expert Comment

by:samri
Comment Utility
are you able to access the page is connected locallly on the machine running apache.

you could start a web browser (on the Redhat box), and try to browse to http://127.0.0.1:8080/ and validate if this possible.  Or you could do a "telnet localhost 8080" from a command shell.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:davidpaez
Comment Utility
Hi Samri,

I can access it locally if I use http://localhost:8080.

However, I get a blank page if I use 127.0.0.1:8080 or the IP address of the machine (locally).

If I do a "telnet localhost 8080" it reads that I am connected.
0
 
LVL 16

Expert Comment

by:Blaz
Comment Utility
There should be a separate virtualhosts file - you certainly have virtualhosts configured but the httpd.conf does not contain any information about them.
0
 
LVL 7

Accepted Solution

by:
stephenhoekstra earned 125 total points
Comment Utility
Tomcat isn't bound to an IPv4 address.

You should be seeing either 0.0.0.0:8080 (bound to all IPv4 addresses) or one of your network IP addresses when doing a netstat, unless this is intended.
0
 

Author Comment

by:davidpaez
Comment Utility
Hi Blaz

Unfortunately, being a Red Hat neophyte, I do not know what the separate file would be.  I did do a search for virtualhosts but nothing was returned.

Perhaps I should start by trying to configure a virtual host in the httpd.conf file?

Thanks again for you help.
0
 

Author Comment

by:davidpaez
Comment Utility
Hi Stephen,

I am not sure what I need to do to bind Tomcat to an IPv4 address.  I have tried editing the server.xml file to explicitly associate port 8080 with the IP of the machine.  Although after making the edit and restarting Tomcat, a netstat -na tcp shows the updated ip address associated with 8080, it does not seem to resolve the issue.

Thanks!
0
 
LVL 7

Expert Comment

by:stephenhoekstra
Comment Utility

Just to make sure, please repaste the 'netstat -anp' output :)

Machine should be accessible from remote locations now when browsing to port 8080.  Let's get that working first, and then we'll move onto configuring apache to redirect or proxy the requests to Tomcat.

Thanks,
Stephen
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Most of the developers using Tomcat find it easy to configure the datasource in Server.xml and use the JNDI name in the code to get the connection.  So the default connection pool using DBCP (or any other framework) is made available and the life go…
Upgrading Tomcat – There are a couple of methods to upgrade Tomcat is to use The Apache Installer is to download and unzip and run the services.bat remove|install Tomcat6 Because of the App that we are working with, we can only use Tomcat 6.…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now