[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2483
  • Last Modified:

Installing Exchange 2003 in 2008 R2 Domain /forestprep compatibility issues

G'day,

We have setup a new Windows 2008 R2 Domain with Windows 2008 R2 Domain Controllers. However I am trying to install Exchange 2003 in this domain. I realise that I must install Exchange 2003 on Server 2003, that is fine.

However, when I attempt to run the Exchange 2003 Setup\I386\Setup.exe /forestprep and /domainprep on the Windows 2008 R2 AD server, it does work.

I receive the Program Compatibility Assistant error "This program is blocked due to compatibility issues". There is no way to ignore this error and Continue. The only options are Cancel or Check for sulutions online.

How can I prepare my 2008 R2 domain for Exchange 2003? Do I need to disable the Compatibility Assistant? If so, how? Do I even need to prepare the Domain?

Thanks for your help!
0
WTAus
Asked:
WTAus
  • 7
  • 4
  • 3
  • +1
1 Solution
 
Psy053Commented:
Are you using Exchange 2003 SP2 Media?
0
 
Psy053Commented:
Also, have you tried disabling the Program Compatability Assistant?

From what I have read, you will need to use Group Policy to do so.
0
 
KevinTHayashiCommented:
I believe that you can disable  Program Compatability Assistant through Group Policy.  you may need to do this through the Default Domain Controller policy as it will override the local policy:

Computer Configuration > Policies > Administrative Templates > Windows Components > Application Compatibility.  Set the "Turn Off Program Compatibility Assistant" to "Enabled".
0
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

 
WTAusAuthor Commented:
Well, I am using Exchange 2003 media, with a separate install to update to 2003 SP2. But I dont think that is the problem, since even the SP2 update gets blocked before it runs.

I've tried to disable the Program Compatability Assistant by doing the following:
On the DC, run Administrative Tools > Group Policy Management
2) Expanded Domain Controllers > right-click Default Domain Controller Policy > Edit
3) Set Computer Configuration > Policies > Administrative Templates > Windows Components > Application Compatibility > set Turn off Program Compatibility Assistant to ENABLED

But this doesnt seem to have any effect... the Program Compatibility Assistant still keeps coming up. I even tried it for Default Domain Policy, with the same results...

Is there a way to verify if the server is actually picking up the Group Policy? Or is there another way to disable it?

Thanks
0
 
KevinTHayashiCommented:
You can run gpupdate from the command line to refresh the policy.  Is the server that you are trying to run this on actually under the Domain Controllers container within AD?  Just want to make sure its not a member server.
0
 
WTAusAuthor Commented:
Tried refreshing, still blocks it. And yep, the computer is definately under the Domain Controllers group. It is the only server running at the moment...

Interestingly, the error in the Event Properties is: "The application (Microsoft Exchange Server, from vendor Microsoft) was hard-blocked and raised the following: Microsoft Exchange Server has a known compatibility issue with this version of Windows.

Could it be because we are using 32-bit media on the x64 Windows 2008? Microsoft doesnt seem to offer any help at all...
0
 
KevinTHayashiCommented:
You should be able to run the 32bit executable on the 64bit OS.. just couldnt do it the other way around.

Run "gpresult /H Desktop/GPResult.html" from the command prompt.  This should generate a report that shows you all of the Group Policy settings applied after s GPUPDATE.
0
 
WTAusAuthor Commented:
OK, I did that, and it is definately applying correctly. Also check the reg key HKLM\SOFTWARE\Policies\Microsoft\Windows\AppCompat!DisablePCA has value 1
Also ran rsop.msc and it shows the policy as applying... yet the program is still blocked by PCA!
What on earth could be going on?
0
 
WTAusAuthor Commented:
OK........... I found somewhere that said if you rename the .exe it will work... and it did... <sigh>
0
 
KevinTHayashiCommented:
Lol. Ok. Good luck!
0
 
rjwesleyCommented:
Are you attempting to install Exchange 2003 on your 2008 server Domain Controller? This of course is not recommended by Microsoft.

Best to install exchange on a member server.

"Exchange 2003 on Windows Server 2003 x64 editions is not supported." from link --> http://msexchangeteam.com/archive/2005/07/11/407529.aspx - I presume the same goes for 2008 server 64-bit

best options are to downgrade to server 2008 32-bit (R2 only available in 64-bit) or upgrade to exchange 2010 installed on a true 64-bit system and OS...the latter probably being the better option

Rob
0
 
Psy053Commented:
The OP has specified that Exchange will be installed on a 2K3 Server, and not on his 2008 R2 DC's
0
 
WTAusAuthor Commented:
We finally fixed the issue by increasing the uploadReadAheadSize to 200MB... it is surprising that this was causing the problem... still, it fixed it! Too bad no one on the entire Experts Exchange knew that... would have saved us many weeks of searching...
0
 
WTAusAuthor Commented:
Oops, previous post was for the wrong Question... The exchange problem was solved simply by the fact that you cannot, and in fact dont even need to, "prepare" a 2008 domain for a 2003 Exchange server... you simply install Exchange 2003 on a Windows 2003 Server computer and it will work fine, even in a 2008 Domain.
0
 
WTAusAuthor Commented:
Figured it out myself
0

Featured Post

Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

  • 7
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now