Solved

Router to support Mutiple VLAN; Bandwidth shape and DHCP server

Posted on 2010-11-24
28
963 Views
Last Modified: 2012-05-10
What I would like to do is setup and configure a device that has a DHCP server with the ability to setup multiple VLAN ‘s that can use a DHCP server to hand out dynamic  IP’s.

I work for a hotel and we have a system that manages our meeting room internet and it works great, what I’m looking for is a device that I can use to up sale our services by selling  bandwidth to clients if they wanted a T1 or multiple T1’s  for  their  event by using VLAN ‘s and also to be able to bandwidth shape that VLAN. (This system will be seperate form our meeting room internet system)
0
Comment
Question by:MeMike
  • 15
  • 12
28 Comments
 
LVL 2

Expert Comment

by:frederi
ID: 34232243
On any DHCP server, you can setup different DHCP scopes, who will attributes different IPs, based on the VLAN from which the requests originates.
The DHCP server will identify the IP subnet/VLAN where the client did its broadcasted request and it will give it an IP on that same subnet, if it has a matching scope.
I hope this is clear enough.
0
 

Author Comment

by:MeMike
ID: 34236563
So a DHCP server can handle this and it can manage multiple VLANS? If so what about the bandwidth shaping can it be a applied to different VLAN's
0
 
LVL 1

Expert Comment

by:amyassein
ID: 34236643
MeMike,

You stated the word "Router"  in your post title .... What is the brand and the model of this router? ... Well, if you have a router, you can configure the DHCP server service in the IOS (If Cisco) ... Also, i want to ask, are the VLANS existing in Layer 2 or Layer 3 switch(es)? ...

Appreciate if you can provide more details about your current network layout.

Regards,
A.Y.
0
 

Author Comment

by:MeMike
ID: 34236696
I have a high end Cisco Router 6506E that we no longer use (it is only 2 ½ years old) and the new Internet pipe will be 200MB ( yes that is equal to 5 DS3). With a pipe this big my thought was to sell a T1 or multiple T1's to client or meetings and using this Cisco router I would like to create say 5 or 10 Vlans each with its own bandwidth size and each VLAN would get IP’s from a DHCP server. How would I handle the limit or shape the bandwidth for each VLAN.

0
 
LVL 1

Expert Comment

by:amyassein
ID: 34236754
First of all, the router by itself is a layer 3 device which doesn't support the creation of VLANs inside it. Instead, switch is used (L2 or L3) .... The router can be used only to route traffice between the VLANS using subinterfaces (If these VLANS in L2 switch) ... Or you can configure interVlan routing (if these VLANS in L3 switch) ...

Configure basic DHCP server in Cisco IOS:

Router(config)# service dhcp (Enabling DHCP)
Router(config)# ip dhcp pool name (Specifies name for the IP Pool)
Router(dhcp-config)# network network-number [mask | /prefix-length] (Specifies the network ID and subnet mask of the network you need to assign ip addresses to its hosts)


What i want from you now .. is to draw me a physical network layout showing how this big pipe is connected to the WAN and how is the router is connected to the LAN switch (core).

About bandwidth shaping, you must first check if your IOS image supports Quality of Service (QoS) ... If so, then only one simple IOS command should be used:

Router(Config)#interface s0/0
Router(config-if)# traffic-shape rate bit-rate [burst-size [excess-burst-size]]

Where bit-rate is the bandwidth for each client.

Regards,
A.Y.
0
 
LVL 1

Expert Comment

by:amyassein
ID: 34236888
Sorry, i didn't answer the question in your last post.

"How would I handle the limit or shape the bandwidth for each VLAN"

You have to create one access list (if all vlans need the same bandwidth) to identify the traffic that comes from each vlan. Then, you apply this access list to the traffic shape command. Here is an example:

Router(config)#access-list 101 permit ip 192.168.1.0 0.0.0.255
                         access-list 101 permit ip 192.168.2.0 0.0.0.255

Router(config)#interface if_name
Router(config-if)#traffic-shape group 101 1000000 125000 125000

If you want each VLAN to have different bandwidth values, so you must create access list for each vlan and apply to different traffic shape values.

Regards,
A.Y.
0
 

Author Comment

by:MeMike
ID: 34239310
AY,
The cisco has 6 different interface shelves to use from ethernet to gbic, I wil draw a network diagram from the ISP and I will get into more detailes of the network layout. I do have layer 2 switches down the network line (1 hop) from the cisco 6506e. If my thinking and understanding is correct this is where I will build my Vlans, I have 3 idf closets with these layer 2 switches and they are all the 48 port switches.

The ISP supplies the hotel with a managed router (lets call this device0) and it is handing off 512 public Ip's.
I will have a dhcp scope defined from the ISP router to allow me to give public IP's to vendor systems that reside on the network a created on a interface 1, then my thinking is I can create interfaces 2 thru x
0
 

Author Comment

by:MeMike
ID: 34239370
Sorry hit post on my phone before I was ready.
Like I was trying to type, setup sub interfaces on the cisco 6506 and route my bandwidth shape, dhcp scope to these layer 2 switches which would be setup exactly the same.

Would I be able to define on the cisco6506 that this port has a public ip and bandwidth shape (if I have QOS).
I will have a network drawing in a few hours.


From what I understand is this cisco can do alot for me if configured correctly?
0
 
LVL 1

Expert Comment

by:amyassein
ID: 34248655
I think you don't need VLANs my friend. As i understood, you want to sell bandwidth to external customers or in other words, you are acting like a small ISP to these customers by providing them leased T1 lines or whatever type of line is.

Since the customers are not physically located in your internal network, so i believe you don't need a VLANs for them. I think you need to use some kind of equipment that is used in ISPs such as FR switch or high end backbone router. Unfortunately, i didn't work in ISPs before in my life so i can't guess about that.

But again, i still need your network layout , send it by attachment or even draw it here using characters such as underscores, dashes, .. etc. I need to see the layout to make proper decision.

Regards,
A.Y.
0
 
LVL 1

Expert Comment

by:amyassein
ID: 34248668
Also, show how your customers are located in your diagram.
0
 

Author Comment

by:MeMike
ID: 34250803
A.Y.

See the attached document and I have more detail of what I'm trying to do below:

You are correct what I’m trying to do is become a ISP for our meeting space by doing and selling "Enhanced Internet Services". The hotel has 25 meeting rooms and our current in-house Internet vendor has the ability to service our standard internet needs wired or wireless and this works great but  If I want enhanced services like VLANS with bandwidth shape my thinking was is becoming a norm, by using the Layer 2 switches in the 3 IDF closets I want to connect rooms by with shaped bandwidth controlled by maybe the Cisco router.  (would this work)
Equipment in the computer room (MDF)
Current Internet pipe is a 200MB pipe with a managed router of 512 IP’s, the DHCP scope has an exclusion of I have 150 IP’s that will be managed from the internet separation switch (public IP’s) I will give the vendor’s there public IP’s for any system going thru out the hotel to the 3 IDF’s.
Using the Cisco 6506 I would interface to these VLANS.
Separation switch config for VLan’s would be something like this:
Port 1-6  Vlan 1-6 would get IP’s from  ISP DCHP Scope or use their assigned public IP’s.  
Port 1- VLan 1: hotel firewall the admin internet (public IP) Shaped to 10MB
Port 2- VLan 2: Hotel guest room meeting room Internet provider shaped to 45MB
Port 3 -6   Vendor systems get IP’s from  ISP DCHP Scope or use their assigned public IP’s
Port 7-12 Vlan 10    Shaped with a pre determined bandwidth and the DHCP from the Cisco 6506 would handout IP’s
Port 13-18 Vlan 20   Shaped with a pre determined bandwidth and the DHCP from the Cisco 6506 would handout IP’s
Port 19-24 Vlan 30   Shaped with a pre determined bandwidth and the DHCP from the Cisco 6506 would handout IP’s
Ect… for the rest of the ports and VLan’s
The above configuration would be the same on each 48 port switch for ease of use, because I would create say 5 Internet bandwidth that we would sell as a package.
IDF Equipment
3 IDF’s HP 48 port switch w/ Gbic ports to connect to separation switch would be 1 hop.
Can I do all this with this equipment or do you recommend a different path?

Visio-Enhanced-Internet-Layout.pdf
0
 
LVL 1

Expert Comment

by:amyassein
ID: 34256059
Hi,

Thanks for the information.

I have couple of comments:

1- How the vendor systems and Hotel are accessing the managed ISP router? ... (VPN, Frame Relay, MPLS, ...etc)

From what i see, they are located remotely (Outside your LAN), how can we assign them to VLAN ports in your internal HP ProCurve switch in order to provide them the needed services? ... However, if they are connected using MPLS or Frame Relay to your ISP router, in this case they can be a part of your VLANs by extending the VLANs to remote sites because MPLS and FR are actually Layer 2 technologies.

2- You should use the Cisco router to create VLANs interfaces because you will use it as DHCP and QoS server so it is better that this router to be aware of its directly connected VLANs interfaces. However, i didn't understand this sentence in red "VLAN Interfaces created on Cisco 6506 thru Separation Switch" and Why are you using four uplinks from ISP router to the HP switch?

Suggestion: Use Cisco 6506 instead to configure VLAN interfaces and configure the uplink to HP as "dot1q" tunking link since you will be using this router as DHCP and QoS shaping server.

Regards,
A.Y.
0
 
LVL 1

Expert Comment

by:amyassein
ID: 34256085
Forgot to mention ...

Please correct me if i am wrong ....

Will the hosts in your VLAN design get Public IPs? .... If so, this will be a severe security hole. VLANs normally are internal segments where hosts are assigned Private IPs then the router is doing the translation (NAT) for them in order to access outside world.
0
 

Author Comment

by:MeMike
ID: 34257610
AY,
I forgot to mention the reason for these clans is because say if a meeting is room 1-4 & room 17;22 & 24 I can clan these meetings as 1 big room in an essence.
To answer some of your question from the earlier post.
Q1: vendor systems would get a static public IP from me and they would either have there own router or use software on there device to protect and or manage there equipment.
Q2 I believe I read on the cisco web site and understand this cisco 6506 can have interfaces (vlan
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 

Author Comment

by:MeMike
ID: 34257691
Or interfaces) are these the same? So again if I understand correctly I create all my vlans on the cisco and uplink (fiber) to the hp switch. The reason I had multiple lines going from the cisco to the hp is because I understood I needed 1 uplink per interface.
Another reason for my thinking to configure the hp with clans per port is for set ut and forget it. Me or my staff would always know ports 5-8 is always Vlan#?
0
 

Author Comment

by:MeMike
ID: 34257761
So on and so forth.
Sorry for the multiple post im on my smartphone on the bus and keep hitting post as we hit a bump or stop quickly.
Almost all of the clients on the Vlans would get Nat address but that is way I will still have a vlan that uses the isp dhcp scope because they request a not Nat adderess.
Another thing what is the advanage of using trucking on hp switch?
0
 
LVL 1

Expert Comment

by:amyassein
ID: 34266208
The main advantage of trunking is to carry the vlan information through that trunk. Without trunking, how can the router be aware of the vlans created in the HP switch and route between them? ..... I think routing between vlans is not the issue here because you didn't require that , for example, Client 1 in Vlan A to communicate with Client 2 in Vlan B.... You only required how to hand out IP addresses to these hosts automatically and traffic shape them.

First, let's solve the DHCP issue here then we will look at traffic shaping later.

As per what you mentioned in your answer, If the vendor systems and the Hotel got their own network and equipments, so i don't think you need to join them in Vlans in your network ... In this scenario, you can act as a DHCP server for them at the gateway level. For example, configure your DHCP server in the ISP router (Not Cisco as per your layout) as this is the gateway edge router and this is where the WAN connection is terminated to remote clients (Hotel and vendor systems). However, you must also configure their edge router as DHCP relay agent in order to forward their hosts requests to your DHCP server.

Checklist:

1- Make sure first your ISP router can reach your clients remote network.
2- Make sure you enable and configure DHCP on your ISP router.
3- Make sure you enable DHCP relay agent in the remote router.

Your ISP router config:

Router(config)#service dhcp
Router(config)#ip dhcp pool pool_name
Router(dhcp-config)#network network-number [mask | /prefix-length]
Router(dhcp-config)#domain-name mydomain.com (optional)
Router(dhcp-config)#default-router ip_addr
Router(dhcp-config)#lease duration


Client router config:

Router(config)#interface s0/0 ( this is the WAN interface)
Router(config-if)#ip helper-address ip_address

Where ip_address is the address of your ISP router's WAN interface.


Try this now and if successful, we will jump to how traffic shape them.

Cheers,
A.Y
0
 
LVL 1

Expert Comment

by:amyassein
ID: 34266312
My friend, i am still confused about something.

Why did you draw the clients as VLANs in your internal network whereas you said that clients are in remote networks?

Are the clients existing locally or remotely? ... Or Are they guests attached to your local network? ...

Thanks
A.Y
0
 

Author Comment

by:MeMike
ID: 34267050
AY,
The isp router will have a dhcp scope enabled but I will not have any access to this router so I will not to be able to act as a dhcp server for my clients but I can and will use the isp router for the my vendors and one off connections to gain internet access.

I think I have confussed the client vendor relationship and the vlan purpose, so will tryto define them and there purpose.

Network overview : Keep in mind all these networks are seperated and only touch (route the cisco router).

NETWORK # 1
NETWORK #1. - ISP NETWORK
Will use mainly for vendor systems, Hotel internet service (admin) these systems will connect to the internet with the use of public ip's either to be given a static or dhcp address supplied by the ISP.

NETWORK# 2. In-house internet provider
This provider will handle all standard internet service for guestrooms (wired and wireless), meeting rooms with there own equipment.

NETWORK# 3 - ENHANCED INTERNET SERVICE (managed by myself)
I will need to be a dhcp server.
I will need to do bandwidth shaping.

To answer your other questions.
clients all use network # 3 they are all local users no remote users this is where I need to sell the bandwidth shaping and the reason I think I need Vlans. For ease of use I configure each HP switch so I know that port 5 thru 9 are a single AT; port 10 thru 14 is 3MB; ports 40 thru 42 is a 20 MB shape.
0
 

Author Comment

by:MeMike
ID: 34267059
Sorry to confuse you I know what I would to do and you can let me know if I can do it this way,

Thanks again.

Mike
0
 
LVL 1

Accepted Solution

by:
amyassein earned 500 total points
ID: 34267497
Understood ...

I assume that Cisco 6506E router to be used to reaching the VLANS in the HP switch not the ISP router.

Refer to the following:

1- Configure Cisco 6506E router to reach the Vlans in HP switch by using subinterfaces.

Router(config)#interface FastEthernet1/1.1
Router(config-if)#description Native VLAN
Router(config-if)#encapsulation dot1q 1 native

Router(config)#interface FastEthernet1/1.2
Router(config-if)#description SVI to Vlan2
Router(config-if)#encapsulation dot1q 2
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shut

......

Repeat the above configuration for every VLAN in your HP Switch.

Note1: (.2) in FastEthernet1/1.2 is a virtual interface and we call it also subinterface.

Note2: it is recommended to leave VLAN 1 alone as this is the default VLAN created for untagged vlan traffic.


2- Configure Cisco 6506E router as a DHCP server:

Router(config)#service dhcp
Router(config)#ip dhcp pool VLAN2_Pool
Router(dhcp-config)#network 192.168.2.0/24
Router(dhcp-config)#domain-name mydomain.com (optional)
Router(dhcp-config)#default-router 192.168.2.1
Router(dhcp-config)#ip dhcp excluded-address addr_range
Router(dhcp-config)#lease duration

.......

Repeat the above configuration for every VLAN.

Note1: it is recommended to remove any DHCP server you have in your network or make sure any DHCP server doesn't has the same pool ranges to avoid conflicts.

Note2: exclude IP range to avoid conflicting with hosts that are statically IP assigned.


3- Configure Cisco 6506E router for traffic shaping:

Router(Config)#interface FastEthernet1/1.2
Router(Config-if)#traffic-shape rate 1000000 125000 125000

......

Repeat the above config for every VLAN using different bit rate values for each one.


If you have any questions, please let me know.

A.Y






0
 
LVL 1

Expert Comment

by:amyassein
ID: 34267752
There is something important here .....

Because we are using QoS Shaping in Cisco router, QoS also should be enabled in the ISP router. Why? ... Because actually the Cisco router is not the last hop resort and we still have the ISP router in our path, therefore, QoS must be enabled along the path. This will introduce a new problem because you don't have access on ISP router so i think you need to call them to configure this for you. (If they agree :))

Cheers,

A.Y
0
 

Author Comment

by:MeMike
ID: 34272405
A.Y.
I understand the reason for QoS being activated on the the ISP router good call, So I have further understand about everything I have suggested doing with the  Cisco router, HP switche  and the creations of the Vlans will all this work the way I envisioned.  Am  I on the correct path  also feel it is built and layed out in a logical way for ease of use.

Let me I understand I will be building multiple DCHP on the Cisco and I build a scope for each vlan?
Is there a method to building different scopes so as not to have a confict? Is this handled in 2 ways different 3 octat and subnet mask?

As I have never programmed a router at this level so please excuse these questions, can you explain these values that you have built?
 
2- Configure Cisco 6506E router as a DHCP server:

Router(config)#service dhcp    (this turns on the service?)
Router(config)#ip dhcp pool VLAN2_ Pool       (This tells me this is Vlan # (2 ) and is going to be a pool?)
Router(dhcp-config)#network 192.168.2.0/24   (IP Range how many IP’s is this  256?)
Router(dhcp-config)#domain-name mydomain.com (optional)  (that’s easy)
Router(dhcp-config)#default-router 192.168.2.1  (always use .1 as the gateway of that range)
Router(dhcp-config)#ip dhcp excluded-address addr_range  (How would you this sytx?  Like this : 001_010)
Router(dhcp-config)#lease duration
Also would this be a good read to learn basic Cisco command sytx.

http://www.tomax7.com/mcse/cisco_commands.htm
0
 
LVL 1

Expert Comment

by:amyassein
ID: 34272436
Ok no problem ...

Here is the explanation:

1- Enabling DHCP service in the router

    Router(config)#service dhcp


2-Creating a pool of ip addresses that will be assigned to hosts in VLAN2

   Router(config)#ip dhcp pool VLAN2_Pool


Note: Cisco doesn't use the term scope like Microsoft. However, the above pool command is the scope of VLAN2. When i said repeat the command for every VLAN, i meant to create addition scopes for every VLAN.


3-Specify the network which the ip addresses will be taken from.

   Router(dhcp-config)#network 192.168.2.0/24

Note: I assume that you are good subnetting, so 192.168.2.0/24 means you have 254 available host IDs to give to client machines in VLAN2.



4-Set the domain name of your current domain.

   Router(dhcp-config)#domain-name mydomain.com (optional)


5-Set the default gateway for client machines.

   Router(dhcp-config)#default-router 192.168.2.1


6-Set an exclusion list of ip addresses

   Router(dhcp-config)#ip dhcp excluded-address addr_range


7-Set the lease duration

   Router(dhcp-config)#lease duration (Optional)


I assume that you already know the modes of Cisco IOS such as configuration mode, dhcp config mode, interface mode, ... etc. Each mode has its own available set of commands to execute. To exit a mode, simply type "exit" in your current mode.

Example:

Router(config)# <------- Configuration mode
Router(config-if)# <-------- Interface configuration mode
Router(dhcp-config)# <--------- DHCP configuration mode.

I suggest the below links for you:

http://www.cisco.com/warp/cpropub/45/tutorial.htm
http://www.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cfdhcp.html




Regards,
A.Y
0
 
LVL 1

Expert Comment

by:amyassein
ID: 34272457
"Router(dhcp-config)#default-router 192.168.2.1  (always use .1 as the gateway of that range)"

DHCP is not just a service to hand out IP addresses only, it gives also many other information for the clients through the use of DHCP options. One of the option is the default gateway. Because the client machine will be configured to grab ip addresses automatically, it also grabs default gateway automatically.

Simple example, in Windows OS, when you select to obtain IP addresses automatically, it turns all  fields into a dimmed fields because  they will be taken from DHCP server.
0
 
LVL 1

Expert Comment

by:amyassein
ID: 34276518
Any update?
0
 

Author Comment

by:MeMike
ID: 34291602
AY
Sorry for the delay I've been working on another project at work. I will read the suggested links you sent me and I do have a base understanding of subnetting and I was aware of the 3 modes of Cisco ISO.
I will accept your solution as this will get me started with the network configuration if I have more question or problems i'll post another question.
Thank you for your time.

Mike
0
 
LVL 1

Expert Comment

by:amyassein
ID: 34298580
Ok thank you MeMike.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now