?
Solved

RDP doesn't work after upgrading to Windows 7 64bit

Posted on 2010-11-25
16
Medium Priority
?
908 Views
Last Modified: 2012-05-10
I used to RDP to my machine at home without problems from my PC at work.
I have just been given a Windows 7 x64 machine as part of the pilot for our hardware refresh.

Strangely, I can now no longer RDP to my home machine, Win7 Ultimate 64bit.
To make it odder still, users on Win7 32bit and XP can still RDP to my machine fine.

Some of the MSTSC settings are locked down via Group Policy, but I have full access to the registry. It would however be bad form to move myself to another OU to avoid the GPs that lock down the MSTSC setings.

Any ideas anyone?
0
Comment
Question by:LPetersson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
16 Comments
 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 34212341
are you saying 32bit systems can RDP to your home system, or just your 64bit LAN system ok??

I assume that port 3389 is open on both systems (as 7 has 2 firewalls) and your are trying to connect home using your external router IP?  On the RDP client, on the Advanced tab, do you have the Server Auth set to Connect & Don't Warn and under Connect from Anywhere to do not use RD server?

I would also de-select IPv6 from your NIC too.
0
 

Author Comment

by:LPetersson
ID: 34212420
32 bit Windows 7 and XP can RDP to me home system which is Windows 7 ultimate 64 bit, yes.

The port is open and Windows' firewall has been disabled on all the machines. I have de-selected IPv6 but forgot to mention this in my post.

MSTSC is set to Connect and don't warn me.
0
 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 34212442
and the Connect from Anywhere option??  what do you have that set to?
0
Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

 

Author Comment

by:LPetersson
ID: 34217228
Where is the 'Connect From Anywhere' option?

It doesn't leap out at me when I look at the settings in MSTSC => Options...
0
 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 34217319
bottom half of the advanced tab.......under Server Authentication.
0
 

Author Comment

by:LPetersson
ID: 34217737
Ahh, the gateway settings, I have tried each of the 3 radio buttons, but since I don't have any credentials, the middle one doesn't accept usage.

The Win7 32bit machine that can connect fine uses the 'Automatically Detect' option.
0
 
LVL 6

Expert Comment

by:RootsMan
ID: 34217807
What is the error message received when you fail to connect?
0
 

Assisted Solution

by:LPetersson
LPetersson earned 0 total points
ID: 34217831
This is the error I get:

---------------------------
Remote Desktop Connection
---------------------------
Remote Desktop can’t connect to the remote computer for one of these reasons:

1) Remote access to the server is not enabled
2) The remote computer is turned off
3) The remote computer is not available on the network

Make sure the remote computer is turned on and connected to the network, and that remote access is enabled.
---------------------------
OK   Help  
---------------------------


As I wrote above, Win7 32bit and XP 32bit clients can connect fine, so the computer is on and the router is forwarding packets...
0
 
LVL 1

Expert Comment

by:wjcott
ID: 34223939
I would check whether the new client can interact with your home client first (ping home IP address)

If you are able to ping your home IP address, I would then attempt a telnet to the RDP port ("telnet <home IP address> 3389"). If you are able to connect to the port, you should get a blank command line window.
0
 
LVL 6

Expert Comment

by:M. Rashel Ahmed
ID: 34244502
0
 

Assisted Solution

by:LPetersson
LPetersson earned 0 total points
ID: 34250235
wjcott/raselaiub: If you had read the question properly and the various comments you would see that I can connect fine from other clients on the same network. In fact, right now I'm RDP'ing to the machine next to me and RDP'ing from that to my home machine.
The problem doesn't lie at the receiving end...
0
 

Accepted Solution

by:
LPetersson earned 0 total points
ID: 34498563
I haven't been able to figure it out and neither has anyone else...

Odd, but hey ho, I get around it to RDPing to a Windows XP machine and then RDPing to my home machine...

Most peculiar, but not worth more of my time right now.
0
 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 34498645
its a strange one, as i use RDP to get to my home system which is Win 7 Pro 64bit, same as my office system, and mine is working fine, though my work system has some modifications such as Autotune disable, Windows Scaling disable and CTCP enabled, IPv6 and Flow Control disabled on the NIC and any IPv6 settings.
0
 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 34498673
i would also suggest using the IP address of your remote system, rather an any names, see if that helps and check the RDP Settings one more time (i also found leaving my home system logged in with active session helps):

1- uncheck the TCP/IP v6  
2 - In options of remote desktop,  tab ADVANCED,  change the server authentications for : Connect and don't warn me.  
3 - Just below, in connect from anywhere, Settings...  select : Do not use an RD Gateway server.

64 bit RDP does appear to have some issues, but 32bit doesn't, might be fixed in a patch or the upcoming SP1 - check your system patches at both ends.  I have also recently just added .Net 4.0 client at both ends incase that alters anything.
0
 

Author Closing Comment

by:LPetersson
ID: 34532771
I accepted my own solution because it was the only available workaround.
0
 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 34532827
got to be an issue with your 64bit system, i could not replicate the fault.
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Assume you have an outside contractor who comes in seasonally or once a week to do some work in your office, but you only want to give him access to the programs and files he needs and keep all other documents and programs private. Can you do this o…
No single Antivirus application (despite claims by manufacturers) will catch or protect you from all Virus / Malware or Spyware threats. That doesn't stop you from further protecting yourself however - and this article is to show you how.
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…
This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.
Suggested Courses
Course of the Month13 days, 14 hours left to enroll

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question