Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 629
  • Last Modified:

Login failed for user 'sa' for SharedServices1 in Sharepoint 2007

When im try edit SharedServices1, error is Login failed for user 'sa'. Yes password for sa was changed.
Can i change database auth throw command line?
stsadm.exe -o editssp -title SharedServices1 no help.
0
Aleksey_S
Asked:
Aleksey_S
  • 2
  • 2
1 Solution
 
TheMakCommented:
1) Is this an attempt at creating a new farm or at re-running the SPTW on a farm that already exists?  I assume you are creating a new farm.2) What account were you logged in as when you ran the SPTW?  Did this account have securityadmin and dbcreator rights in the SQL instance that you're using for SharePoint?3) Is Windows Firewall turned on for your SQL Server and/or for your SharePoint server?


http://www.go4answers.com/Example/sharedservices1-default-49069.aspx
0
 
Aleksey_SAuthor Commented:
1) farm already exists, problem run after detach and attach databases (and change sa password)
2) account domain\ssp is db owner SharedServices1 database
3)accout domain\spadmin is farm admin, im try get domain\spadmin dbowner on all bases, change SharedServices1 to domain\spadmin and still nothing.
Problem with SharedServices1 runnung with old sa password and can't change type auth for it.
0
 
TheMakCommented:
It sounds like a permissions issue. Can you check a number of things.

1. The application pool accounts will need to have dbo rights on the databases associated with the web applications.
2. If you are administrating the SSP you should be ogged on with an account that has full control on the SSP web application
3. SharedServices1_DB is the database containing the services configurations, your SSP app pool account will need dbo rights on this database at a minimum.

Come back with more info after checking these items.
--------------------------------------------------------------------------------
http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/b2e89723-067a-4177-86b5-16a28e208f61

OR

It looks like you've set up your connection to use your Windows account to connect to the database rather than supplying a user name and password.  When you're connecting through Visual Web Developer at design-time, you're connecting to the database as yourself.  I'm guessing that you're an administrator on the machine and for the database and you connect successfully.  The actual application will run under the ASP.NET account.  If you have not granted that account permission to the database, the connection attempt will fail with the message you described.

Here's a quick breakdown of some options:

1.)  Use a user name and password in the connection string
2.)  Have the application run under a different account that has permission to access the database
3.)  Grant permission to the ASP.NET account
4.)  Consider having ASP.NET impersonate the current user

I hope this information proves helpful.

http://social.msdn.microsoft.com/forums/en-US/adodotnetdataproviders/thread/26fd5295-e9e2-44e7-9a3d-6af69da77093/
0
 
Aleksey_SAuthor Commented:
in registry im find old sa password, so preblem resolved.

[HKEY_LOCAL_MACHINE\Software\Microsoft\Office Server\12.0\Search\Applications\GUID\ResourceManager]
"Data"="Server=server;Database=SharedServices1_Search_DB;Uid=sa;Pwd=*******;App=Windows SharePoint Services;Timeout=15"
0
 
HairbrushCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now