Solved

SharePoint 2010- Site links no longer work EXTERNALLY after enabling/disabling anonymous access.

Posted on 2010-11-25
4
785 Views
Last Modified: 2012-05-10
In doing some testing, I enabled and disabled anonymous access in SharePoint 2010 for the SharePoint- 80 web application.  During the course of that, I created a new internet "zone".    After testing, I deleted that application pool extension (and that extension only)...not surprisingly, none of my links, libraries, lists, documents etc. work...they all appear, but when you click on any file, it is "not found".  You can completely navigate the site- again, everything is there but you just can't get to it.  Search also does not work externally.  It allows you to use search, but doesn't return any results.

I was very careful to only delete the "Internet" zone that I created- and leave the SharePoint- 80 alone.  I don't think I've "lost" any data- I think I've just really gummed up the permissions for logging in EXTERNALLY.

If I'm in the the domain, everything works fine- it's when I try to login from outside that the issues begin.

What do I need to check?
0
Comment
Question by:thompsonwireless
  • 2
  • 2
4 Comments
 
LVL 15

Accepted Solution

by:
sharepointguru14 earned 500 total points
ID: 34214832
what zone do you have your external access going to? What is the authentication model? and is anonymous access enabled on it?
0
 
LVL 6

Author Comment

by:thompsonwireless
ID: 34216642
- When this started there was one zone- "Default", that's the only zone that appears again.

- The authentication model is "Windows". "Enable Anonymous Access" is still checked, but that doesn't seem to matter.  "Integrated windows authentication, NTLM" is also selected, and "Enable client integration" is set to yes.  "Require use Remote Interfaces permission" is NOT checked.
0
 
LVL 15

Assisted Solution

by:sharepointguru14
sharepointguru14 earned 500 total points
ID: 34219945
so you access the site internally at the same URL as you do externally?

Normally when enabling external access you extend the web application to another zone (say Default for internal) and extend that out to the Internet Zone. This allows you to change the URL so maybe internally its http://intranet but externally its https://intranet.com

if you are using the default zone for both and anoymous access is enabled, it seems that you are granting view rights for anonymous users (which would be anybody access from off the network) but the Windows credentials are being picked up and used when internally so everything works as expected.
0
 
LVL 6

Author Comment

by:thompsonwireless
ID: 34219957
I resolved the issue by adjusting the AAM.

Thanks to everyone for your help!
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
PHP 7 with IIs and SQL Server Windows 2008 Server failed to connect 8 86
Hide http port number 5 45
sharepoint list help 2 28
Sharepoint 2010 2 11
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
This video shows how to use Hyena, from SystemTools Software, to bulk import 100 user accounts from an external text file. View in 1080p for best video quality.

832 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question