Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2292
  • Last Modified:

Turn off dde for access 2003 in server 2008

I'm getting the "There was a problem sending the command to the program" error when running an access 2003 database from the desktop on a server 2008 terminal server. I have checked and unchecked all the combinations on the advanced tab of the database and cannot get the message to go away. Where do I get rid of the dde process in this environment. On server 2008 the folder options, file association tab doesn't look like the older versions where you have a dde option. I guess it's somewhere in the registry, but I can't for the life of me find out where to go.
0
breauxlg
Asked:
breauxlg
  • 8
  • 3
  • 2
1 Solution
 
breauxlgAuthor Commented:
Thanks.
0
 
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
Do you get this error while you're performing any specific task - for example, does it occur when you Open a Form, or when you enter data in a control, etc etc?

Have you performed maintenence on the database (i.e. Compact, Compile, Decompile, etc)?

0
 
breauxlgAuthor Commented:
The database basically just opens, runs a procedure, and closes. The prodecure runs and performs the intended function, but the message still appears. After clicking OK, it goes away, but it confuses the users to have that message pop up evertime the database runs. Thanks for caring enough to respond, by the way.
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
breauxlgAuthor Commented:
I have tried decompiling and recompiling, compacting and repairing, etc. to no avail.
0
 
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
What's the procedure? What does it do?
0
 
breauxlgAuthor Commented:
It just copies a front-end database to the desktop of the user.
0
 
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
Can you post the code that causes the error?
0
 
breauxlgAuthor Commented:
Here's the little database that generates the error. It does not generate the error on Server 2003.  BackupLoadWorks.zip
0
 
jbodagerCommented:
try going to this registry key:  HKEY_CLASSES_ROOT\Access.MDBFile\shell\Open\ddeexec

change the key name "ddeexec" to "NOddeexec".

I had a very similar problem and it fixed my issue.  My co-worker helped me with this issue.  We found that the ability to turn off DDE in Access was removed in current versions of windows, so you need to go into the registry to do it.  changing "ddeexec" to "NOddexec" is kink of a hack, but it worked.

good luck.
0
 
breauxlgAuthor Commented:
jbodager - There is no key in the registry at that point. I don't have Access.MDBFile under HKEY_CLASSES_ROOT. That looked hopeful, though.
0
 
breauxlgAuthor Commented:
I found the access.application registry entry and renamed the ddeexec to noddeexec and the message went away. Thanks jbodager.
0
 
breauxlgAuthor Commented:
I'm just glad someone was still looking at my problem. Thanks.
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 8
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now