Setting up UTF-8 encoding in output window of netbean6.5

Hi,

My application is reading excel file with chinese charatecters.

When I debug my code then all chinese character in output window is displayed as ????

How do we set encoding for output window and what encoding is perferable to display output in chinese as well with english

Please suggest

Many Thanks
tia_kamakshiAsked:
Who is Participating?
 
Bruce SmithConnect With a Mentor Software Engineer IICommented:
The reason you are not getting the "Choose Font" option is because you have an older version of NetBeans. I have NetBeans 6.9.1 but you are running NetBeans 6.5. Here is what my output context menu looks like in 6.9.1:

NetBeans 6.9.1
I would advise that you update your NetBeans IDE to the new version and try my solution above as you could see it prints out both the Chinese characters and English characters.

PS. You said: "When there is no output before executing the project. The output window is greyed out and we cannot do right click on it." This is correct, you have to run or debug a project or script before you will be able to choose the font. The font will change immediately when you select it, not at the next run.
0
 
Bruce SmithSoftware Engineer IICommented:
I looked and looked and couldn't find a way to do this. The only solution to show Chinese characters in the output window is to change the font to a pre-installed Chinese font on your system by right-clicking inside the output window. But this of course isn't a solution to 'English and Chinese'.

Cheers
0
 
tia_kamakshiAuthor Commented:
Thanks patsmitty for your response.

I have right click on my output window but I cannot see any option to set 'English and Chinese'.

Can you please help what steps I need to follow to achieve this task

Thanks again

0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
Bruce SmithSoftware Engineer IICommented:

1. Right-click inside of the Output window


2. Select 'Choose Font...'


1. Find and select the 'Monospaced' font.


This worked for me!

 Chinese and English!
0
 
tia_kamakshiAuthor Commented:
Hi,

Thanks for your reply.

When there is no output before executing the project. The output window is greyed out and we cannot do right click on it.

When we debug the project and stop in between then we can right click inside the output window, but still I cannot see any choose Font option

Can you please guide me how you have done?

Many Thanks
printscreen.bmp
0
 
tia_kamakshiAuthor Commented:
Many Thanks
0
All Courses

From novice to tech pro — start learning today.