Solved

Cannot ping www.microsoft.com

Posted on 2010-11-25
9
1,792 Views
Last Modified: 2012-05-10
Hi,

I recently took over a server in a school. I was trying to update the server when I noticed the machine couldn't ge to windows update. On firther investigation it won't ping any part of microsoft.com. NSLookup seems to work but it won't ping (Ping request could not find host www.microsoft.com. Please check the name and try again.) or browse to www.microsoft.com or obviously windows update.

The setup is that the school gets its broadband through a VPN on a Cisco. There are 2 nics in the server and it's acting as a router to create a separate network on the LANside of the Cisco. I'm seeing some issues in relation Master Browser errors in the logs so I wanted to update the machine to get a line in the sand. Very frustrating. Have tried a lot of things but feel like a need a fresh look.

Any help, please!
Tom.
0
Comment
Question by:tomfogarty
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 7

Expert Comment

by:expert1010
ID: 34214136
Ping is unfortunately not always usable. Try to see if you can reach it with traceroute. Windows traceroute command would be "tracert". Try without DNS and with.

tracert -d microsoft.com
tracert microsoft.com

You should at least be able to reach somewhere in microsofts network 207.46.0.0/16

Here's a trace from me (2 first disguised). From 11 and on there is some ACL that's hindering the backets to get through.

 3  static-213.50.128.33.addr.se.sn.net (213.50.128.33)  11.503 ms   11.025 ms   14.410 ms
 4  ge3-7.ign-p2.got.se.ip.tdc.net (212.214.180.45)  24.142 ms   23.404 ms   22.675 ms
 5  nyc-76e-1.ntwk.msn.net (198.32.118.18)  115.520 ms   116.533 ms   116.582 ms
 6  209.240.210.130 (209.240.210.130)  117.938 ms   117.530 ms   118.012 ms
 7  ge-7-0-0-0.co1-64c-1b.ntwk.msn.net (207.46.40.90)  200.890 ms   201.644 ms   201.141 ms
 8  ge-7-2-0-0.wst-64cb-1b.ntwk.msn.net (207.46.46.116)  200.353 ms   200.358 ms   201.052 ms
 9  ge-1-1-0-0.cpk-64c-1b.ntwk.msn.net (207.46.46.249)  201.167 ms   201.967 ms   201.364 ms
10  ten2-4.cpk-76c-1b.ntwk.msn.net (207.46.47.195)  193.427 ms   193.100 ms   192.987 ms
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *

Here's a tcp traceroute to port 80 on www.microsoft.com

Tracing the path to www.microsoft.com (65.55.12.249) on TCP port 80 (http), 30 hops max
 3  static-213.50.128.33.addr.se.sn.net (213.50.128.33)  11.670 ms  10.695 ms  11.268 ms
 4  ge3-7.ign-p2.got.se.ip.tdc.net (212.214.180.45)  15.591 ms  14.936 ms  15.183 ms
 5  nyc-76e-1.ntwk.msn.net (198.32.118.18)  115.036 ms  114.969 ms  109.384 ms
 6  209.240.210.130  115.165 ms  114.916 ms  116.334 ms
 7  ge-7-0-0-0.co1-64c-1b.ntwk.msn.net (207.46.40.90)  194.850 ms  195.860 ms  189.556 ms
 8  * * *
 9  * * *
10  wwwco2vip.microsoft.com (65.55.12.249) [open]  193.104 ms  195.369 ms  188.923 ms
0
 
LVL 5

Expert Comment

by:Matt Davies
ID: 34214176
Have you checked for virus infection? There are a few classics that screw up access to Microsoft and a number of AV sites such as McAfee or Symantec.
0
 
LVL 27

Expert Comment

by:Lukasz Chmielewski
ID: 34214240
Any proxy server / firewall hardware ? Is there any WSUS server in the network ?
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:tomfogarty
ID: 34214601
Hi,

To answer all questions together!

expert1010
See result of tracert below
C:\Documents and Settings\Administrator>tracert -d microsoft.com
Unable to resolve target system name microsoft.com.

C:\Documents and Settings\Administrator>tracert microsoft.com
Unable to resolve target system name microsoft.com.


See result of nslookup
C:\Documents and Settings\Administrator>tracert -d microsoft.com
Unable to resolve target system name microsoft.com.

C:\Documents and Settings\Administrator>tracert microsoft.com
Unable to resolve target system name microsoft.com.


Matthewidavies
I'm running a virus scan now. I'll update as soon as it's done.

Roads_Roads
Not aware of any proxy/firewall hardware. I'm checking the WSUS situation - how would this affect it?

How does the fact that this server is effectively a router impact on this problem/DNS. I wouldn't have thought it would impact on it. I have tried pinging other sites like yahoo/google and other browsing and all seems OK. I have also flushed DNS, recreated DNS zones and checked the HOSTS file.

Tom.


0
 
LVL 27

Expert Comment

by:Lukasz Chmielewski
ID: 34215693
Did you actually >>restart<< DNS service ? Did you try to reach MS site with an IP address ?
0
 

Author Comment

by:tomfogarty
ID: 34215752

Server has been restarted serevarl times. Have tried a resolved IP to get to MS but it doesn' ping. This doesn't tell me anything though since pinging www.microsoft.com on any machine won't return anything because presumably they have ICMP turned off on the outside.

Tom.
0
 
LVL 8

Accepted Solution

by:
psychogr earned 500 total points
ID: 34215884
I know some viruses mess up networking and block access to *.windows.* sites.
I bet you cannot browse update.microsoft.com either..

All you have to do is to download Microsoft Removal Tool (MRT) and scan your system with it.

Good luck
0
 
LVL 3

Expert Comment

by:Suryanarayan Balakrishnan Iyer
ID: 34215933
Check if can ping any other website from your system.  ICMP to microsoft.com would not work. Check your DNS binding and check with the ISP since you would be forwarding your packets to the ISP DNS.
0
 

Author Closing Comment

by:tomfogarty
ID: 34338489
Apologies for the delay in getting back - MRT did the trick.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
TCP Reset from Server 3 87
Exchange, OWA, PROXY 7 59
Cannot access website or email server 4 81
DNS logs 1 19
I wrote this article to explain some important DNS concepts that should be known to avoid some typical configuration errors I often see in forums. I assume that what is described here is the typical behavior of Microsoft DNS client. I don't know …
BIND is the most widely used Name Server. A Name Server is the one that translates a site name to it's IP address. There is a new bug in BIND (https://kb.isc.org/article/AA-01272), affecting all versions of BIND 9 from BIND 9.1.0 (inclusive) thro…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…
This video shows how to use Hyena, from SystemTools Software, to update 100 user accounts from an external text file. View in 1080p for best video quality.

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question