• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 984
  • Last Modified:

SharePoint site 2010 access issue with FQDN doesn't work but works fine with machine name ?

Hi All,

I've deployed Sharepoint 2010 already and have created new site on port 80, however when i type http://machinename it works but not with http://machinename.domain.com ?

is there anything faulty in the configuration ?

any help is appreciated.

Thanks.
0
jjoz
Asked:
jjoz
  • 4
  • 4
1 Solution
 
logideepakCommented:
this could be handled  by adding a mapping in your hosts file located at C:\Windows\System32\drivers\etc.

however, this would need to be added at each client machine.

A better way would be to add a lookup zone in DNS server.
0
 
jjozAuthor Commented:
oh, so it is not the sharepoint server settings ?
0
 
logideepakCommented:
you can check the alternate access mappings in sharepoint 2010 central administration.. but it is mostlty because of the fact that the remote computer is not able to resolve the FQDN of your sharepoint server
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
jjozAuthor Commented:
thanks logideepak, the reason why i ask here is taht i don't understand AAM:-|
0
 
logideepakCommented:
alternate access mapping is basically to define how and through which URL your sharepoint site will be accessed in different zones.

typcially when you want to make your site available for internet or intranet environment and dont want the user to actually request the site using machine name you allow the settings to be handled through the aam.

for e.g. http://mycompany.intranet.com
http://mycompany.com

for all these cases you need to add an entry into Forward lookup zone and then replicate the settings in AAM
0
 
jjozAuthor Commented:
ok so in thiscase AAM + DNS changes, because I've done Host Header changes and AAM it is not going anywhere :-|
0
 
logideepakCommented:
yes
0
 
jjozAuthor Commented:
thanks man !
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now