Solved

Exchange 2010 OWA Slow

Posted on 2010-11-25
11
2,896 Views
Last Modified: 2012-06-27
All,

I'm getting lots of complaints from our users that the connectivity to our OWA is very slow. Everytime I check, it seems fine to me, but we have over 20 users in different offices / networks with the same complaint. We're running Exchange 2010 SP1 w/ Rollup 1 on a Windows 2008 R2 box. There's plenty of memory and cpu on this machine so thats definately not the cause. Our Exchange is sitting behind an MS TMG 2010 Server. I did notice in the event viewer on the Exchange server that we had several of these entries: EventID: 5139 Source: WAS "A listener channel for protocol 'http' in worker process '4388' serving application pool 'MSExchangeOWAAppPool' reported a listerner channel failure.

Could this be the cause? Whats the suggested solution? How do I troubleshoot this?

TIA,

0
Comment
Question by:rcs81
  • 5
  • 2
  • 2
  • +2
11 Comments
 
LVL 1

Expert Comment

by:alok-mishra
ID: 34215684
Run this commanaf

iisreset /noforce
0
 
LVL 1

Author Comment

by:rcs81
ID: 34215722
I've tried that as well, still getting complaints that its slow.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34215785
Slow? What are the users doing that appears slow? Are they external? Maybe time to roll out outlook anywhere.

Or are they doing owa searches and it is slow?
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 
LVL 1

Expert Comment

by:alok-mishra
ID: 34215844
0
 
LVL 11

Expert Comment

by:JuusoConnecta
ID: 34216385
I agree with MegaNuk3, what is the defination from users when they complain about the slowness ?

Is it slow with the login ? Slow once your logged onto to OWA ? Have you tried it yourself to confirm that this is for all users and not just a limited set of users. This to determine if it is an server side issue or a client side issue,
0
 
LVL 1

Author Comment

by:rcs81
ID: 34217953
Here's the complaint:

When logging into OWA its fast. However when clicking on any of the links ("Inbox", "Sent Items", "Calendar") they have to wait for 1 minute before the page displays the data. These mailboxes have very little data as of now <1mb. OWA speeds up after using it for sometime, but if they close the browser window and try to login in again its back to being slow.

I have not been able to replicate the problem on my end. No issues with Outlook Anywhere. Hope this sheds some light
0
 
LVL 1

Author Comment

by:rcs81
ID: 34217983
Forgot to mention that they are external users, no one is on the local LAN.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34220111
have you run exbpa on there to see if it highlights anything?
0
 
LVL 26

Expert Comment

by:e_aravind
ID: 34259721
netsh interface tcp set global autotuninglevel=disabled (on the W2k8 servers)
0
 
LVL 1

Accepted Solution

by:
rcs81 earned 0 total points
ID: 34481800
It was a problem with our TMG servers NIC. After swapping out the NIC the problem went away
0
 
LVL 1

Author Closing Comment

by:rcs81
ID: 34514762
Faulty hardware
0

Featured Post

Free Tool: Postgres Monitoring System

A PHP and Perl based system to collect and display usage statistics from PostgreSQL databases.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
This article explains how to install and use the NTBackup utility that comes with Windows Server.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question