Solved

Exchange 2010 OWA Slow

Posted on 2010-11-25
11
2,900 Views
Last Modified: 2012-06-27
All,

I'm getting lots of complaints from our users that the connectivity to our OWA is very slow. Everytime I check, it seems fine to me, but we have over 20 users in different offices / networks with the same complaint. We're running Exchange 2010 SP1 w/ Rollup 1 on a Windows 2008 R2 box. There's plenty of memory and cpu on this machine so thats definately not the cause. Our Exchange is sitting behind an MS TMG 2010 Server. I did notice in the event viewer on the Exchange server that we had several of these entries: EventID: 5139 Source: WAS "A listener channel for protocol 'http' in worker process '4388' serving application pool 'MSExchangeOWAAppPool' reported a listerner channel failure.

Could this be the cause? Whats the suggested solution? How do I troubleshoot this?

TIA,

0
Comment
Question by:rcs81
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
  • 2
  • +2
11 Comments
 
LVL 1

Expert Comment

by:alok-mishra
ID: 34215684
Run this commanaf

iisreset /noforce
0
 
LVL 1

Author Comment

by:rcs81
ID: 34215722
I've tried that as well, still getting complaints that its slow.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34215785
Slow? What are the users doing that appears slow? Are they external? Maybe time to roll out outlook anywhere.

Or are they doing owa searches and it is slow?
0
Comparison of Amazon Drive, Google Drive, OneDrive

What is Best for Backup: Amazon Drive, Google Drive or MS OneDrive? In this free whitepaper we look at their performance, pricing, and platform availability to help you decide which cloud drive is right for your situation. Download and read the results of our testing for free!

 
LVL 11

Expert Comment

by:JuusoConnecta
ID: 34216385
I agree with MegaNuk3, what is the defination from users when they complain about the slowness ?

Is it slow with the login ? Slow once your logged onto to OWA ? Have you tried it yourself to confirm that this is for all users and not just a limited set of users. This to determine if it is an server side issue or a client side issue,
0
 
LVL 1

Author Comment

by:rcs81
ID: 34217953
Here's the complaint:

When logging into OWA its fast. However when clicking on any of the links ("Inbox", "Sent Items", "Calendar") they have to wait for 1 minute before the page displays the data. These mailboxes have very little data as of now <1mb. OWA speeds up after using it for sometime, but if they close the browser window and try to login in again its back to being slow.

I have not been able to replicate the problem on my end. No issues with Outlook Anywhere. Hope this sheds some light
0
 
LVL 1

Author Comment

by:rcs81
ID: 34217983
Forgot to mention that they are external users, no one is on the local LAN.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34220111
have you run exbpa on there to see if it highlights anything?
0
 
LVL 26

Expert Comment

by:e_aravind
ID: 34259721
netsh interface tcp set global autotuninglevel=disabled (on the W2k8 servers)
0
 
LVL 1

Accepted Solution

by:
rcs81 earned 0 total points
ID: 34481800
It was a problem with our TMG servers NIC. After swapping out the NIC the problem went away
0
 
LVL 1

Author Closing Comment

by:rcs81
ID: 34514762
Faulty hardware
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
Sometimes clients can lose connectivity with the Lotus Notes Domino Server, but there's not always an obvious answer as to why it happens.   Read this article to follow one of the first experiences I had with Lotus Notes on a client's machine, my…
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question