Solved

Cannot connect to Remote Desktop on some workstations

Posted on 2010-11-26
6
448 Views
Last Modified: 2012-06-27
I cannot to several workstations on a network at a remote site. The fact that I can connect to some indicates this isn't a routing problem, or a firewall problem. The error message is the standard one you get when Remote Desktop is turned off, but I checked this setting when last visited the site, and it was on.

I can't think what the cause could be.

I'm using IPSec to tunnel to the local network and using local IPs from the DNS list.
   

0
Comment
Question by:Jason210
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 2

Accepted Solution

by:
mattsam earned 100 total points
ID: 34216378
Have your checked that the service is started on the machines,  I think its the "remote desktop service"   I assume that they are xp pro machines and dont have any extra firewall software that could be blocking the rdp port.  

Also try to telnet to them on port 3389
0
 
LVL 6

Assisted Solution

by:nipponsoul
nipponsoul earned 100 total points
ID: 34216381
Different clients (OS) use different authentications - for example in Windows 7, Remote Desktop uses Network Level Authentication.

Select "Allow connections from computers running ANY version of Remote Desktop" and see if that works ...



0
 
LVL 3

Assisted Solution

by:veaceslavz
veaceslavz earned 100 total points
ID: 34216417
Did you include the username with which you try to connect to allowed to connect remotely?
Can you connect to administrative shares on remote computer?
Which operating system you (and on remote computer) are?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Assisted Solution

by:gkhnckr
gkhnckr earned 100 total points
ID: 34216425
and please check with telnet 3389 tcp port for RDP service is on and waiting connection.
If it's not open can you ping that machines? If your answer yes please check your rdp service situations as my friends answered above.
0
 
LVL 77

Assisted Solution

by:Rob Williams
Rob Williams earned 100 total points
ID: 34222189
Some things to check:
1-try connecting using the IP of the remote computer not the computer name
2-"allow users to connect remotely to this computer" must be enabled
3-you must be a member of the remote desktop users group of the local machine (administrators are by default)
4-if the workstation is a member of a server 2000/2003 domain you will have one of the 2 following check boxes, depending on the version, on the "Terminal Services Profile" of the users profile in Active Directory. Make sure it is checked appropriately. "Deny the user permission to log on to any terminal server", or "Allow Logon to Terminal Server"
5-if XP SP2 or Server 2003 SP1 the firewall needs to be configured to allow remote connections ( I would disable for now for troubleshooting purposes)
6-makesure any other software firewalls are disabled as well (for test purposes), including Internet security suites. Symantec's sometimes needs to be uninstalled or if using Symantec Antivirus some versions have "Internet Worm Protection" which can block Remote Desktop. Try disabling that as well.
7-Verify the Remote Desktop User group has the rights to log on using Terminal Services.  Go to Control Panel | Administrative tools | Local Security Policy | Local Policies | User Rights Assignments ...make sure Remote Desktop Users is included in "allow logon through Terminal Services"  
8-The terminal Services service must be running
If you have access to the remote machine make sure it is "listening" for your connection. To do so at a command line enter (substitute port # if not using default 3389):
 netstat  -an  |find  "3389"
You should get the following result:
TCP   0.0.0.0:3389    0.0.0.0:0    listening
If not go to Start  | Run | services.msc and see if Terminal Services is started and set to automatic
9- Note also; only runs on XPpro, not XPhome
0
 
LVL 11

Author Closing Comment

by:Jason210
ID: 34456834
All good answers but none of them solved the problem. Thanks.
0

Featured Post

Space-Age Communications Transitions to DevOps

ViaSat, a global provider of satellite and wireless communications, securely connects businesses, governments, and organizations to the Internet. Learn how ViaSat’s Network Solutions Engineer, drove the transition from a traditional network support to a DevOps-centric model.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
In this article we have discussed the manual scenarios to recover data from Windows 10 through some backup and recovery tools which are offered by it.
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question