Replace function in XSLT

Hi
from xslt iam using
 <MarketValue>
            <xsl:text disable-output-escaping="yes">R </xsl:text><xsl:value-of select="format-number(MarketValue,'#,##0.00')" />
          </MarketValue>

This will give the result in the form of    R 67,373,229.85.

Now i need to replace the comma with space in the above string.
pls give me the code for the above requirement.
Ravi

i have string like
mu_ravi1Asked:
Who is Participating?
 
Geert BormansInformation ArchitectCommented:
The proper way however would be to make the space an active character by means of a named xsl:decimal-format
if you make the space the grouping seperator, you can directly use that

<?xml version="1.0" encoding="UTF-8"?>
<xsl:stylesheet 
    xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
     version="1.0">
    <xsl:decimal-format name="my-format" grouping-separator=" "/>
    <xsl:template match="test">
        <MarketValue>
            <xsl:text disable-output-escaping="yes">R </xsl:text><xsl:value-of select="format-number(MarketValue,'# ##0.00', 'my-format')" />
        </MarketValue>
    </xsl:template>
</xsl:stylesheet>

Open in new window

0
 
Geert BormansInformation ArchitectCommented:
<xsl:value-of select="format-number(MarketValue,'#,##0.00')" />
to become
<xsl:value-of select="translate(format-number(MarketValue,'#,##0.00'), ',' ' ')" />
0
 
mu_ravi1Author Commented:

it is giving errors.
iam sending my xslt file .
pls modify the xslt and send me.
---------------------------------------------------------------
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE xsl:stylesheet [
  <!ENTITY nbsp "&#160;">
]>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:xasp="urn:myextension">
  <xsl:output method="xml"/>
  <xsl:template match="/Data/PortfolioCollection">
    <GridViewData>
      <xsl:for-each select="UTPortfolio">
        <ListData>
          <FundName>
            <xsl:value-of select="xasp:GetFundMapping(FundName)" />
          </FundName>
          <FundClass>
            <xsl:value-of select="FundClass" />
          </FundClass>
          <PriceDate>
            <xsl:value-of select="xasp:ConvertDateFormat(PriceDate)" />
          </PriceDate>
          <NAV>
            R <xsl:value-of select="format-number(NAV,'# ##0.00')" />
          </NAV>
          <MarketValue>
            <xsl:text disable-output-escaping="yes">R </xsl:text><xsl:value-of select="format-number(MarketValue,'# ##0.00')" />
          </MarketValue>
          <NoOfInvestor>
            <xsl:value-of select="NoOfInvestor" />
          </NoOfInvestor>
        </ListData>
      </xsl:for-each>
    </GridViewData>
  </xsl:template>
-------------------------
pls modify the above xslt and send me .
pls it is very urgent.
Thanks
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
Geert BormansInformation ArchitectCommented:
please look carefully at the xml I sent
there is decimal-format definition, you need to copy that
    <xsl:decimal-format name="my-format" grouping-separator=" "/>
and reference it as I showed in my XSLT

I have two comments with your reply
1. You did not do what I suggested, of course there are errors
2. It would help if you told at least what the error was you are experiencing.

Please do some small effort yourself of integrating my suggestion with your code
0
 
mu_ravi1Author Commented:
Hi Gertone

hates of to ur solution.
It works perfectly.
thank u very much
0
 
Geert BormansInformation ArchitectCommented:
welcome
0
 
mu_ravi1Author Commented:
Hi Gertone

may i know ur details.
U are technically very sound.
iam from india.
iam working as programmer in india.
With Regards
Ravi
0
 
Geert BormansInformation ArchitectCommented:
you can find my contact details in my profile
http://www.experts-exchange.com/M_3538911.html

my web reference is there,
my email as well, but you need to make
[at] an "@"
and
[dot] a "."
0
 
mu_ravi1Author Commented:
excellent and amazing
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.