Exmerge on Exchange 2003 Failing to open Information Store

I am receiving an error message when trying to export emails. I used this program before and had no problems.

Does anyone have any suggestions?

[10:09:44] Error opening message store (MSEMS). Verify that the Microsoft Exchange Information Store service is running and that you have the correct permissions to log on. (0x8004011d)
[10:09:44] Errors encountered. Copy process aborted for mailbox 'A Person' ('APerson').
[10:09:44] Number of items copied from the source store for all mailboxes processed: 0
[10:09:44] Total number of folders processed in the source store: 0
[10:09:44] 0 mailboxes successfully processed. 1 mailboxes were not successfully processed. 0 non-fatal errors encountered.
[10:09:44] Process completion time: 00:00:00
mail2clkAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Tony JConnect With a Mentor Lead Technical ArchitectCommented:
Looks like the account you're using doesn't have rights to the mailbox you are running ExMerge against.

http://www.petri.co.il/grant_full_mailbox_rights_on_exchange_2000_2003.htm
0
 
mail2clkAuthor Commented:
The Administrator and Exmerge have full mailbox access.
0
 
Tony JConnect With a Mentor Lead Technical ArchitectCommented:
Hmm ok - perhaps you need to delegate control?

In Exchange System Manager, right-click the organization (for example, right-click First Organization (Exchange)), and then click Delegate control.

The Exchange Administration Delegation Wizard starts.

Click Next.

If the user account under which you run the Exchange Mailbox Merge program is not listed in the Users and groups box, and if it does not have the role of Exchange Full Administrator, click Next, add this user account with the role of Exchange Full Administrator, and then click OK.

Click Next, and then click Finish.

Quit Exchange System Manager
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
The_KirschiCommented:
Maybe you have to change the LocalisedExchangeServerServiceName in ExMerge.ini so the correct name of the information store is used. Have a look at that.
0
 
Pete LongConnect With a Mentor Technical ConsultantCommented:
>>The Administrator and Exmerge have full mailbox access.

Not be default he doesn't? unless you've manually added the rights to the admin account see my article below

Using "Exmerge" to export mailbox's to pst files
http://www.petenetlive.com/KB/Article/0000091.htm
0
 
Tony JLead Technical ArchitectCommented:
Already covered that above ;-)
0
 
ipajonesConnect With a Mentor Commented:
Normally with this sort problem it relates to the inherited deny Send As/Receive As permissions.  As explicitly defined permissions take precedence over inherited permssions make sure that when you say that your admin account has full access these are additional permissions defined at the mailstore root NOT inherited permissions.

IMPORTANT:  Don't change the inheritence of permissions though as you can run into all sorts of problems if you remove the special permissions setup/required by Exchange.

If you follow the link in Tony's post the article on Daniel Petri's site shows you the steps of how to add the required permissions I'm talking about to ensure Exmerge has the appropriate rights.  Or see the following MS KB article.

http://support.microsoft.com/kb/292509

I would also encourage you to create a security group, make your admins a member of this group and apply the above permissions to the group you've created.

--IJ
0
 
Tony JLead Technical ArchitectCommented:
Hey IPA you stalking me now? lol just joking but a very good point. You'd be surprised how often a deny creeps into Exchange (particularly 2000/2003 it would seem).
0
 
ipajonesCommented:
Tony - I'm not I promise!  Just happens to be we're answering the same question again!  Just wanted to make the point about the inheritence factor.
0
 
mail2clkAuthor Commented:
I added it in a couple of years ago. Exmerge worked fine back in Dec 2009.  Maybe the service needs restarting?
0
 
Tony JLead Technical ArchitectCommented:
A year's a long time - I would suggest checking permissions. Remember they don't always just inherit.
0
 
Tony JLead Technical ArchitectCommented:
IPA - I was only joking. You tend to find the same names crop up time and again on here by the very nature of the fact that the same people tend to be subject matter experts in the same field.

The more the merrier in my opinion - it's surprising how much you learn by answering and participating.

Welcome to EE, by the way.
0
 
ipajonesCommented:
Thanks Tony.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.