?
Solved

Edit RD Web Access (TSWeb) Default.aspx

Posted on 2010-11-26
25
Medium Priority
?
7,773 Views
Last Modified: 2012-08-13
Hi,
I am currently using the RDWeb Access with Windows Server 2008 R2 formely TSWeb. I would like to have the tick automatically checked on the option that says "I am using a private computer that complies with my organization's security policy." I know this can be done as I have seen it when searching on Google, I've come accross other peoples RDWeb pages that are available and they have them tick by default. I have attached a screenshot of the page in question. I've come to the conclusion that you will have to edit the Default.aspx wich is located in the directory %windir%\Web\RDWeb\Pages\<The Language of Your Location>\Default.aspx

Any help would be great, many thanks in advance
Default.jpg
0
Comment
Question by:bilbazafa
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 5
  • 2
  • +2
25 Comments
 
LVL 6

Expert Comment

by:fluk3d
ID: 34217235
Open IIS Manager on TS Web Access hosted Server, Go to Sites - Default Sites and TS. Under IIS Catagory Select Authentication and enable Anonymous Authentication.
0
 
LVL 15

Expert Comment

by:pcsmitpra
ID: 34217281
Hi

One possibility would be to change the CSS file so that the text does not display.  For example, try adding the following to the tswa.css file:

#WebPartManager1_TSPortalWebPart1contentPublicCheckbox
{
        display: none !important
}

This works in IE8, But need to check for your environment.
0
 

Author Comment

by:bilbazafa
ID: 34217292
In response to fluk3d

When I go into the Default Web Site there is:-
aspnet_client
RDWeb
Rpc
RpcWithCert

I've been into the RDWeb went to Authentication and changed it to Anonymous Authentication with no pravail. Am I in the correct section?
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 

Author Comment

by:bilbazafa
ID: 34217322
In response to pcsmitpra

If I did this would it also tick it as well as hide the text? As it being tick is important.

0
 
LVL 6

Expert Comment

by:fluk3d
ID: 34217341
Yes the RDWeb section is where you are changing the authentication
0
 

Author Comment

by:bilbazafa
ID: 34217353
I didnt work I'm afraid.
0
 

Author Comment

by:bilbazafa
ID: 34217399
I altered the tswa.css and it worked but it does not tick the box which is important. I there possibly some code I can add the this to tick the box?
0
 
LVL 15

Expert Comment

by:pcsmitpra
ID: 34217544
Hi

Please go through : http://207.46.16.252/en-ca/library/dd560668%28WS.10%29.aspx
I believe you need to enable the "public mode", On same page you can find which versions have this additional feature.

Thank you
0
 

Author Comment

by:bilbazafa
ID: 34221581
Yes that's what I'm asking pcsmitpra. I need to know how to have the box permanently ticked as stated above!
0
 

Author Comment

by:bilbazafa
ID: 34481120
Any one????
0
 
LVL 30

Expert Comment

by:Brad Howe
ID: 34516993
Hi,

Please take a look at my previous post for this option.

Make "This is a private computer" the default in RDWeb.
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_26475321.html?sfQueryTermInfo=1+10+30+hades666+rdweb

Cheers,
Hades666
0
 

Author Comment

by:bilbazafa
ID: 34518676
Hi hades666 thanks for getting back to me. This is very similar to what I want but I don't get this login page as I have removed it. I get the next page that is dislayed once you have entered the username and password correctly. Can you some how apply what you have done to this page above?   See the picture above.....

0
 

Author Comment

by:bilbazafa
ID: 34518686
Looks like I'm getting somewhere with user hades666, hopefully!
0
 
LVL 1

Expert Comment

by:EKSH-Tech
ID: 34800493
bilbazafa,  did you find a resolution to this issue?
0
 
LVL 30

Expert Comment

by:Brad Howe
ID: 34800773
As an FYI, I just deployed a RDWeb to my dev this morning and don't even see that in the webparts or in the code.

Very strange.

Can you attach you default.aspx please?

Hades6666
0
 
LVL 1

Expert Comment

by:EKSH-Tech
ID: 34801812
Hades666,

I too am trying to figure how out how to configure the "I am using a private computer.." checkbox to be checked by default on the remoteapp programs page (not the login page).  I have also disabled forms authentication and enabled windows authentication so my domain computers are able to bypass the login page using SSO.  I had SSO working seamless in 08 for my domain computers as end users would not be promted either at the website login or at application launch.  I am trying to reproduce this config in 08R2 and the only hickup i have is the private checkbox.  If the box is checked apps launch using SSO, if not a login promt is displayed.  I have already notified end users to make sure the box is checked but I have found the less i ask of end users the more successful the solution. Below is my default.aspx.  I would imagine you would also need to look at config.aspx?


Default.aspx
0
 

Author Comment

by:bilbazafa
ID: 34801915
EKSH-Tech,

I have done the same also and looking for the solution.

Hades666 is my Default.aspx.

Many Thanks
Default.aspx
0
 
LVL 1

Expert Comment

by:EKSH-Tech
ID: 34801966
Bilbazafa,

I did not mean to hijack your thread and honestly I had hoped you would have the answer for us all by now!  I will post pack if i find a solution.  Thanks!
0
 

Author Comment

by:bilbazafa
ID: 34801979
EKSH-Tech

That's ok I never thought you were. I just thought you'd explained it better than me so that's why I wrote that I'd done the same. But know I've never found the answer. If you do then please like you said share it with me, and I to you also.

Cheers

0
 
LVL 1

Accepted Solution

by:
EKSH-Tech earned 2000 total points
ID: 34810852
Bilbazafa,

I have found a resolution to this issue.
First off I do not believe you uploaded the correct default.aspx.  Make sure you are editing the default.aspx located in the RDWeb\Pages\en-US\ directory.  Then find the line of code;

public bool fUserAdmin = false, fConfigPage = false, bShowPublicCheckBox = false, bPrivateMode = false;

Edit the line to be;

public bool fUserAdmin = false, fConfigPage = false, bShowPublicCheckBox = false, bPrivateMode = true;

This worked for me and now my domain users are not promted for any login credentials when using the RDWeb site.  Try this out and let me know if it works for you.  If not there are a few other changes I made to my environment that I will walk you through.
0
 
LVL 1

Expert Comment

by:EKSH-Tech
ID: 34872502
Bilbazafa,

Did that work for you?
0
 

Author Closing Comment

by:bilbazafa
ID: 34872806
Perfect. Many Thanks
0

Featured Post

Introducing Priority Question

Increase expert visibility of your issues by participating in Priority Question, our latest feature for Premium and Team Account holders. Adjust the priority of your question to get emergent issues in front of subject-matter experts for help when you need it most.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The System Center Operations Manager 2012, known as SCOM, is a part of the Microsoft system center product that provides the user with infrastructure monitoring and application performance monitoring. SCOM monitors:   Windows or UNIX/LinuxNetwo…
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
Suggested Courses
Course of the Month15 days, 10 hours left to enroll

741 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question