Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1348
  • Last Modified:

Data Execution Prevention in Windows 7 Ultimate 64-bitQuestion


I disabled DEP with the Command below from the Command Prompt:
bcdedit.exe /set {current} nx AlwaysOff

Now, i can not enable DEP with the On command:
bcdedit.exe /set {current} nx AlwaysOn

The options are greyed out under System Properties.
Also, my DEP exclusions are blank.  I shoud have backed up the DEP settings some how :(
I added DEP exclussions because Windows 7 freezes Video Games.
0
xCyberFreakx
Asked:
xCyberFreakx
  • 3
2 Solutions
 
Mez4343Commented:
Did you go to the DEP tab under Perforqamnce Options and see if you can turn it back ON  thru windows GUI?
http://windows.microsoft.com/en-US/windows7/Change-Data-Execution-Prevention-settings
0
 
xCyberFreakxAuthor Commented:
yes i did
0
 
and235100Commented:
Try running "bcdedit.exe /set {current} nx OptIn" (no quotes) from an elevated cmd prompt (Start, type cmd, right-click cmd icon that appears in the start menu, choose Run as Administrator). Run the command and restart your computer. This should enable DEP after the restart.
0
 
xCyberFreakxAuthor Commented:
tried it many times and performed the restart. no joy.
0
 
xCyberFreakxAuthor Commented:
great job guys. ty
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now